Jump to content


Photo

How-to-guide: Installing Exchange 2010 SP1


  • Please log in to reply
1 reply to this topic

#1 Andersson

Andersson

    Advanced Member

  • Members
  • PipPipPip
  • 109 posts
  • Gender:Male
  • Location:Sweden
  • Interests:Exchange
    Workout
    Soccer

Posted 05 January 2011 - 06:44 PM

Published: 2011-01-05
Updated: -
Version: 1.0

Please note that this guide is designed to get you up and running in a LAB Environment as quickly as possible.
This guide is provided as is without any guarantee, if you find any errors please report them in the forums.




The purpose with this how-to-guide is to give those administrators around the world an insight in how a default/basic installation should be done.

Let's get started…



From the beginning, we have some prerequisites that need to be solved directly.
We need an administrator account which has the following permissions: domain admin, enterprise admin and schema admin.

In large organizations it's often that the Active Directory personal upgrades the schema before running the installation.
In this lab and scenario I'm emulating a small organization with a single server installation.

In the lab environment I'm using VMware Workstation and haven't sized the machine like it should be in a production environment.
On my Exchange server I have configured it with the following disks.
C: - Operating System
D: - Exchange binary's
E: - Databases
F: - Transaction Logs

I can't tell you how you should size your server(s) without knowing about the environment and the business requirements.
Here's a nice link to a TechNet article about performance; http://technet.micro...y/dd351192.aspx.
For sizing the storage there are a storage calculator provided by the MS Exchange Team that can be found here.
Article; http://msexchangetea...117.aspx.<br />File; http://msexchangetea...es/default.aspx.



I'm using Windows 2008 R2 Enterprise Edition with Exchange 2010 Standard Edition.
There is no need of using Enterprise on Windows if you aren't going to use the failover clustering (DAG in Exchange 2010).
In my case I'm going to do a post about this later so I want to use this machine in later posts.


I will not add any text about certificates in this post, I'll take it in the next part when configuring Exchange with all necessary settings.






Installing prerequisites


These 6 prerequisites need to be installed before starting the installation of Exchange, or else it will complain about them.

KB979099 (AD RMS)
http://support.micro...om/?kbid=979099

Filter Pack
http://go.microsoft..../?LinkID=191548

WCF: Enable WebHeader settings on the RST/SCT
http://code.msdn.mic...ft.com/KB982867

LockConvoy On Windows Server 2003 Post KB 971988
http://code.msdn.mic...ft.com/KB979744

Win7 rollup package (PR for QFE 810219)
http://code.msdn.mic...ft.com/KB983440

Fix for Microsoft .NET Framework 2.0 Service Pack 2
http://connect.micro...ownloadID=27977



For installing the other prerequisites there are xml file(s) that can be used.
In this case it's a single server installation and then there is a file named: exchange-typical.xml.
It's located in the scripts folder of the media.

image01.png



Start a command prompt with elevated permissions (Run as admin).

image02.png



I went into where my media was (C:\media) and scripts, there we have the Exchange-Typical.xml file.
This file should be used with the following command "ServerManagerCmd –ip Exchange-Typical.xml".
It will install all Windows prerequisites.

image03.png




Here's a screenshot how it looks like when it's finished.

image04.png




A restart is required like the prompt says above, when Windows is starting up it will complete the installation of the roles/features and prerequisites.

image05.png






Starting the installation of Exchange Server 2010 SP1


It's now time for the Exchange installation, go to the media path and right click the setup.com file and choose "Run as administrator".

image06.png



Select; Step 3 and choose "Install only languages from the DVD".

image07.png



Start the installation by pressing Step 4; Install Microsoft Exchange.

image08.png



The introduction will give you short information, press the Next button.

image09.png



Read through and select that you agree the license agreement or else you can't continue.

image10.png



I'm selecting that I don't want to report my errors since this is a lab environment.

image11.png



In this screen I'm selecting the typical installation and observe that my installation path is changed to D:\ instead of C:\ and also marking the check to
automatically install Windows Server roles and features required for Exchange Server.

image12.png



It's time to set the Exchange Organization name, I'm naming it WindowsNoob and also I'm not choosing the option to split the permissions
since this is a lab environment and not a large organization with those requirements.

image13.png



I have selected to not support older Outlook versions than Outlook 2007, in this case we don't need public folders. If Outlook 2003 is used
we would per automatic get a public folder database.

image14.png



If this server is going to be internet faced, with that means if it should be directly published to internet for Outlook Web App, ActiveSync and Outlook Anywhere.
I've selected that it should be facing internet with the address; owa.domain.com.

image15.png



On this screen I'm selecting that I don't want to join the program right now.

image16.png



This is what happens if you haven't installed the necessary prerequisites :-)

image17.png



Continuing the installation, the warning is just telling me that it will prepare the Active Directory Schema for Exchange 2010 SP1.
Press Install to begin the installation.

image18.png



The installation is successfully completed. It's time for a reboot.

image19.png



In the next post I will go through how to configure it.



Sources:

http://technet.micro...y/bb125224.aspx

Microsoft Community Contributor Award 2011/2012 - MCITP Exchange 2010
My linkedin profile at > http://se.linkedin.c...sson/10/b4a/225
Follow me on Twitter > @jonand82
Follow windowsnoob.com on Twitter > @windowsnoob
Check my blog at > http://www.testlabs.se/blog


#2 deheugden

deheugden

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 08 April 2014 - 06:43 PM

How did you conou configure the vmware networkcards? Or didnt you install your lab In vmware workstation? I did that , tried the networkcard with bridged and nat but that doenst seem to work, exchage member cannot connect to the dc. So i have to change both into local host and that means i cannot configure exchange to communicate with outside.

2nd, my isp hosts my dns, o thats another tricky thing. What shoul i change at my isp dns and how should i configure my test environment dns.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Locations of visitors to this page