Jump to content


Sign in to follow this  
mose@CP

Multicast WDS over cisco network

Recommended Posts

I need some serious help. I can deploy my images fine, but they are unicast/broadcast. I am trying to setup a multicast and am having no luck. I followed the guide here to setup the multicast session on the WDS server. As far as I can tell it is setup correctly, but it does not see the clients. Under properties for the Multicast IP address it is setup to get the ip address from the DHCP server. No settings have been altered on the DHCP server in regards to multicasting, I am not sure if any changes need to be made.

 

there are 3 cisco 3550 and 1 cisco 3750 switches between the virtual server that is hosting the WDS server and the clients. IGMP snooping is enabled on all switches. The correct VLANs and all ports are selected under the Multicast Router Ports tab. Fast port is enabled on the corresponding ports on all switches. I can let you know the other settings if it is necessary.

 

I have a large number of systems that need to have an image deployed to them and it is currently killing the bandwidth and taking forever. Please any help would be appreciated. Thank you.

Share this post


Link to post
Share on other sites

try changing the addresses used by WDS from the default 239.X.X.X to 224.1.X.X to be compatible with the default cisco configuration. Restart the WDS service after making the change.

 

cheers

anyweb

Share this post


Link to post
Share on other sites

I had to update the IOS on my Cisco routers with the IP Services IOS.

 

try changing the addresses used by WDS from the default 239.X.X.X to 224.1.X.X to be compatible with the default cisco configuration. Restart the WDS service after making the change.

 

cheers

anyweb

Share this post


Link to post
Share on other sites

and did that resolve the problem, can you go into more detail to help others that may have this issue ?

Share this post


Link to post
Share on other sites

and did that resolve the problem, can you go into more detail to help others that may have this issue ?

 

Problem was not fixed. Multicast was not functioning correctly over network. Went to a different setup to get around the problem.

Share this post


Link to post
Share on other sites

 

mose@CP - what was the different setup you went to? Was it a Multicast solution?

You need IGMP snooping enabled on all access switches, and multicast routing and PIM (IP services IOS) enabled on all L3 switches. Some switches will have PIM/mcast and IGMP snooping on them depending on your topology.

 

So imagine a hub and spoke topology. Your core switch and WDS/SCCM server resides in the hub. And your core switch Switch A is connected to Switch B in another building on your campus. You route between Switch A and Switch B.

 

In Switch A and B, ip multicast-routing distributed has to be enabled globally. ip pim sparse-dense mode is enabled per routed/VLAN interface. Verify with show ip pim neighbor and show ip pim interface. This is like show cdp neighbor for multicast routing. You should see your directly connected neighbor with the 1st command, and all interfaces with pim enabled with the 2nd.

 

Now Switch B connects to switches C, D, and E in this building to provide access to hosts. Switches C, D & E need ip igmp snooping enabled globally. Verify with show ip igmp snooping mrouter. This will show the port that connects back to Switch B. Show ip igmp groups will show multicast groups that clients have joined. Even without an OSD running, you'll likely see hosts like network printers joining groups because of default settings.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...