Jump to content


Sign in to follow this  
mqh7

Dell e6420 fails on MDT package

Recommended Posts

Our CM2012 OSD works for all of our Dell hardware except the Dell E6420 laptop. In have two E6420's at my desk and both fail in the same way at the same time. You PXE boot up and it prompts you for the DP password. Then it prompts you to choose a TS. We only have one TS so I pick that and it does resolve all packages. But then it does on the 3rd step within the TS. "Use Toolkit Package" This is our MDT toolkit package that works on all Dell hardware except this E6420.

 

 

Here is part of the SMSTS.LOG

 

I know this package is there and it does work since all other hardware uses it. Why would it not work only on this one type of hardware?

 

 

 

 

Set a global environment variable _SMSTSLogPath=X:\WINDOWS\TEMP\SMSTSLog TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Expand a string: smsswd.exe /run:MH10003F cscript.exe Scripts\ZTISCCM.wsf TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Expand a string: TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Command line for extension .exe is "%1" %* TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Set command line: smsswd.exe /run:MH10003F cscript.exe Scripts\ZTISCCM.wsf TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Start executing the command line: smsswd.exe /run:MH10003F cscript.exe Scripts\ZTISCCM.wsf TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
!--------------------------------------------------------------------------------------------! TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Expand a string: WinPEandFullOS TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Executing command line: smsswd.exe /run:MH10003F cscript.exe Scripts\ZTISCCM.wsf TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
[ smsswd.exe ] InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
PackageID = 'MH10003F' InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
BaseVar = '', ContinueOnError='' InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
ProgramName = 'cscript.exe Scripts\ZTISCCM.wsf' InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
SwdAction = '0001' InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
ResolveSource flags: 0x00000000 InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
SMSTSPersistContent: . The content for package MH10003F will be persisted InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
DownloadOnDemand flag is true. Attempting to download content locally for Package MH10003F. InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
nPos != String::npos, HRESULT=800700a1 (e:\nts_sccm_release\sms\framework\core\ccmcore\path.cpp,101) InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
RecursiveCreatePath(sPath.substr(0, nPos), psa), HRESULT=800700a1 (e:\nts_sccm_release\sms\framework\core\ccmcore\path.cpp,104) InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
RecursiveCreatePath(sPath.substr(0, nPos), psa), HRESULT=800700a1 (e:\nts_sccm_release\sms\framework\core\ccmcore\path.cpp,104) InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
RecursiveCreatePath( sNormalizedPath, psa ), HRESULT=800700a1 (e:\nts_sccm_release\sms\framework\core\ccmcore\path.cpp,159) InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
DownloadContentLocally (pszSource, sSourceDirectory, dwFlags, hUserToken, mapNetworkAccess), HRESULT=800700a1 (e:\nts_sccm_release\sms\framework\tscore\resolvesource.cpp,3273) InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
TS::Utility::ResolveSource (pszPkgID, sPath, 0, hUserToken, mapNetworkAccess), HRESULT=800700a1 (e:\nts_sccm_release\sms\client\osdeployment\installsoftware\runcommandline.cpp,399) InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
Failed to resolve the source for SMS PKGID=MH10003F, hr=0x800700a1 InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
cmd.Execute(pszPkgID, sProgramName, dwCmdLineExitCode), HRESULT=800700a1 (e:\nts_sccm_release\sms\client\osdeployment\installsoftware\main.cpp,372) InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
Install Software failed to run command line, hr=0x800700a1 InstallSoftware 7/9/2014 6:21:59 AM 668 (0x029C)
Process completed with exit code 2147942561 TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
!--------------------------------------------------------------------------------------------! TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Failed to run the action: Use Toolkit Package.
The specified path is invalid. (Error: 800700A1; Source: Windows) TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
MP server http://MGH-SCCM12-01.acme.org. Ports 80,443. CRL=false. TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Setting authenticator TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Set authenticator in transport TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Sending StatusMessage TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Setting message signatures. TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Setting the authenticator. TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
CLibSMSMessageWinHttpTransport::Send: URL: MGH-SCCM12-01.acme.org:80 CCM_POST /ccm_system/request TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Request was successful. TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Set a global environment variable _SMSTSLastActionRetCode=-2147024735 TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Set a global environment variable _SMSTSLastActionSucceeded=false TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Clear local default environment TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Let the parent group (MDT PreReq) decides whether to continue execution TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
The execution of the group (MDT PreReq) has failed and the execution has been aborted. An action failed.
Operation aborted (Error: 80004004; Source: Windows) TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Failed to run the last action: Use Toolkit Package. Execution of task sequence failed.
The specified path is invalid. (Error: 800700A1; Source: Windows) TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
MP server http://MGH-SCCM12-01.acme.org. Ports 80,443. CRL=false. TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Setting authenticator TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Set authenticator in transport TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Sending StatusMessage TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Setting message signatures. TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Setting the authenticator. TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
CLibSMSMessageWinHttpTransport::Send: URL: MGH-SCCM12-01.acme.org:80 CCM_POST /ccm_system/request TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Request was successful. TSManager 7/9/2014 6:21:59 AM 1076 (0x0434)
Execution::enExecutionFail != m_eExecutionResult, HRESULT=80004005 (e:\nts_sccm_release\sms\client\tasksequence\tsmanager\tsmanager.cpp,923) TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Task Sequence Engine failed! Code: enExecutionFail TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
**************************************************************************** TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Task sequence execution failed with error code 80004005 TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Cleaning Up. TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Removing Authenticator TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
shKey.DeleteValue( c_szRegValue_SecurityToken ), HRESULT=80070002 (e:\nts_sccm_release\sms\framework\ccmutillib\ccmutillib.cpp,1660) TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
!sTSMDataPath.empty(), HRESULT=80070002 (e:\nts_sccm_release\sms\framework\tscore\resolvesource.cpp,1425) TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
There is no TSM local data path being set TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Successfully unregistered Task Sequencing Environment COM Interface. TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Command line for extension .exe is "%1" %* TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Set command line: "X:\sms\bin\i386\TsProgressUI.exe" /Unregister TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Executing command line: "X:\sms\bin\i386\TsProgressUI.exe" /Unregister TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
==========[ TsProgressUI started in process 1588 ]========== TsProgressUI 7/9/2014 6:37:00 AM 1584 (0x0630)
Command line: "X:\sms\bin\i386\TsProgressUI.exe" /Unregister TsProgressUI 7/9/2014 6:37:00 AM 1584 (0x0630)
Unregistering COM classes TsProgressUI 7/9/2014 6:37:00 AM 1584 (0x0630)
Unregistering class objects TsProgressUI 7/9/2014 6:37:00 AM 1584 (0x0630)
Shutdown complete. TsProgressUI 7/9/2014 6:37:00 AM 1584 (0x0630)
Process completed with exit code 0 TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Successfully unregistered TS Progress UI. TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
g_TSManager.Run(), HRESULT=80004005 (e:\nts_sccm_release\sms\client\tasksequence\tsmanager\tsmanager.cpp,766) TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
::RegQueryValueExW(hSubKey, szReg, NULL, NULL, NULL, &dwSize), HRESULT=80070002 (e:\nts_sccm_release\sms\framework\tscore\utils.cpp,811) TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
RegQueryValueExW is unsuccessful for Software\Microsoft\SMS\Task Sequence, SMSTSEndProgram TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
GetTsRegValue() is unsuccessful. 0x80070002. TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
End program: TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Error Task Sequence Manager failed to execute task sequence. Code 0x80004005 TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Sending error status message TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
MP server http://MGH-SCCM12-01.acme.org. Ports 80,443. CRL=false. TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Setting authenticator TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Set authenticator in transport TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Sending StatusMessage TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Setting message signatures. TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Setting the authenticator. TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
CLibSMSMessageWinHttpTransport::Send: URL: MGH-SCCM12-01.acme.org:80 CCM_POST /ccm_system/request TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Request was successful. TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Finalize logging request ignored from process 792 TSManager 7/9/2014 6:37:00 AM 1076 (0x0434)
Process completed with exit code 2147500037 TSPxe 7/9/2014 6:37:00 AM 556 (0x022C)
Task Sequence Manager returned code 0x80004005 TSPxe 7/9/2014 6:37:00 AM 556 (0x022C)
ThreadToResolveAndExecuteTaskSequence returned code 0x00000000 TSPxe 7/9/2014 6:37:00 AM 1192 (0x04A8)
ResolveProgressPage::OnWizardNext() TSPxe 7/9/2014 6:37:00 AM 1192 (0x04A8)
Activating Finish Page. TSPxe 7/9/2014 6:37:00 AM 1192 (0x04A8)
Exiting with return code 0x00000000 TSPxe 7/9/2014 6:37:00 AM 1192 (0x04A8)
Execution complete. TSBootShell 7/9/2014 6:37:01 AM 772 (0x0304)
hMap != 0, HRESULT=80070002 (e:\nts_sccm_release\sms\framework\tscore\environmentscope.cpp,493) TSBootShell 7/9/2014 6:37:01 AM 772 (0x0304)
m_pGlobalScope->open(), HRESULT=80070002 (e:\nts_sccm_release\sms\framework\tscore\environmentlib.cpp,335) TSBootShell 7/9/2014 6:37:01 AM 772 (0x0304)
this->open(), HRESULT=80070002 (e:\nts_sccm_release\sms\framework\tscore\environmentlib.cpp,553) TSBootShell 7/9/2014 6:37:01 AM 772 (0x0304)
::RegQueryValueExW(hSubKey, szReg, NULL, NULL, NULL, &dwSize), HRESULT=80070002 (e:\nts_sccm_release\sms\framework\tscore\utils.cpp,811) TSBootShell 7/9/2014 6:37:01 AM 772 (0x0304)
RegQueryValueExW is unsuccessful for Software\Microsoft\SMS\Task Sequence, SMSTSEndProgram TSBootShell 7/9/2014 6:37:01 AM 772 (0x0304)
GetTsRegValue() is unsuccessful. 0x80070002. TSBootShell 7/9/2014 6:37:01 AM 772 (0x0304)
End program: TSBootShell 7/9/2014 6:37:01 AM 772 (0x0304)
Finalizing logging from process 764 TSBootShell 7/9/2014 6:37:01 AM 772 (0x0304)
Finalizing logs to root of first available drive TSBootShell 7/9/2014 6:37:01 AM 772 (0x0304)
Successfully finalized logs to X:\SMSTSLog TSBootShell 7/9/2014 6:37:01 AM 772 (0x0304)
Cleaning up task sequencing logging configuration. TSBootShell 7/9/2014 6:37:01 AM 772 (0x0304)

Share this post


Link to post
Share on other sites


Did you ever find a solution for this issue?

I am having the exact same issue with an HP EliteBook Folio 9480m. On 45+ other models I support, the Package I am calling from a Task in my TS executes successfully. However, on the HP EliteBook Folio 9480M, it fails. The Task runs a CMD-Line (Name.HTA) ... that's it ... it just calls an HTA.

 

I suspect it may have something to do with the WinPE 3.0 x86 Mass Storage Driver, but I am not sure.

 

Update (2014-11-19):

The 9480M has a C:\ drive, but there is no C:\_SMSTaskSequence folder ... therefore, the Packages cannot copy the source files locally. My TS errs-out with a 0x800700A1 error. I have tried updating my BOOT.wim with a more recent version of the iaStorAC.inf (Intel® Desktop/Workstation/Server Express Chipset SATA RAID Controller), but that has proven not to be successful.

 

Guess I am still looking for the correct Mass Storage Driver for WinPE 3.0 x86.

Share this post


Link to post
Share on other sites

Hey guys,

 

any luck on this issue?

 

We also have the same issue the HP Folio 9480m's as well. However, you should find if you use another HDD from an older/different model, it will image fine. This makes me think that it very well could be a mass storage driver as you're suspecting, however it's not too good that you can't find the right one. Did you ever find another INF file to inject that would work?

 

thanks

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...