Jump to content


bennettjd

Install All Software after OSD is finished

Recommended Posts

Does anyone know how to kick off all the Software App Installs after a OSD TS is run?

 

Here is the scenario

1. The machine is apart of say 3 different collections and software is deployed to the collections as required.

2. The machine gets added to a 4th collection to image (from ts).

3. Machine is imaged with OS and base software

4. Right after I want the software assigned by those 3 collections to start installing with no interaction.

 

Why.

Because i have 1000 laptops in different carts that have different apps and want all the assigned apps to be installed before they get put back in the cart.

Share this post


Link to post
Share on other sites


Hi Peter,

 

thanks for sharing.

Unfortunately the script is not returning the "true" collection memberships for the client. Exclusions are obviously not saved in SMS_FullCollectionMembership.

 

OK, Forget about the last line <_< Just thanks for your work. Someone just deleted my Test-Clients exclusion collection.

Share this post


Link to post
Share on other sites

Thanks Peter van der Woude

This is right what I was looking for and almost just a month after you posted that.

 

A question. I am trying to figure out to have the container to recuse down. Or here is my scenario.

Format he root of Device collections I have a folder called "Addon Apps"

Below that I have Vendors of software. Like "Adobe", "Microsoft", "Autodesk", ect....

This way it is organized the same way as how i store the install files on my file server.

 

With the command '$ContainerNodeId = (Get-WmiObject -ComputerName $SiteServer -Class SMS_ObjectContainerNode -Namespace root/SMS/site_$SiteCode -Filter "Name='$Container' and ObjectTypeName='SMS_Collection_Device'").ContainerNodeId'

 

If the collection is at the "Addon Apps" it shows on the screen to be listed.

If they are in the "Adobe" or any of the other folders underneath they don't show "Skip applications" but writes nothing. This is while using the -Container "Addon Apps"

 

If I change the (-Container "Addon Apps") to (-Container "Adobe") it shows "Skip applications" It seems to only work with the root container or folder. Is this supposto or is there something else that i can change to get this to filter through.

Share this post


Link to post
Share on other sites

You could also remove the whole containernodeID part, if it's only bothering. The only reason I putted it in there is to make the search area a bit smaller, but I can imagine that it's not always helpfull.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...