Jump to content


Recommended Posts

Hey,

I'm hoping someone can point me in the right direction.

 

 

I'm having an issue in getting my application pool identity cmWebSvc to have enough permissions to query the SCCM SQL database.

 

If I use my CMAdmin account the web service returns results as expected.

 

This is how I currently have it configured but it doesn't seem to be enough..

 

 

5jDPbs4.png

 

Could anyone shed some light?

 

Thanks!

Share this post


Link to post
Share on other sites

Hi Garth,

Sorry that was a bit vague!

 

I'm using Maik Koster's Web Services version 7.3. The MDT.asmx and AD.asmx pages functions run fine with the permissions specified.

 

No, I haven't configured any RBA in SCCM. Only SQL permissions directly on the database.

 

A sample query would be: Select * from sms_tasksequencepackage using the GetTaskSequences function.

 

The funny thing is I can log into the database via SQL management studio a run the query from there no problem ?!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...