Jump to content


Sign in to follow this  
P3nnyw1se

fail to detect by registry after deployment

Recommended Posts

this is simple, I push out an application, an exe file.
And of course I need to create a detection method.

In this example I'm not able to use any file, as the versions don't differentiate on files,
and I need to be able to tell different versions apart.

 

So instead I turne to registry, there is a value in there that lets me differentiate versions.
Here is what I do ->

 

okpq3n.jpg

 

I confirm that the registry exists after installation, but it fails detecting the program anyway.
So basicly the deployment works, but it can't see this registry.

Why?, the path is correct.. I've tried using both the flag in '32'bit and without.

Share this post


Link to post
Share on other sites

Update: Seems to be a security issue, I'm not able to connect to computers trying to reach their registry, but I'm very much able to connect to their drives.
thats a problem, because I simply can't differentiate on the files.


Update: Okay its definetly a security issue, I dont seem to have permission to go into a domain computers registry.

So New Question!!
How do I allow SCCM access to the devices registry?
I dont care how I do it, if its through GPO etc. but whats do I need to change?

Share this post


Link to post
Share on other sites

I'm assuming this is the problem.
because when I wanna browse a detection method, I'm able to connect to machines going to the folders.
but I'm not able to connect to any machines on my domain if I pick registry as source.
furthermore when I add a registry as my detection method by hand.. it just doesn't Work.

can I shomehow check configMgr has the access it needs?




Share this post


Link to post
Share on other sites

You have probably not enabled remote registry on your machines. That would explain why you cannot connect to your clients registry from the console.

Share this post


Link to post
Share on other sites

and where do I set that? .. I've been browsing through Administration settings and can't find client registry allowance anywhere

Share this post


Link to post
Share on other sites

You can enable the remote registry service for the endpoints you're interested in via GPO, if that's suitable for your needs.

 

If you want to just do a quck check on a system or two remotely, running 'sc \\targetName start remoteRegistry' should suffice.

 

As Peter said, though - you shouldn't need to do this for CM to be able to check. Enabling remote registry will allow you to connect from elsewhere, e.g. your workstation with the proper credentials, but the CM client itself is local, and shouldn't be effected by remote registry being turned off

Share this post


Link to post
Share on other sites

well I simply had to give up on it.. I can't look in the registry of the machines using detection methods, but I got full access on all accounts.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...