Jump to content


Sign in to follow this  
kkonovalov

Trying to add OU selection to the CM2012 Bitlocker FrontEnd HTA

Recommended Posts

Has anyone had luck adding OU selection to the CM2012 Bitlocker FrontEnd HTA? I have been trying for some time now without luck.

I have a drop down with multiple selections which link to this code below to pass the variable over. I also add options in my apply network settings which is show in the attached image.

 

I have this:

If ADOU.value = "1" Then
oTSEnvironment("swn_ADOU") = "Administrative"
'msgbox("LDAP://OU=Administrative,OU=Workstations,DC=online,DC=com: " & oTSEnvironment("swn_ADOU"))'
ElseIf ADOU.value = "2" Then
oTSEnvironment("swn_ADOU") = "Developement"
'msgbox("LDAP://OU=Development,OU=Workstations,DC=online,DC=com: " & oTSEnvironment("swn_ADOU"))'
ElseIf ADOU.value = "3" Then
oTSEnvironment("swn_ADOU") = "External"
'msgbox("LDAP://OU=External,OU=Workstations,DC=online,DC=com: " & oTSEnvironment("swn_ADOU"))'
ElseIf ADOU.value = "4" Then
oTSEnvironment("swn_ADOU") = "IT"
'msgbox("LDAP://OU=IT,OU=Workstations,DC=online,DC=com: " & oTSEnvironment("swn_ADOU"))'
ElseIf ADOU.value = "5" Then
oTSEnvironment("swn_ADOU") = "Restricted"
'msgbox("LDAP://OU=Restricted,OU=Workstations,DC=online,DC=com: " & oTSEnvironment("swn_ADOU"))'
ElseIf ADOU.value = "5" Then
oTSEnvironment("swn_ADOU") = "Sales"
'msgbox("LDAP://OU=Sales,OU=Workstations,DC=online,DC=com: " & oTSEnvironment("swn_ADOU"))'
ElseIf ADOU.value = "5" Then
oTSEnvironment("swn_ADOU") = "Service Computers"
'msgbox("LDAP://OU=Service_Computers,OU=Workstations,DC=online,DC=com: " & oTSEnvironment("swn_ADOU"))'
End If

post-27906-0-73265900-1420733030_thumb.png

Share this post


Link to post
Share on other sites


did you edit the hta/javascript backend too ? what happens when you select an ou, did you confirm that it's set before the task sequence starts

Share this post


Link to post
Share on other sites

I think my java backend is the problem.. How do I confirm it is being set before the task sequence starts? I get an error that there is a problem with the task sequence and it has to shut down. If I continue to start windows no domain is joined.

Share this post


Link to post
Share on other sites

simply monitor the smsts.log and review the success or failure of the step setting the variable, also check the dumpvars step, it allows you to view variables that are set in winpe.

 

to do all this, use the pause functionality built into the task sequence

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...