Jump to content


Arcuss88

ConfigMgr Client Setup fails during OSD on Win7

Recommended Posts

I am trying to build support for additional models into my Task Sequence and feel this model is fighting me the whole way. I have been able to identify the drivers required for this desktop and have been able to confirm that my SCCM Driver Package is installing all devices correctly. With that said though I am getting an error during the installation of the SCCM Client only on this model. The same WIM is used on another model without issue. With all that being said here is what I'm seeing.

 

WIM is applied, Driver Package is correctly selected and applied, the "Setup Windows and ConfgMgr" task is run and copies the required files locally. The machine reboots and the "Setup Windows and ConfgMgr" task continues for about 2 secs, then exits, the machine reboots again and instead of continuing the Task Sequence it boots into the Windows 7, WIM only.

 

Below is a sample of the ccmsetup.log

<![LOG[==========[ ccmsetup started in process 2540 ]==========]LOG]!><time="12:03:00.785+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:9437">
<![LOG[Running on platform X64]LOG]!><time="12:03:00.925+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="util.cpp:1837">
<![LOG[Launch from folder C:\_SMSTaskSequence\OSD\DEV00018\]LOG]!><time="12:03:00.925+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:721">
<![LOG[CcmSetup version: 5.0.7958.1000]LOG]!><time="12:03:00.925+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:727">
<![LOG[Could not create WMI locator class (80040154)]LOG]!><time="12:03:01.112+480" date="01-09-2015" component="ccmsetup" context="" type="3" thread="2544" file="wminamespace.cpp:264">
<![LOG[CheckAndLogOSInformation failed with 0x80040154]LOG]!><time="12:03:01.112+480" date="01-09-2015" component="ccmsetup" context="" type="2" thread="2544" file="util.cpp:1938">
<![LOG[Ccmsetup command line: "C:\_SMSTaskSequence\OSD\DEV00018\ccmsetup.exe" /useronly /source:C:\_SMSTaskSequence\OSD\DEV00018 /config:MobileClient.TCF /status:632]LOG]!><time="12:03:01.143+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:3590">
<![LOG[Command line parameters for ccmsetup have been specified.  No registry lookup for command line parameters is required.]LOG]!><time="12:03:01.143+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:3775">
<![LOG[Command line: "C:\_SMSTaskSequence\OSD\DEV00018\ccmsetup.exe" /useronly /source:C:\_SMSTaskSequence\OSD\DEV00018 /config:MobileClient.TCF /status:632]LOG]!><time="12:03:01.143+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:3776">
<![LOG[Copying config file from C:\_SMSTaskSequence\OSD\DEV00018\MobileClient.TCF to folder C:\WINDOWS\ccmsetup\. Return result: 0x0]LOG]!><time="12:03:01.190+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:4173">
<![LOG[SslState value: 224]LOG]!><time="12:03:01.190+480" date="01-09-2015" component="ccmsetup" context="" type="0" thread="2544" file="ccmsetup.cpp:4425">
<![LOG[CCMHTTPPORT:    80]LOG]!><time="12:03:01.190+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:8617">
<![LOG[CCMHTTPSPORT:    443]LOG]!><time="12:03:01.190+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:8632">
<![LOG[CCMHTTPSSTATE:    0]LOG]!><time="12:03:01.190+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:8650">
<![LOG[CCMHTTPSCERTNAME:    ]LOG]!><time="12:03:01.190+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:8668">
<![LOG[FSP:    ]LOG]!><time="12:03:01.190+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:8720">
<![LOG[CCMFIRSTCERT:    1]LOG]!><time="12:03:01.190+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:8778">
<![LOG[Config file:      C:\WINDOWS\ccmsetup\MobileClientUnicode.tcf]LOG]!><time="12:03:01.284+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:4539">
<![LOG[Retry time:       10 minute(s)]LOG]!><time="12:03:01.284+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:4540">
<![LOG[MSI log file:     C:\WINDOWS\ccmsetup\Logs\client.msi.log]LOG]!><time="12:03:01.284+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:4541">
<![LOG[MSI properties:    INSTALL="ALL" PATCH="C:\_SMSTASKSEQUENCE\OSD\DEV00018\HOTFIXES\CLIENT\X64\CONFIGMGR2012AC-R2-KB2905002-X64.MSP" SMSPROVISIONINGMODE="1" SMSSITECODE="USD" CCMHTTPPORT="80" CCMHTTPSPORT="443" CCMHTTPSSTATE="0" CCMFIRSTCERT="1"]LOG]!><time="12:03:01.284+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:4542">
<![LOG[Source List:]LOG]!><time="12:03:01.284+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:4550">
<![LOG[                  C:\_SMSTaskSequence\OSD\DEV00018]LOG]!><time="12:03:01.284+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:4566">
<![LOG[MPs:]LOG]!><time="12:03:01.284+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:4569">
<![LOG[                  None]LOG]!><time="12:03:01.284+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:4572">
<![LOG[Could not create WMI locator class (80040154)]LOG]!><time="12:03:01.284+480" date="01-09-2015" component="ccmsetup" context="" type="3" thread="2544" file="wminamespace.cpp:264">
<![LOG[No version of the client is currently detected.]LOG]!><time="12:03:01.284+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:2748">
<![LOG[Failed to create CLSID_CTaskScheduler instance (0x80040154).]LOG]!><time="12:03:01.284+480" date="01-09-2015" component="ccmsetup" context="" type="3" thread="2544" file="wintask.cpp:600">
<![LOG[Updated security on object C:\WINDOWS\ccmsetup\.]LOG]!><time="12:03:01.409+480" date="01-09-2015" component="ccmsetup" context="" type="0" thread="2544" file="ccmsetup.cpp:9281">
<![LOG[A Fallback Status Point has not been specified.  Message with STATEID='100' will not be sent.]LOG]!><time="12:03:01.409+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:9763">
<![LOG[Downloading file C:\_SMSTaskSequence\OSD\DEV00018\ccmsetup.exe]LOG]!><time="12:03:02.423+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:5685">
<![LOG[Downloading C:\_SMSTaskSequence\OSD\DEV00018\ccmsetup.exe to C:\WINDOWS\ccmsetup\ccmsetup.exe]LOG]!><time="12:03:02.423+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:5769">
<![LOG[File download 16% complete (262144 of 1614520 bytes).]LOG]!><time="12:03:02.439+480" date="01-09-2015" component="ccmsetup" context="" type="0" thread="2544" file="ccmsetup.cpp:9185">
<![LOG[File download 32% complete (524288 of 1614520 bytes).]LOG]!><time="12:03:02.439+480" date="01-09-2015" component="ccmsetup" context="" type="0" thread="2544" file="ccmsetup.cpp:9185">
<![LOG[File download 48% complete (786432 of 1614520 bytes).]LOG]!><time="12:03:02.439+480" date="01-09-2015" component="ccmsetup" context="" type="0" thread="2544" file="ccmsetup.cpp:9185">
<![LOG[File download 64% complete (1048576 of 1614520 bytes).]LOG]!><time="12:03:02.439+480" date="01-09-2015" component="ccmsetup" context="" type="0" thread="2544" file="ccmsetup.cpp:9185">
<![LOG[File download 81% complete (1310720 of 1614520 bytes).]LOG]!><time="12:03:02.439+480" date="01-09-2015" component="ccmsetup" context="" type="0" thread="2544" file="ccmsetup.cpp:9185">
<![LOG[File download 97% complete (1572864 of 1614520 bytes).]LOG]!><time="12:03:02.439+480" date="01-09-2015" component="ccmsetup" context="" type="0" thread="2544" file="ccmsetup.cpp:9185">
<![LOG[File download 100% complete (1614520 of 1614520 bytes).]LOG]!><time="12:03:02.439+480" date="01-09-2015" component="ccmsetup" context="" type="0" thread="2544" file="ccmsetup.cpp:9185">
<![LOG[Download complete.]LOG]!><time="12:03:02.439+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:5867">
<![LOG[CreateInstance of CLSID_BackgroundCopyManager failed with 80040154. Unable to check BITS version]LOG]!><time="12:03:03.688+480" date="01-09-2015" component="ccmsetup" context="" type="3" thread="2544" file="util.cpp:1319">
<![LOG[This operating system does not contain the correct version of BITS. BITS 2.5 or later is required.]LOG]!><time="12:03:03.688+480" date="01-09-2015" component="ccmsetup" context="" type="3" thread="2544" file="ccmsetup.cpp:1957">
<![LOG[A Fallback Status Point has not been specified.  Message with STATEID='321' will not be sent.]LOG]!><time="12:03:03.688+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:9763">
<![LOG[Deleted file C:\WINDOWS\ccmsetup\ccmsetup.exe.download]LOG]!><time="12:03:03.688+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:9493">
<![LOG[CcmSetup failed with error code 0x80040154]LOG]!><time="12:03:03.688+480" date="01-09-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:10879">

The thing that is bothering me is the "This operating system does not contain the correct version of BITS. BITS 2.5 or later is required." line. This makes absolutely NO sense, the OS is Windows 7 SP1, the same WIM runs perfectly fine on VMs and at least one other physical model.

 

Any ideas would be helpful as I'm at a complete loss on this one.

 

smsts.log

<![LOG[Executing C:\_SMSTaskSequence\OSD\DEV00018\ccmsetup.exe /useronly /source:C:\_SMSTaskSequence\OSD\DEV00018 /config:MobileClient.TCF /status:632]LOG]!><time="12:02:57.228+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="installclient.cpp:1084">
<![LOG[Command line for extension .exe is "%1" %*]LOG]!><time="12:02:57.228+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="commandline.cpp:228">
<![LOG[Set command line: "C:\_SMSTaskSequence\OSD\DEV00018\ccmsetup.exe" /useronly /source:C:\_SMSTaskSequence\OSD\DEV00018 /config:MobileClient.TCF /status:632]LOG]!><time="12:02:57.228+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="commandline.cpp:731">
<![LOG[Executing command line: "C:\_SMSTaskSequence\OSD\DEV00018\ccmsetup.exe" /useronly /source:C:\_SMSTaskSequence\OSD\DEV00018 /config:MobileClient.TCF /status:632]LOG]!><time="12:02:57.228+480" date="01-09-2015" component="OSDSetupHook" context="" type="1" thread="2396" file="commandline.cpp:827">
<![LOG[Launching command shell.]LOG]!><time="12:02:59.115+480" date="01-09-2015" component="OSDSetupHook" context="" type="1" thread="2484" file="debugwindow.cpp:202">
<![LOG[Windows station: WinSta0]LOG]!><time="12:02:59.115+480" date="01-09-2015" component="OSDSetupHook" context="" type="1" thread="2484" file="utils.cpp:43">
<![LOG[Desktop: Default]LOG]!><time="12:02:59.115+480" date="01-09-2015" component="OSDSetupHook" context="" type="1" thread="2484" file="utils.cpp:62">
<![LOG[executing command: C:\WINDOWS\system32\cmd.exe /k]LOG]!><time="12:02:59.115+480" date="01-09-2015" component="OSDSetupHook" context="" type="1" thread="2484" file="debugwindow.cpp:63">
<![LOG[executed command: C:\WINDOWS\system32\cmd.exe /k]LOG]!><time="12:02:59.115+480" date="01-09-2015" component="OSDSetupHook" context="" type="1" thread="2484" file="debugwindow.cpp:80">
<![LOG[Process completed with exit code 1]LOG]!><time="12:03:03.813+480" date="01-09-2015" component="OSDSetupHook" context="" type="1" thread="2396" file="commandline.cpp:1123">
<![LOG[FALSE, HRESULT=80004005 (e:\nts_sccm_release\sms\client\osdeployment\osdgina\installclient.cpp,1151)]LOG]!><time="12:03:03.813+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="installclient.cpp:1151">
<![LOG[Client installation failed, code 1]LOG]!><time="12:03:03.813+480" date="01-09-2015" component="OSDSetupHook" context="" type="3" thread="2396" file="installclient.cpp:1151">
<![LOG[   Setting URL = http://#Server#.#Server#.com, Ports = 80,443, CRL = false]LOG]!><time="12:03:03.813+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="utils.cpp:6143">
<![LOG[   Setting Server Certificates.]LOG]!><time="12:03:03.813+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="utils.cpp:6171">
<![LOG[   Setting Authenticator.]LOG]!><time="12:03:03.813+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="utils.cpp:6178">
<![LOG[Set authenticator in transport]LOG]!><time="12:03:03.813+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="libsmsmessaging.cpp:7734">
<![LOG[   Setting Media Certificate.]LOG]!><time="12:03:03.813+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="utils.cpp:6195">
<![LOG[pszUnicodeString != 0, HRESULT=80070057 (e:\nts_sccm_release\sms\framework\core\ccmcore\string.cpp,301)]LOG]!><time="12:03:04.234+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="string.cpp:301">
<![LOG[Non fatal error 0x80070057 in sending task sequence execution status message to MP]LOG]!><time="12:03:04.234+480" date="01-09-2015" component="OSDSetupHook" context="" type="2" thread="2396" file="utils.cpp:6390">
<![LOG[   Setting URL = http://#Server#.#Server#.com, Ports = 80,443, CRL = false]LOG]!><time="12:03:04.234+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="utils.cpp:6143">
<![LOG[   Setting Server Certificates.]LOG]!><time="12:03:04.234+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="utils.cpp:6171">
<![LOG[   Setting Authenticator.]LOG]!><time="12:03:04.234+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="utils.cpp:6178">
<![LOG[Set authenticator in transport]LOG]!><time="12:03:04.234+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="libsmsmessaging.cpp:7734">
<![LOG[   Setting Media Certificate.]LOG]!><time="12:03:04.234+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="utils.cpp:6195">
<![LOG[pszUnicodeString != 0, HRESULT=80070057 (e:\nts_sccm_release\sms\framework\core\ccmcore\string.cpp,301)]LOG]!><time="12:03:04.250+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="string.cpp:301">
<![LOG[Non fatal error 0x80070057 in sending task sequence execution status message to MP]LOG]!><time="12:03:04.250+480" date="01-09-2015" component="OSDSetupHook" context="" type="2" thread="2396" file="utils.cpp:6390">
<![LOG[Command line for extension .exe is "%1" %*]LOG]!><time="12:03:05.264+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="commandline.cpp:228">
<![LOG[Set command line: "C:\WINDOWS\system32\_SMSOSDSetup\TsProgressUI.exe" /Unregister]LOG]!><time="12:03:05.264+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="commandline.cpp:731">
<![LOG[Executing command line: "C:\WINDOWS\system32\_SMSOSDSetup\TsProgressUI.exe" /Unregister]LOG]!><time="12:03:05.264+480" date="01-09-2015" component="OSDSetupHook" context="" type="1" thread="2396" file="commandline.cpp:827">
<![LOG[==========[ TsProgressUI started in process 2776 ]==========]LOG]!><time="12:03:05.264+480" date="01-09-2015" component="TsProgressUI" context="" type="1" thread="2780" file="winmain.cpp:330">
<![LOG[Command line: "C:\WINDOWS\system32\_SMSOSDSetup\TsProgressUI.exe" /Unregister]LOG]!><time="12:03:05.264+480" date="01-09-2015" component="TsProgressUI" context="" type="0" thread="2780" file="winmain.cpp:332">
<![LOG[Unregistering COM classes]LOG]!><time="12:03:05.264+480" date="01-09-2015" component="TsProgressUI" context="" type="1" thread="2780" file="winmain.cpp:204">
<![LOG[Unregistering class objects]LOG]!><time="12:03:05.264+480" date="01-09-2015" component="TsProgressUI" context="" type="1" thread="2780" file="winmain.cpp:495">
<![LOG[Shutdown complete.]LOG]!><time="12:03:05.264+480" date="01-09-2015" component="TsProgressUI" context="" type="1" thread="2780" file="winmain.cpp:512">
<![LOG[Process completed with exit code 0]LOG]!><time="12:03:05.264+480" date="01-09-2015" component="OSDSetupHook" context="" type="1" thread="2396" file="commandline.cpp:1123">
<![LOG[Successfully unregistered TS Progress UI.]LOG]!><time="12:03:05.264+480" date="01-09-2015" component="OSDSetupHook" context="" type="1" thread="2396" file="utils.cpp:2903">
<![LOG[InstallSMSClient(loadDir, dwResult), HRESULT=80004005 (e:\nts_sccm_release\sms\client\osdeployment\osdgina\basesetuphook.cpp,1506)]LOG]!><time="12:03:05.264+480" date="01-09-2015" component="OSDSetupHook" context="" type="0" thread="2396" file="basesetuphook.cpp:1506">
<![LOG[Failed to install SMS Client (0x80004005)]LOG]!><time="12:03:05.264+480" date="01-09-2015" component="OSDSetupHook" context="" type="3" thread="2396" file="basesetuphook.cpp:1506">
<![LOG[Waiting for command shell to complete.]LOG]!><time="12:03:05.264+480" date="01-09-2015" component="OSDSetupHook" context="" type="1" thread="2484" file="debugwindow.cpp:218">

Share this post


Link to post
Share on other sites

Wanted to provide an update on this question I posed. On the 9th when I posted this question I was at a total loss and didn't know what was wrong or how to fix it. I came in this morning and just for grins and giggles I went ahead and re-ran the Task Sequence on the machine in question. Came back roughly an hour later and it had completed successfully... no issues... All Drivers installed, SCCM Client installed, All Software installed, and BitLocker encryption started! Still don't know what the cause\fix was unfortunately, but I'm thinking whatever it was it was machine specific. Unfortunately I don't have another machine of the same model to confirm this though.

Share this post


Link to post
Share on other sites

Anytime I see this error in the ccmsetup.log its because the BITS service is either "Stopping" Not running or Disabled (damn users w/ admin rights). I know this issue you were seeing during the TS, but if anyone else see's this I would look at services first.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...