Jump to content

  • 0

JDK deploying. Need Help!!




how can i copy two .jar files into a local directory.

The Problem:

Standard User have read permission.

only admin have read write permission.


Maybe with a xcopy Batch file? but how did i have to configure the sccm. what did i have to do?


Iam a newbi in the sccm world and i hope to get help at this forum.


Thanks for all help

Share this post

Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Hi ,
thanks for your helpful page, i tried the instructions and everything looked good.
But now i try to start a new Paket and from now on i will allways get a 0x1(1) error message.
Maybe i think i have a node in my head, i can't find the right way.
I use the following parameters:

I create a package
I check the box package has source files
I specify the folder where the files are: \\server\subfolder$\lib
I specify a standard program
I name the program (copy) and specify in the command line:
(that looks like :
cmd.exe /c copy /y "%~dp0Files2Copy*.*" "%programfiles\Java\jdk1.8.0_45\jre\lib\security")
I run whether or not logged in with admin rights
I distribute the package, the deploy to the client.

in ccmcache i can see all the files (batch and the subfolder) = check!
But in the exexecmgr.log i see:
Execution is completet for program copy. the exit cod is 1, the execution status is FailureNonRetry.

Do you have any suggestion ?
I hope you can help me...


Share this post

Link to post
Share on other sites

  • 0

I saw that your location ist even Germany.


wir können auch in deutsch kommunizieren...


Ich habe die änderungen vorgenommen und die Batch datei noch mehr vereinfacht:


if not exist c:\test md c:\test
copy /y "%~dp0files2copy*.*" c:\test

Share this post

Link to post
Share on other sites

  • 0

Sorry, you got to keep in in english, so people can understand what you said. forum rules.

What about the "files2copy" part in your path ? Is that a folder name or do the files names all start with files2copy? If it is a older you are still missing a backslash "files2copy\*.*" Also make sure that the target directory exists on the machine.

Share this post

Link to post
Share on other sites

  • 0

ok :-)


the Files2Copy is a folder. Here are the two folders

Server: \\servername\subfolder$\Unlimited Security Policy JDK 8

(\\servername\subfolder$\Unlimited Security Policy JDK 8\security)

Client: C:\Program Files\Java\jdk1.8.0_45\jre\lib\security


Yesterday night, i tried to start by zero and build a test file:



if not exist c:\test md c:\test
copy "%~dp0Files2Copyfile1.txt" c:\test
copy ".\Files2Copy\file2.txt c:\test
copy "%~dp0\Files2Copy\file3.txt" c:\test
copy "%~dp0\Files2Copy\file4.txt" "c:\test"
copy /y "%~dp0Files2Copyfile5.txt" c:\test
copy "%~dp0*.*" c:\test


Server folder :

\\servername\subfolder$\Unlimited Security Policy JDK 8\

(\\servername\subfolder$\Unlimited Security Policy JDK 8\test)

Client folder :



It was ok! Only File3.txt, File4.txt and the last one worked fine!

OK now i know how to build the folder names. (I hope)


after that i tried it at my problem-batch-file but again "Failure".


now, after a short night, i will test ist again with this changed Version of my batch file:



copy "%~dp0\security\local_policy.jar" "C:\Program Files\Java\jdk1.8.0_45\jre\lib\security\"
copy "%~dp0security\US_export_policy.jar" "%ProgramFiles%\Java\jdk1.8.0_45\jre\lib\security"
copy "%~dp0\security\README.txt" "C:\Program Files\Java\jdk1.8.0_45\jre\lib\security"


Server Folder:

\\servername\subfolder$\Unlimited Security Policy JDK 8/

(\\servername\subfolder$\Unlimited Security Policy JDK 8/security)

Client Folder:

C:\Program Files\Java\jdk1.8.0_45\jre\lib\security


But now, i have two questions:


1. is it ok to use copy /y ....... ? or may i only use copy ..... (without /y )

2. must be the server folder and the clientfolder with the same name?


Like: \\servername\subfolder$\Unlimited Security Policy JDK 8/Securtiy

C:\Program Files\Java\jdk1.8.0_45\jre\lib\security


or is this ok?

//servername/subfolder$/Unlimited Security Policy JDK 8/

C:\Program Files\Java\jdk1.8.0_45\jre\lib\security



Thanks for you help !!!

Share this post

Link to post
Share on other sites

  • 0

Yessssss.... i fixed it!

But i don't know how! :-)


i compared both ways: 1. first batch(1) file with folders and the 2nd. batch (2)(Test)

i copied partly the batch (1) commands into the batch (2) an it worked good.

until everything was combined into the batch(2) and that is the right and woking one:


copy /y "%~dp0\Files2Copy\*.*" "C:\Program Files\Java\jdk1.8.0_45\jre\lib\security"


Server folders: \\server\subfolder$\Oracle\Development Kit\Unlim.Sec. Pol. JDK8

client folders: C:\Program Files\Java\jdk1.8.0_45\jre\lib\security


the only one thing i changed is the foldername of the last two server folder:

first: \\servername\subfolder$\Unlimited Security Policy JDK 8\test

now: \\servername\subfolder$\Unlim.Sec. Pol. JDK8\Folder2Copy


Maybe the foldername was to long ! ?!

Now it runs perfekt !


Thanks for your help ! Have a nice Weekend !!

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...