Jump to content


Token

Machines are inconsistantly joining the domain

Recommended Posts

Afternoon,

 

Recently, I have noticed that some our machines are not consistantly joining the domain as part of the task sequence. I find the issue is very strange, for example the same laptop can take multiple attempts before finally going through and completing the task sequence. The issue occurs with different laptop/desktop manufacturers and models. It also occurs with machines that have previously been sucessful through the task sequence.

 

Our setup has been in place for 18 months and the task sequence has not been altered. The boot image has also not been altered and the correct network drivers are present. I have read that the network drivers in the driver package may need updating, however as the machines will occasionally work I am unsure as to whether that is the correct answer. Within the task sequence I have checked that the user account used to join the machine is correct and it has appropriate permissions.

 

After reviewing the SMSTS logs I have noticed the following:

 

Found network adapter "Intel® Ethernet Connection I217-V" with IP Address 169.254.101.136. TSMBootstrap 04/06/2015 12:32:50 2920 (0x0B68)

So I think it must be failing due to the IP address. I am unsure as to why a 169.254 address would be issued. Can anyone explain why it picks up this address during the image build?

 

Towards the end of the SMSTS log I can see the following:

 

Retrying... TSManager 04/06/2015 12:47:36 2972 (0x0B9C)
CLibSMSMessageWinHttpTransport::Send: URL: sccm-vm-wm1.XXXX.co.uk:443 CCM_POST /ccm_system_AltAuth/request TSManager 04/06/2015 12:47:36 2972 (0x0B9C)
In SSL, but with no client cert TSManager 04/06/2015 12:47:36 2972 (0x0B9C)
Error. Received 0x80072ee7 from WinHttpSendRequest. TSManager 04/06/2015 12:47:36 2972 (0x0B9C)
unknown host (gethostbyname failed) TSManager 04/06/2015 12:47:36 2972 (0x0B9C)
hr, HRESULT=80072ee7 (e:\nts_sccm_release\sms\framework\osdmessaging\libsmsmessaging.cpp,8936) TSManager 04/06/2015 12:47:36 2972 (0x0B9C)
sending with winhttp failed; 80072ee7 TSManager 04/06/2015 12:47:36 2972 (0x0B9C)

 

So I google'd the above and it is effectively telling me that machine can not speak to the DC in order to join the domain. Which makes sense as it has a 169.254 network.

 

Hopefully someone may have seen something like this before. It is starting to cripple our productivity.

 

Please let me know if any further information.

 

Thanks in advance.

Stephen

Share this post


Link to post
Share on other sites


Hi Peter,

 

Thanks for the response. I have checked our DHCP server and we currently have 40% IP addresses left from our address pool.

 

The machines are picking up a DHCP address during PXE boot and I can see this on the DHCP server. However, during the task sequence (during the Apply Network Settings stage...I assume) the build fails and resorts to the applied image but obviously not on the domain.

 

Is there anywhere else that I should be checking?

Share this post


Link to post
Share on other sites

You could try manually joining a number of workgroup machines to the domain with the same domain join account set in TS and see if this has similar issues, this way then you can rule out SCCM if it is the same?

Has the user account set in TS for domain join been altered in anyway with permissions etc..

Has DNS settings changed i:e DHCP settings for clients to know what DNS server IP is

 

You could also try and create a new TS with minimal software just for speediness with deployments to see if it works any better.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...