Jump to content


Grasty

Surface Pro 3 Windows 10 Imaging?

Recommended Posts

So I have a working Windows 10 OSD Deployment MDT Based Task Sequence that I am trying to use on a Surface Pro 3.

 

I added the NIC Drivers to the x64 Boot Image, and I have confirmed on other systems that the x64 Boot Image is the one being grabbed by PXE (The whole LIFO thing), so I am confident that the x64 Boot Image is what is being grabbed on the Surface.

 

When i attempt to PXE Boot on the Surface I just get the error "Invalid Signature Detected. Check Secure Boot Policy in Setup".

 

If it makes a difference, I am using a dock.

 

Also I am using SCCM 2012 R2 SP1 (I also have MDT 2013 Update 1 Re-Release installed).

Share this post


Link to post
Share on other sites


I'm PXE booting the SP3 no problem here, can you share your smspxe.log and a screenshot of the error you see please

Share this post


Link to post
Share on other sites

Im not sure if it is failing before or after picking the boot image and connecting to the SCCM Server.

 

I only see these two lines in the smspxe log from this morning since I got here

 

Begin validation of Certificate [Thumbprint E6A6897EBADD1990D967119DE527783A302D2587] issued to '{E80B36A6-97EA-40AE-AB65-C5D77BEC0077}' SMSPXE 9/26/2015 9:44:57 AM 11544 (0x2D18)
Completed validation of Certificate [Thumbprint E6A6897EBADD1990D967119DE527783A302D2587] issued to '{E80B36A6-97EA-40AE-AB65-C5D77BEC0077}' SMSPXE 9/26/2015 9:44:57 AM 11544 (0x2D18)

 

Here is the error: http://imgur.com/6YchO5i

 

To PXE Boot, I am holding down the volume down button and pressing the power button. Then I let go of the volume down button when i see the Surface Logo. Then i see something along the lines of "PXE Boot ipv4" or something like that. Then I get the error.

 

This is a brand new surface pro 3, so the settings on it should all be whatever they default as when you buy it.

Share this post


Link to post
Share on other sites

So after spending all day trying to get this to work, I think I found the issue.

 

I could have sworn these guys were using ip helper addresses and not DHCP Options, so when I saw all those recommendations to use ip helper addresses, I ignored them because I thought they were already setup.

 

I noticed that there was another message popping up in between the PXE IPv4 and the error I was getting, but it was flashing across the screen really quick and i couldnt read it in time. I video recorded the process and tried to go frame by frame and noticed "NBP Filename boot\x86\wdsnbp.com", which is weird because im using a x64 Boot image. So I looked at the DHCP Options and sure enough, there was Option 66 and 67 pointing to the SCCM Server and boot\x86\wdsnbp.com. I tried removing them, but then PXE just timed out so I dont think they have the ip helper addresses configured. Unfortunately that isnt something I have access to so I cant check it.

 

Anyways, im confident that is the issue. If it still doesnt work after ip helper addresses then I will post back here.

Share this post


Link to post
Share on other sites

awesome result, and yes the SP3 won't be able to boot from that boot image as it's x64

can you do me a favor and video the boot sequence up until your error so i can see where it's failing with that error ?

Share this post


Link to post
Share on other sites

Here is the video

https://vid.me/G4RK

 

I tried removing the DHCP Options, but then the IPv4 PXE just timed out. Then I tried changing the boot option to be boot\x64\wdsnbp.com but i got the same error as before. I am still waiting on the network guy to try and add the ip helper addresses.

Share this post


Link to post
Share on other sites

Hi,

It will not boot using that either as it is not an BIOS machine it uses UEFI and the boot file name is different for UEFI. So what you need to do is to switch to using IP Helpers instead of the DHCP Option. The DHCP option as never been recommended by Microsoft and possible not supported either and the reason is the little issue you have ran into now that it will not support different technologies.

 

http://blogs.technet.com/b/configurationmgr/archive/2011/01/05/troubleshooting-the-pxe-service-point-and-wds-in-configuration-manager-2007.aspx

Regards,
Jörgen

Share this post


Link to post
Share on other sites

Thanks for the clarification as to why changing it to x64 didnt work. I did tell the network guy that they need to add ip helper addresses, I am just waiting for him to actually do it.

 

Thanks again both of you

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...