Jump to content


Recommended Posts

Setting up windows 10 deployment from SCCM, using UDI and I'm having a problem with the UILanguage variable from UDI not working. I had the same problem with Windows 7 and gave up looking for a solution.

 

My WIM file that is used has english, chinese, french, italian, spanish, dutch, and german language packs installed in it before it was captured with DISM.

 

My unattend file has the following section with the UDI variables in it:

 

<settings pass="oobeSystem">
<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<InputLocale>%KeyboardLocale%</InputLocale>
<SystemLocale>%SystemLocale%</SystemLocale>
<UILanguage>%UILanguage%</UILanguage>
<UILanguageFallback>en-US</UILanguageFallback>
<UserLocale>%UserLocale%</UserLocale>
</component>
everything works except UILanguage, including the rest of the unattend file to join the domain and a bunch of other settings. When Windows boots, instead of the task sequence continuing along i get prompted by OOBE to select a language of the ones installed. after i select a language, the task sequence continues until its done.
Does anyone have an thoughts or ideas on this?

Share this post


Link to post
Share on other sites


Presuming you have updated your Unattend.xmlf were you aware there has been a bug around since MDT 2012 Update 1 with the UDIWizard.wdf file within the MDT Toolkit.......Yes this still exists in MDT 2013 Update 2!

 

Credit goes Raphael at the The Desktop Team:

 

http://thedesktopteam.com/raphael/sccm-2012-r2-and-mdt-2013-udi-locale/

 

I was pulling my hair out a couple of years back with my XP to Win 7 upgrades, fix still required for all versions of MDT 2013. Hope this helps.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...