Jump to content


Sign in to follow this  
George

"My language is" question when deploying Multilanguage Windows 7

Recommended Posts

Hi everyone!

Great forum! Thanks!

 

I have questions about Windows 7 deploying with SCCM `07 SP2.

 

1. When computer is deployed with multilingual image I got a stupid console wizard called “Set Up Windows – My Language Is…” and I have to choose between languages installed into current image. When I choose Russian, for example, setup continues at step “Setup Windows and ConfigMgr”. Is there any way to disable this wizard? (See screenshot - sorry about quality, it is iPhone :angry: ).

post-3996-12556116646414_thumb.jpg

 

2. How can I disable “Choose network location” after first user logon?

 

Thanks for help! :rolleyes:

 

Update:

Found this - link

I need to edit WIM with DISM or maybe i need to create custom unattend.xml?

Share this post


Link to post
Share on other sites

Hi George

 

Welkom :)

 

The best way is to use a Unattend XML file.

In there you can set every setting you like.

Language, screen resolution, Keyboard, …

 

Cheers

Share this post


Link to post
Share on other sites

Hi George

 

Welkom :)

 

The best way is to use a Unattend XML file.

In there you can set every setting you like.

Language, screen resolution, Keyboard, …

 

Cheers

 

Hi Kinom!

Thanks! :)

 

I did these steps without success:

 

1. Created XML like this:

 

<?xml version="1.0" encoding="utf-8"?>

<unattend xmlns="urn:schemas-microsoft-com:unattend">

<settings pass="oobeSystem">

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State">

<Display>

<ColorDepth>32</ColorDepth>

<HorizontalResolution>1024</HorizontalResolution>

<RefreshRate>60</RefreshRate>

<VerticalResolution>768</VerticalResolution>

</Display>

<OOBE>

<HideEULAPage>true</HideEULAPage>

<NetworkLocation>Work</NetworkLocation>

<ProtectYourPC>1</ProtectYourPC>

<SkipUserOOBE>true</SkipUserOOBE>

</OOBE>

</component>

</settings>

<cpi:offlineImage cpi:source="" xmlns:cpi="urn:schemas-microsoft-com:cpi" />

</unattend>

 

2. Added package contains this XML file.

3. In "Apply Operating System" step i have ticked "Use Unattended or Sysprep answer file..." and selected package and filename.

 

System was installed, joined domain and now it's asked to choose "My language" again :(

Share this post


Link to post
Share on other sites

did you make sure to update the distribution points with the edited version of your unattend.xml package

Share this post


Link to post
Share on other sites

did you make sure to update the distribution points with the edited version of your unattend.xml package

Yes, i did. The unattend.xml file located in \\GS-AUDIT01.GS.LOCAL\SMSPKGF$\AV100037

But LOGFILE looks strange for me...

 

\\GS-AUDIT01.GS.LOCAL\SMSPKGF$\AV100037Setting %SystemRoot% to "C:\WINDOWS"

Loading existing answer file "C:\WINDOWS\panther\unattend\unattend.xml"

Getting namespace "Microsoft-Windows-Deployment" for architecture "x86"

Getting namespace "Microsoft-Windows-Shell-Setup" for architecture "x86"

Getting namespace "Microsoft-Windows-International-Core" for architecture "x86"

Writing configuration information to C:\WINDOWS\panther\unattend\unattend.xml

Successfully saved configuration information to C:\WINDOWS\panther\unattend\unattend.xml

Image installation completed sucessfully.

Closing image file \\GS-AUDIT01.GS.LOCAL\SMSPKGF$\AV100036\Windows 7.wim

Entering ReleaseSource() for \\GS-AUDIT01.GS.LOCAL\SMSPKGF$\AV100036reference count 1 for the source \\GS-AUDIT01.GS.LOCAL\SMSPKGF$\AV100036\ before releasing

Released the resolved source \\GS-AUDIT01.GS.LOCAL\SMSPKGF$\AV100036\.

Share this post


Link to post
Share on other sites

Update!

I have success with this method:

1. Mount OS Image with DISM

2. Copy unattend.xml to C:\Windows\Panther\Unattend\

3. unMount and Commit image with DISM

4. Deploy

Why that happens?

Somebody know why TS does not take my unattend,xml from package?

post-3996-12558854360693_thumb.jpg

Share this post


Link to post
Share on other sites

if you look at the zticonfigure.log file you should see references to the unattend.xml file being merged (or not) with your one,

 

so what does it tell you ?

Share this post


Link to post
Share on other sites

Hi,

 

old post I know but cannot figure this one out...

I use ImageUnattend.xml with WDS...all other settings work except for this last screen, not matter what I setup it still asks user at the end...

Share this post


Link to post
Share on other sites

Hi,

 

old post I know but cannot figure this one out...

I use ImageUnattend.xml with WDS...all other settings work except for this last screen, not matter what I setup it still asks user at the end...

 

I'll have the same issue. Al other unattend settings seems to get picked up by the TS but I still got the same screen as OP during OSD... I'll try the option as mentioned by George to "dism in" the unattend.xml to the panther directory.

Will report this week with my findings.

Share this post


Link to post
Share on other sites

Regenerate your XML using WindowsSIM. I had this issue when i upgraded to IE11 in my reference image. Apparently IE11 changes the unattend xml schema slightly so i was getting this popup too.

 

Open the XML in windows sim, open your .wim file and find the erronous code. It will show straight away. Youll get some sort of warning like "this feature is deprecated or something". Just remove that section, save, refresh DPs and try again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...