Jump to content


"The Path is Not of Legal Form" Error When Trying to Create MDT Boot Images

Recommended Posts

Hey Guys / Niall -

I'm wrapping up a complete rebuild of the production environment's SCCM. So far, I've installed SCCM 2012 R2, applied SP1, then applied CU3. Recently, I installed MDT 2013 Update 2 then ran the ConfigMgr Integration as Administrator. I'm trying to create the base MDT Packages, but am getting errors! :(

When trying to create a new MDT Boot Image, I perform the following steps:

  1. Right click Boot image and choose to create a new MDT boot image
  2. Enter the (empty) source path for the boot image
  3. Enter the desired name and version
  4. Select x64 and 128mb
  5. On the next page (Components) get the error message "The path is not of a legal form"
  6. The components page behind it is empty (doesn't list any of the components). Clicking OK simply dismisses the error window and leaves me at the blank Components page. If i click OK on it, I get the error "Object reference not set to an instance of an object" so must cancel out of it.
As I initially installed MDT to D: (keeping the rest of the default path the same), I removed the ConfigMgr integration, uninstalled MDT, reinstalled MDT to the default path on C:, reintegrated, and tried again - got the same error. Google only has a couple of things about it - one being from Niall - saying basically to make sure everything is launched as admin. It is, but still no go.

Any suggestions? Thanks!

Share this post

Link to post
Share on other sites

Ok. My issue is resolved.


I created a new deployment share in MDT and then configured it. In doing so, MDT 2013 required that I install Windows ADK for Windows 10. (I previously had Windows ADK for Windows 8.1 installed.)

After these steps, I tried again to create a boot image using MDT, and did not receive the error.


Also, if you are using ADK for Windows 10 to generate boot images for SCCM using MDT, you may encounter this issue too: https://support.microsoft.com/en-us/kb/3143760

Edited by stephenhebert

Share this post

Link to post
Share on other sites

I struggled with this for the better part of yesterday afternoon and this morning. Launching MDT prompted the error that I did not have adk 8.1 installed (I installed adk for win 10). After installing adk 8.1, after selecting x64 on options, next, the Components section now displays all the checkboxes with Microsoft Data Access Components the one selected by default.


Worth noting that initially I did have 8.1 installed, but with troubleshooting I uninstalled it to put the win10 version on. Other things I did for troubleshooting: activate windows, update to sccm current branch, then all the small hotfixes within sccm, and all win updates.

Share this post

Link to post
Share on other sites

I was getting this same error (On the Components page "The path is not of a legal form")

[with ADK for win10 =10.1.14393.0


SCCM CB 1610]

I fixed this issue with below steps:

1. removing the MDT integration with Config Manager

2. uninstalling the MDT and ADK

3. Install the ADK first then install the MDT

4. Re-integration of MDT with CM

Now the issue is fixed in my environment.


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...