Jump to content


Sign in to follow this  
Lagamorph

Failure when installing Application during deployment task sequence

Recommended Posts

Hi all,

 

So this is kind of following on from a previous thread where I was having trouble with installing an MSI during a deployment task sequence, where the installation would just hang endlessly. Oddly this only occurred on physical servers, deploying to VMs worked fine and the installation script worked fine outside of SCCM with no boxes popping up.

I decided to try a different approach to resolve the issue and instead of a package I thought I'd make use of the new SCCM Applications to try and install the MSI, but I'm experiencing a new issue with this. Whenever I try to install the application I'm receiving an error,

Permissions on the requested may be configured incorrectly. Access is denied. (Error: 80070005; Source: Windows)

The smsts.log file shows the following,

<![LOG[Policy evaluation initiated]LOG]!><time="16:00:47.371-60" date="05-25-2016" component="InstallApplication" context="" type="1" thread="4032" file="utils.cpp:4437">
<![LOG[Waiting for policy to be compiled in 'root\ccm\policy\machine' namespace ]LOG]!><time="16:00:47.371-60" date="05-25-2016" component="InstallApplication" context="" type="1" thread="4032" file="installapplication.cpp:544">
<![LOG[Query path = 'CCM_ApplicationCIAssignment.AssignmentID="DEP-ZER201AA-ScopeId_121E90BF-ADD6-4509-816E-76D3C5CF0367/Application_368f474b-9ba3-4984-977a-08770d9a8746"']LOG]!><time="16:00:47.371-60" date="05-25-2016" component="InstallApplication" context="" type="1" thread="4032" file="installapplication.cpp:571">
<![LOG[Verified policy is compiled in 'root\ccm\policy\machine' namespace]LOG]!><time="16:00:47.371-60" date="05-25-2016" component="InstallApplication" context="" type="1" thread="4032" file="installapplication.cpp:596">
<![LOG[Invoking App Management SDK to evaluate app polices]LOG]!><time="16:00:47.402-60" date="05-25-2016" component="InstallApplication" context="" type="0" thread="4032" file="installapplication.cpp:384">
<![LOG[Process completed with exit code 2147942405]LOG]!><time="16:00:47.558-60" date="05-25-2016" component="TSManager" context="" type="1" thread="2408" file="commandline.cpp:1124">
<![LOG[!--------------------------------------------------------------------------------------------!]LOG]!><time="16:00:47.558-60" date="05-25-2016" component="TSManager" context="" type="1" thread="2408" file="instruction.cxx:805">
<![LOG[Failed to run the action: Install Splunk (x64). Permissions on the requested may be configured incorrectly.
Access is denied. (Error: 80070005; Source: Windows)]LOG]!><time="16:00:47.558-60" date="05-25-2016" component="TSManager" context="" type="3" thread="2408" file="instruction.cxx:911">

To me this makes it appear that the Detection Method of the Application is failing.

Originally I left the detection method at the automatically created MSI method, but this failed. So I changed the Detection rule to simply detect the presence of a folder on the C:\ drive, however this is still failing.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...