Jump to content


SCCM Hardware Inventory not reporting on any installed programs...

Recommended Posts

I've got an SCCM 2012 installation. hardware inventory is running correctly (for the most part). Resource explorer is reporting back on physical hardware but no installed software is showing up. I've followed guidance from several KB articles but the issue is not resolved. After doing the following I ran a Hardware Inventory across toe building. It ran late last week and again yesterday. Yielding no results.


Additional symptom: When I build a query, I select the "Software Products", "Product Name" attribute. When I click on the "Value" box, which would normally give me a drop down list of items, it is also empty. What am I MISSING!!!!!!????


I've gone in to the Default Client Settings, "Hardware Inventory" option and selected additional "Inventory Classes" to collect:


Installed apps (64)....

Installed apps (win32reg.....)

Installed executable - .....

Installed Software - ......

Software Licensing Prod.....

Software Licensing Serv.....

Software Shortcut.....

Software Tag......


In "Software Inventory" option I DID NOT "SET" any "Inventory File Types", nor did I select "Collect Files". Based on the KB articles, If I set the items above, I didn't need to set these items.


Thanks in advance for the help.


Share this post

Link to post
Share on other sites

I got it figured out. I believed a resource when they said that you didn't have to select a "Type" in the software inventory. I went back, selected *.exe and guess what? INVENTORY!!!!

I NEVER recommend using or enabling SW inventory.. Too many issues with it.

Instead stick with the Hardware inventory reports, you clients will thank you.



Share this post

Link to post
Share on other sites

Re: your previous reply. I don't see Add/Remove Program anywhere. It looked like it had been replaced with installed software references. What am i missing. And, if I disable the software inventory, where do I make the change that will get me the installed programs...? I'm new to 2012, although I worked extensively in 2007....




Share this post

Link to post
Share on other sites

17 minutes ago, renoldrobin said:

HI I have similar issue,


When i try to run a report tried to add the value but VALUE of the product Name is not visible. Please find the attachment,

First off that report doesn't use HW inventory. It use SW inventory. SW inventory is disabled by default as it is useless. https://www.enhansoft.com/sccm-software-inventory/

Instead use the ARP reports to see what is installed on computers. 


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...