Jump to content


Sign in to follow this  
akearins

Deployment Failure - Empty Cache Folder

Recommended Posts

Hi

 

I have machines with SWX2015/ Autodesk products 2016 and want to install SWX2016/Autodesk 2017 applications

 

I have successfully deployed the applications to new builds and tested with a device with SWX2015 and it successfully removed 2015 and installed 2016.

 

Issue I am having now is deployment begins on clients and Downloads reach 99%, the cache folder are downloading folders/files.

Installation Fails message appears and the Cache folders are then emptied..

 

This is the same for all applications we try and deploy

 

From AppDiscovery log

 

Performing detection of app deployment type SolidWorks 2016(ScopeId_70485144-E84C-45C6-BE66-CD28413BC4FE/DeploymentType_adf85ebe-9036-47c8-8a4e-ca7e699921eb, revision 12) for system.]LOG]!><time="12:03:20.432-60" date="07-22-2016" component="AppDiscovery" context="" type="1" thread="1404" file="appprovider.cpp:2148">
<![LOG[+++ Application not discovered. [AppDT Id: ScopeId_70485144-E84C-45C6-BE66-CD28413BC4FE/DeploymentType_adf85ebe-9036-47c8-8a4e-ca7e699921eb, Revision: 12]]LOG]!><time="12:03:20.668-60" date="07-22-2016" component="AppDiscovery" context="" type="1" thread="1404" file="localapphandler.cpp:291">
<![LOG[+++ Did not detect app deployment type SolidWorks 2016(ScopeId_70485144-E84C-45C6-BE66-CD28413BC4FE/DeploymentType_adf85ebe-9036-47c8-8a4e-ca7e699921eb, revision 12) for system.]LOG]!><time="12:03:20.668-60" date="07-22-2016" component="AppDiscovery" context="" type="1" thread="1404" file="appprovider.cpp:540">
<![LOG[ ActionType - Install will use Content Id: Content_808b38d6-8dd9-48e4-8528-a351129a4274 + Content Version: 1 for AppDT "SolidWorks 2016" [scopeId_70485144-E84C-45C6-BE66-CD28413BC4FE/DeploymentType_adf85ebe-9036-47c8-8a4e-ca7e699921eb], Revision - 12]LOG]!><time="12:03:21.674-60" date="07-22-2016" component="AppDiscovery" context="" type="1" thread="1404" file="appprovider.cpp:1543">

Share this post


Link to post
Share on other sites


How big are these apps, and how big are the client caches?

 

I don't remember the details, but we saw something similar when deploying the Dynamics AX client. The default cache size is, I want to say, 5GB. The AX install was 7+GB. Clients would try to install it and fail since the app was too big to fit in the cache. Solution was to increase the cache size on the clients.

 

I'm not familiar with the specific Autodesk stuff you're using, but in my experience with Autodesk Infrastructure Design Suite, I know their installers can run to the tens of GB, so you might be running into this same thing.

Share this post


Link to post
Share on other sites

I've had this before, and like Jaybone has said the cache size will probably be getting too full for the application. In the past I've had to increase the cache size to 50gb to allow suites of autodesk apps etc to install.

Share this post


Link to post
Share on other sites

Cleared all Caches and set to 30GB..without clearing Cache its still only using 12GB ..application is 10GB

 

watched the entire process just now..downloads 97% all files are in cache from DP and then just deletes all files and folder

 

Does not happen on clean installs only currently imaged devices...

 

Extract from CAS log

 

 

<![LOG[Download completed for content Content_808b38d6-8dd9-48e4-8528-a351129a4274.1 under context System]LOG]!><time="15:24:59.702-60" date="07-26-2016" component="ContentAccess" context="" type="1" thread="5656" file="contentaccessservice.cpp:1937">
<![LOG[Failed to open file c:\windows\ccmcache\i\64bit\edrawings\common64\edrawings2016\axshdocvw.dll with error [32].
]LOG]!><time="15:25:07.716-60" date="07-26-2016" component="ContentAccess" context="" type="3" thread="5656" file="securityutil.cpp:478">
<![LOG[CheckExclusiveFileAccessAndSetFilePermissions failed for c:\windows\ccmcache\i\64bit\edrawings\common64\edrawings2016\axshdocvw.dll]LOG]!><time="15:25:07.716-60" date="07-26-2016" component="ContentAccess" context="" type="3" thread="5656" file="newhashdir.cpp:201">
<![LOG[敒敳䙴汩健牥業獳潩獮 failed; 0x80070020]LOG]!><time="15:25:07.716-60" date="07-26-2016" component="ContentAccess" context="" type="3" thread="5656" file="newhashdir.cpp:207">
<![LOG[慈桳潃瑮湥t failed; 0x80070020]LOG]!><time="15:25:07.716-60" date="07-26-2016" component="ContentAccess" context="" type="3" thread="5656" file="newhashdir.cpp:730">
<![LOG[慈桳潃瑮湥t failed; 0x80070020]LOG]!><time="15:25:07.716-60" date="07-26-2016" component="ContentAccess" context="" type="3" thread="5656" file="newhashdir.cpp:730">
<![LOG[慈桳潃瑮湥t failed; 0x80070020]LOG]!><time="15:25:07.716-60" date="07-26-2016" component="ContentAccess" context="" type="3" thread="5656" file="newhashdir.cpp:730">
<![LOG[慈桳潃瑮湥t failed; 0x80070020]LOG]!><time="15:25:07.716-60" date="07-26-2016" component="ContentAccess" context="" type="3" thread="5656" file="newhashdir.cpp:730">
<![LOG[慈桳潃瑮湥t failed; 0x80070020]LOG]!><time="15:25:07.716-60" date="07-26-2016" component="ContentAccess" context="" type="3" thread="5656" file="newhashdir.cpp:730">
<![LOG[潃灭瑵䍥湯整瑮慈桳 failed; 0x80070020]LOG]!><time="15:25:07.716-60" date="07-26-2016" component="ContentAccess" context="" type="3" thread="5656" file="newhashdir.cpp:826">
<![LOG[Failed to do hash verification with preference : 4. Try to verify at next hash algorithm]LOG]!><time="15:25:07.716-60" date="07-26-2016" component="ContentAccess" context="" type="3" thread="5656" file="contentaccessservice.cpp:132">
<![LOG[Download failed for content Content_808b38d6-8dd9-48e4-8528-a351129a4274.1 under context System, error 0x80091007]LOG]!><time="15:25:07.716-60" date="07-26-2016" component="ContentAccess" context="" type="2" thread="5656" file="contentaccessservice.cpp:2485">
<![LOG[Download failed for download request {A768FB28-EE3B-420A-9461-9B62C88C2FA9}]LOG]!><time="15:25:07.716-60" date="07-26-2016" component="ContentAccess" context="" type="2" thread="5656" file="downloadcontentrequest.cpp:1155">
<![LOG[Raising event:
[sMS_CodePage(437), SMS_LocaleID(1033)]
instance of SoftDistHashMismatchEvent
{
ClientID = "GUID:CD247210-96B5-4342-AE4E-797E0B64E30A";
DateTime = "20160726142507.721000+000";
MachineName = "machine name";
PackageId = "Content_808b38d6-8dd9-48e4-8528-a351129a4274";
PackageName = "Content_808b38d6-8dd9-48e4-8528-a351129a4274";
PackageVersion = "1";
ProcessID = 4436;
SiteCode = "SIT";
ThreadID = 5656;
};
]LOG]!><time="15:25:07.723-60" date="07-26-2016" component="ContentAccess" context="" type="1" thread="5656" file="event.cpp:715">
<![LOG[successfully raised SoftDistHashMismatchEvent event.]LOG]!><time="15:25:07.723-60" date="07-26-2016" component="ContentAccess" context="" type="1" thread="5656" file="downloadmanager.cpp:1045">
<![LOG[Error: DeleteDirectory:- Failed to delete Directory C:\Windows\ccmcache\i.BCWork with Error 0x00000002.]LOG]!><time="15:25:16.323-60" date="07-26-2016" component="ContentAccess" context="" type="3" thread="5656" file="delpath.cpp:22">
<![LOG[Releasing content request {A768FB28-EE3B-420A-9461-9B62C88C2FA9}]LOG]!><time="15:25:17.402-60" date="07-26-2016" component="ContentAccess" context="" type="1" thread="6516" file="contentaccessservice.cpp:1861">

Share this post


Link to post
Share on other sites

Heard of an issue where if there are too many files (500+) then sccm has issues. Try zip the file up and deploy it. See if it help. 7zip can be run using command line, just redo your script so it unpacks the file then installs.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...