Jump to content


Sign in to follow this  
dinci5

OSD TS fails with error 0x0000264B

Recommended Posts

Hi,

 

SCCM 2012 R2 SP1

 

We are unable to stage PC's on one of our remote sites with a local DP.

The error we receive is just strange: 0x0000264B

See screenshot...

 

Also, attached you can find the smsts.log file.

 

One of the things I notice in the log file is:

FAILURE ( 9803 ): ERROR - Machine is not authorized for upgrading (OSInstall=N), aborting.

Now I know I've seen this before but I really don't remember how I've solved it last time.

The PC is in SCCM and the OSInstall variable is set to Y

So not sure why it fails.

 

It all worked well for over a year then it suddenly stopped working.

Nothing has changed in our environment.

Can anyone push me in the right direction?

 

Thank you

post-31237-0-20893300-1472549466.jpg

smsts.log

Share this post


Link to post
Share on other sites


Your MDT Database returns this ...

 

 

Property OSINSTALL is now = N InstallSoftware 30.08.2016 08:54:59 1888 (0x0760)
Obtained OSINSTALL value from SQL: OSINSTALL = N InstallSoftware 30.08.2016 08:54:59 1888 (0x0760)

 

So the sequence is working fine. Time to check your customsettings.ini and database entries.

Share this post


Link to post
Share on other sites

Your MDT Database returns this ...

 

 

So the sequence is working fine. Time to check your customsettings.ini and database entries.

 

Could you be more specific?

Nothing changed in the last year in our environment and everything is working just fine on all other sites.

 

What exactly should I look for in the database and/or customsettings.ini

I would rather leave customsettings.ini as is beacuse it works on all other sites.

Share this post


Link to post
Share on other sites

I never managed to solve this problem.

Now I have another device with this error.

See smsts.log for details.

 

In the SCCM Status Message Queries I see these errors:

"The task sequence execution engine failed execution of a task sequence. The operating system reported error 617: You have attempted to change your password to one that you have used in the past. The policy of your user account does not allow this. Please select a password that you have not previously used."

 

And:

"The task sequence execution engine failed executing the action (Error in the task sequence) in the group (Gather Logs and StateStore on Failure) with the error code 9803
Action output: . The operating system reported error 617: You have attempted to change your password to one that you have used in the past. The policy of your user account does not allow this. Please select a password that you have not previously used."
And:
"The task sequence execution engine failed executing the action (Validate) in the group (New Computer) with the error code 9803
Action output: [ smsswd.exe ]
PackageID = ''
BaseVar = '', ContinueOnError=''
ProgramName = 'cscript.exe "C:\_SMSTaskSequence\WDPackage\Scripts\ZTIValidate.wsf"'
SwdAction = '0001'
Command line for extension .exe is "%1" %*
Set command line: Run command line
Working dir 'not set'
Executing command line: Run command line
Process completed with exit code 9803
Microsoft ® Windows Script Host Version 5.812
Copyright © Microsoft Corporation. All rights reserved.
Microsoft Deployment Toolkit version: 6.2.5019.0
The task sequencer log is located at X:\windows\TEMP\SMSTSLog\SMSTS.LOG. For task sequence failures, please consult this log.
ERROR - Machine is not authorized for upgrading (OSInstall=N), aborting.
FAILURE ( 9803 ): ERROR - Machine is not authorized for upgrading (OSInstall=N), aborting.
Command line returned 9803. The operating system reported error 617: You have attempted to change your password to one that you have used in the past. The policy of your user account does not allow this. Please select a password that you have not previously used."

smsts.log

Share this post


Link to post
Share on other sites

It's hard to tell why gather is returing OSInstall=N without knowing your customsettings.ini and your MDT database. Maybe it's the default value in your case if for example the dafault gateway is not listed in your DB, or the machine type or something else.

Everything is working as it should be. Just the returned dataset is not what you are expecting.

Here is where ztiutility opts out because OSInstall is not set to Y. No clue why this translates to error 617 in SCCM. I would ignore that.

'//----------------------------------------------------------------------------
		'//  Abort if "OSInstall" flag is set to something other than "Y"
		'//----------------------------------------------------------------------------

		If oEnvironment.Exists("OSInstall") then
			If UCase(Left(oEnvironment.Item("OSInstall"), 1)) <> "Y" then
				oLogging.CreateEvent 41046, LogTypeError, "ERROR - Machine is not authorized for upgrading (OSInstall=" & oEnvironment.Item("OSInstall") & "), aborting.", Array()
				oLogging.ReportFailure "ERROR - Machine is not authorized for upgrading (OSInstall=" & oEnvironment.Item("OSInstall") & "), aborting.", 9803
			Else
				oLogging.CreateEntry "OSInstall flag is set, install is allowed.", LogTypeInfo
			End if
		Else
			oLogging.CreateEntry "OSInstall flag is not set, validation check bypassed.", LogTypeInfo
		End if

Share this post


Link to post
Share on other sites

For clarification...

This is a Microsoft Surface Pro 3.
We have already deployed 500+ of those successfuly and all other preloads are working just fine.

That's why it's confusing why this devcie keeps failing.

 

I have installed it successfuly with a clean Windows 10 ISO and joined to domain just to check if there might be something wrong with the device itself.

Everything working fine.

Then tried to preload again and it fails.

 

SCCM is a great tool but it sucks when something is failing. It's so hard to figure out why.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...