Jump to content


Sign in to follow this  
Lagamorph

Server 2016 - Skip Product Key failing

Recommended Posts

Hi all.

 

I know Server 2016 is still in Technical Preview, but we're beginning to do some work on testing deployment via SCCM. Whilst on the whole it's been successful, whenever we do the deployment it hangs at a screen prompting to enter a Product Key. We can manually select the option to Do it later and the deployment continues as normal, but obviously this is hardly a long term workable solution.

Does anyone have any ideas on how we can automatically skip this?

 

Below is my customsettings.ini,

[Settings]
Priority=Default
Properties=MyCustomProperty
 
[Default]
OSInstall=Y
SkipCapture=YES
SkipAdminPassword=YES
AdminPassword=<REMOVED>
SkipProductKey=YES
SkipLocaleSelection=YES
KeyboardLocale=0809:00000809
UserLocale=en-GB
UILanguage=en-GB
Systemlocale=en-GB
SkipTimeZone=YES
TimeZoneName=GMT Standard Time
So we're already telling it to skip the product key there, though the Product Key field is blank in the Apply Windows Settings stage. This has never been a problem for our 2008R2 and 2012R2 deployments. We were simply able to deploy the OS then activate via KMS later.

Share this post


Link to post
Share on other sites

is there a pid.txt or similar in the sources folder with the key ?

 

otherwise have you tried specifying the tp key ?

Share this post


Link to post
Share on other sites

Sorry for the delayed response on this.

 

There is no pid.txt file that I could see unfortunately, though after doing more digging I think I may have found the cause. Apparently with the last few versions of Windows, the installation on a non Volume Licensed copy of Windows cannot automatically bypass the Product Key entry with no product key specified in the Unattend.xml, even when deploying via SCCM, this functionality is only available on Volume License versions. As I'm just using the Windows Server 2016 trial ISO at the moment, which won't be a Volume License version, it may not yet possess the ability to do this automatically.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...