Jump to content


Sign in to follow this  
zcaa0g

Can't run command in advertised OSD task sequence when in Windows

Recommended Posts

I have an OSD advertisement and when I try to run a command either directly or from a software package that is in the OSD task sequence, it just hangs on the step. This is only an issue within the Windows environment, I don't have this issue in the WinPE environment.

 

So for example, I have a task sequence step calling Windows Paint, it will bring up the OSD task sequence dialog box saying it is running the step, but it doesn't actually run from a visible standpoint, nor do you see the actual mspaint.exe process. I see this issue whether I call notepad.exe, a custom executable or whatever and whether I do it as a direct command or as an actual SCCM software package.

 

I have the command calling %windir%\system32\mspaint.exe and this doesn't work even when specifying the working directory. Below is from the SMTS log, so you can see it is calling the command, but it doesn't seem to actually do anything. Any ideas?

 

 

Expand a string: smsswd.exe /run: %windir%\system32\mspaint.exe TSManager 9/9/2016 10:29:15 AM 4280 (0x10B8)
Expand a string: TSManager 9/9/2016 10:29:15 AM 4280 (0x10B8)
Start executing the command line: smsswd.exe /run: %windir%\system32\mspaint.exe TSManager 9/9/2016 10:29:15 AM 4280 (0x10B8)
!--------------------------------------------------------------------------------------------! TSManager 9/9/2016 10:29:15 AM 4280 (0x10B8)
Expand a string: WinPEandFullOS TSManager 9/9/2016 10:29:15 AM 4280 (0x10B8)
Executing command line: smsswd.exe /run: %windir%\system32\mspaint.exe TSManager 9/9/2016 10:29:15 AM 4280 (0x10B8)
[ smsswd.exe ] InstallSoftware 9/9/2016 10:29:16 AM 1804 (0x070C)
PackageID = '' InstallSoftware 9/9/2016 10:29:16 AM 1804 (0x070C)
BaseVar = '', ContinueOnError='' InstallSoftware 9/9/2016 10:29:16 AM 1804 (0x070C)
ProgramName = 'C:\WINDOWS\system32\mspaint.exe' InstallSoftware 9/9/2016 10:29:16 AM 1804 (0x070C)
SwdAction = '0001' InstallSoftware 9/9/2016 10:29:16 AM 1804 (0x070C)
Command line for extension .exe is "%1" %* InstallSoftware 9/9/2016 10:29:16 AM 1804 (0x070C)
Set command line: Run command line InstallSoftware 9/9/2016 10:29:16 AM 1804 (0x070C)
Working dir 'C:\WINDOWS\system32' InstallSoftware 9/9/2016 10:29:16 AM 1804 (0x070C)
Executing command line: Run command line InstallSoftware 9/9/2016 10:29:16 AM 1804 (0x070C)

Share this post


Link to post
Share on other sites

Try using this:

cmd /c %windir%\system32\mspaint.exe

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...