Jump to content


Sign in to follow this  
Edenost

SCCM WSUS Error 80244019 (Client install)

Recommended Posts

Hi All,

 

I just wanted to drop a quick message to let you know about an old error I came across this morning when configuring the client install through WSUS.

 

After installing WSUS and the SUP on my Server 2012R2 install with SCCM CB, I was getting error 80244019 from the Windows Update client on the client machines.

 

After some investigation, I found that the "Content" directory within IIS was inaccessible by IIS.

I could manually reach it by going there myself, or using the run command. I could access it by the share name, and directly on the host itself, from multiple locations with multiple accounts.

But when I right clicked on it and chose "Explore", it told me the directory could not be found/access (or something along those lines, sorry no screenshots! :().

 

Following on from that, I decided to check the permssions of course, which were all correct.

I removed and reinstalled WSUS and SUP a couple of times, but doing the same process each time I installed it.

 

In the end, I removed both WSUS and SUP from the SCCM Server.

Rebooted.

Reinstalled WSUS, but rather than storing the updates using the UNC path, I pointed it to the local path, so "E:\Sources\Windows Updates" for example, rather than "\\SCCM\Sources\Windows Updates".

 

I told SCCM to STOP installing the client through WSUS.

Waited for the rule to finish to remove it from the deployment (you can confirm this by going back in to the setting and both boxes will be empty (nothing is published).

Told it to publish by WSUS again, then waiting a few more minutes.

After a short while, I checked the Windows Updates folder again, and there it was, CCMSetup.exe was present.

I then checked the "Content" directory in IIS and it was accessible this time by clicking "Explore".

 

I went back to one of my servers. Told it to check for updates, and it worked! :)

 

Just in case anyone else comes across this in the future as I did search online, but nothing really pointed to this being an issue.

To me, it looks like it doesn't like to use the UNC paths! But I'm sure someone will correct me if I'm wrong.

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...