Jump to content


Recommended Posts

Good Morning gents,

 

I recently switch my SCCM CB 1610 from http tp https, everything it's working fine until I tested the Software Update. I downloaded and deploy a patch and on the client i get the following errors:

 

Its a WSUS Update Source type ({B3CE6C4E-8947-43F7-9E10-275AFDD23DB8}), adding it. WUAHandler 3/7/2017 11:03:03 AM 17740 (0x454C)
Existing WUA Managed server was already set (https://sccmserver.domain.LOCAL:8531), skipping Group Policy registration. WUAHandler 3/7/2017 11:03:03 AM 17740 (0x454C)
Added Update Source ({B3CE6C4E-8947-43F7-9E10-275AFDD23DB8}) of content type: 2 WUAHandler 3/7/2017 11:03:03 AM 17740 (0x454C)
Scan results will include all superseded updates. WUAHandler 3/7/2017 11:03:03 AM 17740 (0x454C)
Search Criteria is (DeploymentAction=* AND Type='Software') OR (DeploymentAction=* AND Type='Driver') WUAHandler 3/7/2017 11:03:03 AM 17740 (0x454C)
Async searching of updates using WUAgent started. WUAHandler 3/7/2017 11:03:03 AM 17740 (0x454C)
Async searching completed. WUAHandler 3/7/2017 11:03:04 AM 8156 (0x1FDC)
OnSearchComplete - Failed to end search job. Error = 0x80244019. WUAHandler 3/7/2017 11:03:04 AM 17740 (0x454C)
Scan failed with error = 0x80244019. WUAHandler 3/7/2017 11:03:04 AM 17740 (0x454C)
everything else it's working fine, and I validated the WCM.log and WSUSCtrl.log and everything looks good with no errors. The managed machine even finds the WSUS server on https://servername.domain.local:8531and IIS binding has been configured with certs.
any ideas?
thanks

Share this post


Link to post
Share on other sites


figure this out.

 

turns out that there is a setting in the web.config file that needs to be changed manually.

  • Checked the Web.config file under location C:\Program Files\Update Services\WebServices\ClientWebService\
  • Checked <services> section and found that it was set to use "ClientWebServiceBinding" and not "SSL"

 

<services>

<service

name="Microsoft.UpdateServices.Internal.Client"

behaviorConfiguration="ClientWebServiceBehaviour">

<endpoint address=""

binding="basicHttpBinding"

bindingConfiguration="ClientWebServiceBinding"

contract="Microsoft.UpdateServices.Internal.IClientWebService" />

<endpoint address="secured"

binding="basicHttpBinding"

bindingConfiguration="ClientWebServiceBinding"

contract="Microsoft.UpdateServices.Internal.IClientWebService" />

</service>

</services>

 

  • Changed the value of "bindingConfiguration" to "SSL" in the above sections.

 

<services>

<service

name="Microsoft.UpdateServices.Internal.Client"

behaviorConfiguration="ClientWebServiceBehaviour">

<endpoint address=""

binding="basicHttpBinding"

bindingConfiguration="SSL"

contract="Microsoft.UpdateServices.Internal.IClientWebService" />

o <endpoint address="secured"

binding="basicHttpBinding"

bindingConfiguration="SSL"

contract="Microsoft.UpdateServices.Internal.IClientWebService" />

</service>

</services>

 

  • Performed IISRESET

hope this helps someone who runs into the same issue.

Share this post


Link to post
Share on other sites
On 7-3-2017 at 8:57 PM, gomezar said:

figure this out.

 

turns out that there is a setting in the web.config file that needs to be changed manually.

  • Checked the Web.config file under location C:\Program Files\Update Services\WebServices\ClientWebService\
  • Checked <services> section and found that it was set to use "ClientWebServiceBinding" and not "SSL"

 

<services>

<service

name="Microsoft.UpdateServices.Internal.Client"

behaviorConfiguration="ClientWebServiceBehaviour">

 

<endpoint address=""

binding="basicHttpBinding"

bindingConfiguration="ClientWebServiceBinding"

contract="Microsoft.UpdateServices.Internal.IClientWebService" />

<endpoint address="secured"

binding="basicHttpBinding"

bindingConfiguration="ClientWebServiceBinding"

contract="Microsoft.UpdateServices.Internal.IClientWebService" />

</service>

</services>

 

  • Changed the value of "bindingConfiguration" to "SSL" in the above sections.

 

<services>

<service

name="Microsoft.UpdateServices.Internal.Client"

behaviorConfiguration="ClientWebServiceBehaviour">

 

<endpoint address=""

binding="basicHttpBinding"

bindingConfiguration="SSL"

contract="Microsoft.UpdateServices.Internal.IClientWebService" />

o <endpoint address="secured"

binding="basicHttpBinding"

bindingConfiguration="SSL"

contract="Microsoft.UpdateServices.Internal.IClientWebService" />

</service>

</services>

 

  • Performed IISRESET

hope this helps someone who runs into the same issue.

You're a life saver :) Easy peazy with your instructions. On most forum posts I read to uninstall WSUS and reinstall. Thanks for taking your time to answer this question.

PS: I know it's an old topic, but just wanted to thank you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...