Jump to content


Sign in to follow this  
sysadmin101

Install Language Pack?

Recommended Posts

I have 2 identical task sequences to install Windows 10.

One installs the Japanese language pack, the other installs the Russian language pack.

 

The Japanese task sequence works perfectly - language pack is installed and Windows boots with all locale settings set as JA-JP.

Logs show:

Microsoft Deployment Toolkit version: 6.3.8443.1000
The task sequencer log is located at X:\WINDOWS\TEMP\SMSTSLog\SMSTS.LOG.  For task sequence failures, please consult this log.
ZTIPatches Entered  state. Deployment Method = SCCM
Operating system being deployed requires amd64 updates.
ConfigMgr patching state.
Load XML....
FindFile: The file Packages.xml could not be found in any standard locations.
Packages.xml not found.  Creating Packages.xml
Creating new Package: D:\_SMSTaskSequence\packages.xml
About to run command: expand "D:\_SMSTaskSequence\Packages\PRI00037\ja-jp\Microsoft-Windows-Client-Language-Pack_x64_ja-jp.cab" -F:update.mum "D:\_SMSTaskSequence\ZTIPatches.tmp"
Command has been started (process ID 756)
ZTI Heartbeat: command has been running for 0 minutes (process ID 756)
Return code from command = 0
     Create Package Item : Microsoft-Windows-Client-LanguagePack-Package
Adding non-language pack entries to unattend.xml

Found 1 matching non-language pack entries.
No <servicing> node found, adding a new one.
Add package {475CAEC0-1C7A-454E-9AEE-70754ABE5C96}
Copying package from D:\_SMSTaskSequence\Packages\PRI00037\ja-jp\Microsoft-Windows-Client-Language-Pack_x64_ja-jp.cab to D:\_SMSTaskSequence\Packages\Package_0001
Copy File: D:\_SMSTaskSequence\Packages\PRI00037\ja-jp\Microsoft-Windows-Client-Language-Pack_x64_ja-jp.cab to D:\_SMSTaskSequence\Packages\Package_0001\
Package {475CAEC0-1C7A-454E-9AEE-70754ABE5C96} added.
Ready to Save!
Adding language pack entries to unattend.xml
An existing <servicing> node was found.
Nothing to save, exit.
Language pack entries added to unattend.xml successfully

With the Russian task sequence, the language pack doesn't get install (and SCCM doesn't record the task sequence stop as having 'failed').

Logs (which has no errors) show:

Microsoft Deployment Toolkit version: 6.3.8443.1000
The task sequencer log is located at X:\WINDOWS\TEMP\SMSTSLog\SMSTS.LOG.  For task sequence failures, please consult this log.
ZTIPatches Entered  state. Deployment Method = SCCM
Operating system being deployed requires amd64 updates.
ConfigMgr patching state.
Load XML....
FindFile: The file Packages.xml could not be found in any standard locations.
Packages.xml not found.  Creating Packages.xml
Creating new Package: C:\_SMSTaskSequence\packages.xml
Unable to find the Packages.xml file, assuming there are no packages to inject.
Adding non-language pack entries to unattend.xml

Adding language pack entries to unattend.xml
No <servicing> node found, adding a new one.
Nothing to save, exit.
Language pack entries added to unattend.xml successfully
About to run command: dism.exe /Image:C:\ /Apply-Unattend:"C:\WINDOWS\panther\unattend\unattend.xml" /ScratchDir:C:\_SMSTaskSequence\Scratch /LogPath:X:\WINDOWS\TEMP\SMSTSLog\ZTIPatches_DISM.log
Command has been started (process ID 592)
ZTI Heartbeat: command has been running for 0 minutes (process ID 592)
  Console > Deployment Image Servicing and Management tool
  Console > Version: 10.0.14393.0
  Console > Image Version: 10.0.14393.0
  Console > The operation completed successfully.
Process completed with exit code 0
Return code from command = 0
Remove Folder: C:\_SMSTaskSequence\Scratch
ZTIPatches processing completed successfully.
Command line cscript.exe C:\_SMSTaskSequence\WDPackage\Scripts\ZTIPatches.wsf returned 0
ReleaseSource() for C:\_SMSTaskSequence\Packages\PRI00039.
reference count 1 for the source C:\_SMSTaskSequence\Packages\PRI00039 before releasing
Released the resolved source C:\_SMSTaskSequence\Packages\PRI00039
Process completed with exit code 0

Somehow the Japanese task sequence runs in D:\ while the Russian task sequence runs in C:\

Both task sequences were created identical - with Windows installing to C:\

Even the same Sysprep file is used - just that JA-JP is replced with RU-RU.

 

Yet the Russian task sequence has this log entry "Unable to find the Packages.xml file, assuming there are no packages to inject." and proceeds to create (what I assume is) an empty unattend.xml - as a result, it doesn't even try to install the language pack (because the unattend.xml file doesn't tell it to).

 

P.S. I have another Korean task sequence (identical except for locale options) - this works perfectly fine as well

 

What's so strange with Russian language packs?

Share this post


Link to post
Share on other sites


I set the unattend.xml file specified in 'Apply Operating System Image' step with hard-coded Russian locale:

<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <UILanguageFallback>en-US</UILanguageFallback>
            <InputLocale>ru-RU;0419:00000419;en-US;0409:00000409</InputLocale>
            <SystemLocale>ru-RU</SystemLocale>
            <UILanguage>ru-RU</UILanguage>
            <UserLocale>ru-RU</UserLocale>
        </component>

I verified that it is indeed Russian during OS installation in WinPE, in the following file:

C:\WINDOWS\panther\unattend\unattend.xml

 

But when it comes to the installing language pack step, it keeps returning this

FindFile: The file Packages.xml could not be found in any standard locations.
Packages.xml not found.  Creating Packages.xml
Creating new Package: C:\_SMSTaskSequence\packages.xml
Unable to find the Packages.xml file, assuming there are no packages to inject.
Adding non-language pack entries to unattend.xml

Adding language pack entries to unattend.xml
No <servicing> node found, adding a new one.
Nothing to save, exit.
Language pack entries added to unattend.xml successfully
About to run command: dism.exe /Image:C:\ /Apply-Unattend:"C:\WINDOWS\panther\unattend\unattend.xml" /ScratchDir:C:\_SMSTaskSequence\Scratch /LogPath:X:\WINDOWS\TEMP\SMSTSLog\ZTIPatches_DISM.log

Instead of:

Creating new Package: D:\_SMSTaskSequence\packages.xml
About to run command: expand "D:\_SMSTaskSequence\Packages\PRI00037\ja-jp\Microsoft-Windows-Client-Language-Pack_x64_ja-jp.cab" -F:update.mum "D:\_SMSTaskSequence\ZTIPatches.tmp"
Command has been started (process ID 756)
ZTI Heartbeat: command has been running for 0 minutes (process ID 756)
Return code from command = 0
     Create Package Item : Microsoft-Windows-Client-LanguagePack-Package

What is wrong?

I'm losing all my hair over this :(

I already specified UILanguage as RU-RU, why does the deployment ignore it and not try to install the Russian language pack?

Share this post


Link to post
Share on other sites

what does the

ZTIPatches_DISM.log

  tell you, can you attach it here

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...