Jump to content

Recommended Posts

Hello all. During OSD my task sequence is failing with error code 0x80004005 at the very end of "Apply Operating System". The attached smsts.log (smtsprobook) seems to indicate something funny going on with partitions?

Test Systems:

1. HP Prodesk 400 G3 SFF

2. HP Probook 430 G3


I have created a task sequence for deploying Windows 7 Enterprise X64 w/ SP1. This task sequence works great for the HP Prodesk. No issues at all. 

     Task Sequence Steps (in order):

  1. Capture Windows Settings
  2. Capture Network Settings
  3.     Install Operating System
  4. Restart in Windows PE
  5. Format and Partition Disk
  6. Apply Operating System
  7. Apply Windows Settings

The rest doesn't really matter since the task sequence is failing at "Apply Operating System" (On the HP Probook 430 G3)

This issue only occurs on the Probook (laptop) and NOT the Prodesk (desktop).

The way we are managing OSD here at my company is to have a "Golden" Task Sequence, then just copy that same task sequence for as many different model of systems we have and insert the corresponding driver package as well as rename the task sequence for whatever new model we discover we have or receive. 

So we received our new shipment of Probooks (laptops) and I did what I always do when we get a new model. I grabbed the Windows 7 drivers for it (Note: These systems come with Windows 10 installed. Our image is Windows 7 Enterprise x64 SP1.) and created/copied a task sequence for the new model by simply switching out whatever driver package was in the task sequence that I just copied with the correct package for that model (a lot of this is irrelevant since again, the task sequence is failing at "Apply Operating System" before it even tries to install drivers.)

Things I Have Done:

  1. Made sure all content called for in the task sequence is on the DP
  2. Deployed the TS as Available (PXE,Media,Blah blah) to All Unknown Computers
  3. Read through the provided smsts.log and could not make sense of it. Seems error 0x80004005 is a "beat around the bush" error 
  4. Created a task sequence from scratch then tested. Still same issue at the same place 
  5. Thought maybe its an issue with my .wim but I dont think so as this has worked on some of our other models tested
  6. Came here for help

I am at a total loss as of where to start to troubleshoot this error. Most of the info you will need to help asses the issue is probably contained in the log(CMTrace it). Please let me know of anything I left out that could help. Thank you!





Edited by JoinedForHelp

Share this post

Link to post
Share on other sites

Are you PXE booting these via legacy or UEFI? I have seen instances where if a device is PXE booted via legacy, but is operating with UEFI, that the format drive step can bugger things up and the apply OS step can't find the partition...but, network boot with UEFI and it formats correctly, and the OS is able to apply.

Also, there is this thread regarding UEFI PXE booting issues.

Share this post

Link to post
Share on other sites

Hi, I had exactly the same issue with SCCM OSD on a HPE DL360 Gen9 server. I disabled a PCI device that was not needed for booting, and then the task "Install Operating System" completed without error.
Before that, I tried correcting the RTC, deleting all Logical drives (arrays), switching between Legacy BIOS boot and UEFI optimized boot, all to no avail.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.