Jump to content


spyder

Unable to apply 1702 hotfix KB4018732

Recommended Posts

We we're early adopters of 1702, and when the hotfix (KB4018732) arrived I wanted to apply it. I started to download it, but when I checked back later it still says Available to download and every option is greyed out. See screenshot in link below.

http://i.imgur.com/FJkc5Iy.png

Is there an easy fix for this? SMS_EXECUTIVE is restarted (as well as the whole site server).


Cheers,
Pär

Share this post


Link to post
Share on other sites
On 2017-04-20 at 7:55 AM, ErikSteffens said:

I've got the same issue here.

Restart of the SMS_EXECUTIVE service or the whole site server doesn't solve the problem.

Anyone got an idea?


Did you start downloading the hotfix too?

Share this post


Link to post
Share on other sites
16 hours ago, Mottl Gergely said:

hello,

some problem here, do you find an Solution?

regards

No, I didn't. I haven't tried any more, actually.

Share this post


Link to post
Share on other sites
On 2017-04-20 at 7:55 AM, ErikSteffens said:

I've got the same issue here.

Restart of the SMS_EXECUTIVE service or the whole site server doesn't solve the problem.

Anyone got an idea?

 

On 2017-05-03 at 3:37 PM, Mottl Gergely said:

hello,

some problem here, do you find an Solution?

regards

 

Did any of you guys find a solution to this?
I tried with the latest update, KB4019926, but the problem is still there...

Share this post


Link to post
Share on other sites
10 hours ago, klcast said:

Any Update... I have the same issue here...

No, still nothing. One of our consultants will be looking into this tomorrow, I will let you know how it goes.

Share this post


Link to post
Share on other sites

I've contacted Microsoft support 3 weeks ago. They said because I used the Fast Ring option they do will not fix this issue.

But the options they gave me helped me find a way to finally update my Site Server. I did the following:

Delete the update records from the SQL Database:
- DELETE FROM CM_UpdatePackages WHERE PackageGuid='239E18DA-5872-47BF-93C5-9531A744C6F3'
- DELETE FROM CM_UpdatePackages WHERE PackageGuid='DBEF803D-D936-46B3-88FE-A5BDD7A03168'

239E18DA-5872-47BF-93C5-9531A744C6F3 is the guid of hotfix KB4018732
DBEF803D-D936-46B3-88FE-A5BDD7A03168 is the guid of hotfix KB4019926

Go to C:\Program Files\Microsoft Configuration Manager\EasySetupPayload and delete inside folders

Restart SMS_EXECUTICE server

Check for Updates from Console. Ussually it takes about 10 minutes. Don't click on Download Updates!!!

When the Updates appear, you should go to the properties of the Service Connection Point Role and change it to offline

Then use the service connection tool https://docs.microsoft.com/en-us/sccm/core/servers/manage/use-the-service-connection-tool to download the update files

It will download several CAB files. You need to extract the files from 239E18DA-5872-47BF-93C5-9531A744C6F3.cab or DBEF803D-D936-46B3-88FE-A5BDD7A03168.cab to C:\Program Files\Microsoft Configuration Manager\EasySetupPayload.
They need to be extracted in a subfolder with the GUID name.

After you got the files in place, you can turn back the properties of the Service Connection Point Role to online.

Now you can try to install the hotfix again. On my Site Server these steps result in installing the hotfix. I think it is not supported by Microsoft, but it worked for me. :rolleyes:

 

Hope this helps.

  • Like 1

Share this post


Link to post
Share on other sites

Interesting, ErikSteffens, I will try that asap.
I had found a similar solution, but it was lacking your last steps, from setting the Service Connection Point offline, so it didn't do anything here. But this looks promising!

Share this post


Link to post
Share on other sites

Oh well...
It turns out I can't set Service Connection Point to offline, since we have an Intune Subscription. And you can't run the Service Connection Tool without the role installed.

I will see what can be done tomorrow.

Share this post


Link to post
Share on other sites

can you check your Redist folder for any non-downloaded files, or files with 0 bytes, such as the file listed below

.. due to WindowsUpdateAgent x86 version not being downloaded

the Redist folder will be in a path such as ...but the GUID will most likely be different.

D:\Program Files\Microsoft Configuration Manager\CMUStaging\7B7E6E7B-3A61-4E84-A5E1-B5DCB514ADED\redist

 

  • Like 1

Share this post


Link to post
Share on other sites

The redist folder doesn't even exist here, only folders with what looks like country codes, like
 

D:\Program Files\Microsoft Configuration Manager\CMUStaging\DBEF803D-D936-46B3-88FE-A5BDD7A03168\0000041d

Also no redist folder under

...\EasySetupPayload\dbef803d-d936-46b3-88fe-a5bdd7a03168\



(the GUID is for KB4019926)

Share this post


Link to post
Share on other sites
On ‎6‎/‎27‎/‎2017 at 7:26 AM, ErikSteffens said:

I've contacted Microsoft support 3 weeks ago. They said because I used the Fast Ring option they do will not fix this issue.

But the options they gave me helped me find a way to finally update my Site Server. I did the following:

Delete the update records from the SQL Database:
- DELETE FROM CM_UpdatePackages WHERE PackageGuid='239E18DA-5872-47BF-93C5-9531A744C6F3'
- DELETE FROM CM_UpdatePackages WHERE PackageGuid='DBEF803D-D936-46B3-88FE-A5BDD7A03168'

239E18DA-5872-47BF-93C5-9531A744C6F3 is the guid of hotfix KB4018732
DBEF803D-D936-46B3-88FE-A5BDD7A03168 is the guid of hotfix KB4019926

Go to C:\Program Files\Microsoft Configuration Manager\EasySetupPayload and delete inside folders

Restart SMS_EXECUTICE server

Check for Updates from Console. Ussually it takes about 10 minutes. Don't click on Download Updates!!!

When the Updates appear, you should go to the properties of the Service Connection Point Role and change it to offline

Then use the service connection tool https://docs.microsoft.com/en-us/sccm/core/servers/manage/use-the-service-connection-tool to download the update files

It will download several CAB files. You need to extract the files from 239E18DA-5872-47BF-93C5-9531A744C6F3.cab or DBEF803D-D936-46B3-88FE-A5BDD7A03168.cab to C:\Program Files\Microsoft Configuration Manager\EasySetupPayload.
They need to be extracted in a subfolder with the GUID name.

After you got the files in place, you can turn back the properties of the Service Connection Point Role to online.

Now you can try to install the hotfix again. On my Site Server these steps result in installing the hotfix. I think it is not supported by Microsoft, but it worked for me. :rolleyes:

 

Hope this helps.

Thank you. I tried this and it did not work. I'm still stuck at installing... any other ideas before I call MS.

Share this post


Link to post
Share on other sites
1 hour ago, reys739 said:

Thank you. I tried this and it did not work. I'm still stuck at installing... any other ideas before I call MS.

I've got anyweb (site admin/owner?) looking into this right now. Will let you know what he finds.

Share this post


Link to post
Share on other sites

Well, my problem was probably very specific for our site. In short, the previous update to 1702 did not go as planned, and some parts still reported as being 1610.
A customized sql script provided by anyweb seems to have resolved the issue, at least the hotfix is now ready to install, so I will try that soon.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...