Jump to content

Recommended Posts

I'm trying to set up a task sequence to deploy Windows 10 via PXE to both UEFI and BIOS clients.

We have SCCM 2012 SP2 CU4 running on Server 2012 (not R2), with WDS 6.5.9200.16384, ADK 10.1.14393.0, and MDT 6.3.8443.1000.
It's s single site and single server.

PXE booting to BIOS clients seems to work fine.

When PXE booting UEFI client, it loads the boot file and then throws out 0xc0000225 complaining about \Windows\Syetem32\boot\winload.efi .

We're deploying the task sequence to the "Unknown Computers" group, and we only care about x64 clients.  The task sequence has an x64 boot image, and is the last task sequence deployed.

Do I have to do something special to allow both BIOS and UEFI clients to boot successfully at the same time (and using the same task sequence)?

I came across this video which sets up policies and defines different files to load based on vendor class, but I haven't tried any of it yet. 

We're using SCCM and not WDS directly, so I wasn't sure if it was appropriate.  Our DHCP server is the same as the SCCM site server, as well.  The only DHCP options I have set are 003 (Router), 006 (DNS Servers), 015 (DNS Domain Name), and 060 (PXEClient).


Share this post

Link to post
Share on other sites

I've tried defining the vendor classes and policies as described in the video, but I've had no luck.  I've also tried removing all of the DHCP options (60, 66, and 67) as well as defining 60 and 67 only (setting 67 to smsboot\x64\wdsmgfw.efi), but every combination results in the same 0xc0000225 error for a UEFI PXE booted VM, and the same "Succeed to download NBP" message (and then nothing) for a physical machine.

Could this be an issue with the boot image?  The PXE booting process loads boot.sdi instantly, then proceeds to load the x64 boot image.  This boot image was created using the "Create Boot Image using MDT" option within SCCM since the existing boot image broke after the upgrade to SCCM 2012 SP2 CU4.

The boot image works fine for BIOS booting.

I get the same result if I import a new x64 boot image using winpe.wim from the Windows 10 ADK and use that as the boot image on the task sequence (and again, deploy it to the group so it's loaded by the client).
I did find out from Resource Monitor that during the UEFI PXE process, C:\RemoteInstall\SMSBoot\x64\bootmgfw.efi is accessed (but I didn't see an access attempt for wdsmgfw.efi).

Share this post

Link to post
Share on other sites

This turned out to be as simple as hitting enter as soon as " Succeed to download NBP" was displayed.  I've added a PXE response delay to give us time to hit enter, but there's still no indication that you have to do so in order to continue with the network boot.

I'm not sure why it fails on a VM, but it works for a physical machine.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...