Jump to content


Windows 10 OSD - defaultuser0, Can't Log In

Recommended Posts

I'm trying to set up a task sequence to deploy Windows 10 via PXE.

We have SCCM 2012 SP2 CU4 running on Server 2012 (not R2), with WDS 6.5.9200.16384, ADK 10.1.14393.0, and MDT 6.3.8443.1000.
It's s single site and single server.

I'm building the image from the official v1607 Enterprise ISO in a VM, entering System Audit Mode and doing some minimal config, and then using a freshly-built SCCM Capture Media ISO to handle the sysprep and image capture.  Once captured, I create a basic (non-MDT) task sequence and deploy it as available to the unknown computers group for media and PXE only.

If I have the task sequence join the domain and install the Configuration Manager client, everything works fine.  I end up with an inaccessible defaultuser0 account on the machine, but I can log in with a domain account and do what I need to do / give it to a user.

However, if I have the task sequence not join the domain, then I can't log into the machine after the image is deployed.  It does the specialize pass and then does the "checking for critical updates" step, reboots, and then it gets to a login screen for "defaultuser0" and I can't log in.  I've checked on the source VM after another fresh build from the installation ISO, and the defaultuser0 account seems to get created as part of the Windows 10 Enterprise v1607 installation.  Even if I delete this account before capturing the image, the defaultuser0 account shows up after deployment.  (We do everything in system audit mode and do not create any accounts.)

I've tried setting the options within the task sequence to enable the admin account and set the password, but it's still not enabled and I can't do anything.  If I try restarting in safe mode or enabling the command prompt, the only account listed/selectable is "defaultuser0" and I can't log into it at all.

I've also tried adding net user command line steps to the task sequence to add a new local user and add it to the local administrators group, but this causes the task sequence to fail with 0x00000002.  The task sequence that doesn't join the domain also does not install configuration manager - this task sequences is for machines that will be off the domain and off the network and not centrally managed.  My guess is these steps can't run in the WinPE environment, but I was unable to find any relevant info in the smsts log.

If I could get the task sequence / capture media to trigger the standard OOBE, I think that would work fine for our purposes.  But I don't know how I can do that.  The capture media doesn't seem to have any options I can control for the sysprep step.
Could I just remove the "Apply Windows Settings" step in the task sequence entirely to achieve the same result?

Again, we're not using MDT because this is a simple, bare bones image and task sequence.  Our goal is to PXE boot and install Windows 10 Enterprise with updates and a few applications pre-installed.  For domain-joined machines, they get policy after booting into the OS and get all the other stuff that they get.  For machines off the domain, all we need is access to a local admin account so we can log in and do a light touch config, depending on each user.  If this isn't possible without MDT, then we'll look at creating the MDT packages and task sequences.


Share this post

Link to post
Share on other sites

I can add an account and add it to the local administrators group during audit mode, and that works fine.  Doing this also prevents the defaultuser0 account from being recreated during deployment.

This will be my workaround for now, I guess, through we'd prefer to enter OOBE after the task sequence applies the image (or have the actual administrator account available).

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.