Jump to content

Recommended Posts

Hello everyone,

I'm currently trying to learn about SCCM and deploying Windows 10 using PXE and MDT, however my clients never seem to get to the task sequence part, instead they just reboot when it says "Preparing network connections". I am able to stop the reboot by pressing F8 and it shows I have an ip, disk looks good using diskpart, can ping sccm fqdn and I'm able to use net use to map a share.

I have crawled every possible forum and posts and nothing seems to help, and I really feel like everything is correct and should be working. I hope to get some help from you experts.

  • The clients I have tried to deploy to are a Dell Optiplex 7040 client and Vmware VMs. I downloaded all the necessary drivers for the Optiplex 7040 and the vmxnet3 driver for the VM which I injected into the WinPE x64 boot image. I also tried to PXE boot without any driver in the boot image.
  • I created a user in AD named SCCM_NAA which has been used as the network access account.
  • The firewall has been completely turned off on the SCCM server.
  • Deployed task sequence to All unknown computers and a collection called Windows 10 Deployment containing PC02.

SMSTS.log (included in post) - All clients always show the same three possible errors
PxeGetPxeData failed with 0x80070005
RegOpenKeyExW is unsuccessful for Software\Microsoft\SMS\Task Sequence
GetTsRegValue() is unsuccessful. 0x80070002.

The guide I've been using to set everything up this one:

Lab setup is as follows, all MSDN media:
SCCM01 - SCCM Server 1702 - Server 2016
SQL01 - SQL Server for SCCM - SQL Server 2016
DC01 & DC02 - AD, DNS and DHCP set up with option 066 and 067 configured pointing to the SCCM server and SMSboot\x64\wdsnbp.com
Dell OptiPlex 7040 - Client
PC02 (VM) - Member of SCCM server as a client
PC03 (VM) - Newly created VM with no OS, but has a virtual HDD attached

Boot image and operating system image

Task sequence





Edited by Robhar

Share this post

Link to post
Share on other sites

In the end I decided to say fuck it and deleted my servers. I've set up a completely new environment and patched SCCM from 1702 to 1706 and applied a hotfix that was available in the SCCM console, all before doing anything else on the newly created server.

Configured everything as it was before and the first VM I tried now see the task sequence and is applying it as we speak.

Lesson learned? Don't be hasty and patch your shit.

Share this post

Link to post
Share on other sites

Hi All, If you still having the same issue even after updating NIC driver, please follow steps below. 


Copied boot.wim to c:\Mount (boot image that you selected for bootable media creation - Location :- Click on boot image properties and then the location will be in 'data source' tab) 

start the Deployment Imaging and Tools Environment cmd prompt (Run as Administrator)

Created new directory C:\WinPEMount\x64 and mount the boot.wim to this directory using the following command

dism /mount-wim /wimfile:c:\mount\boot.wim /index:1 /mountdir:c:\winpemount\x64

Open the folder c:\winpemount\x64 and check whether it has sms folder available. If it has SMS folder then it should have bin, boot and data folder under it. 

If one of these folders missing, you need to copy it from the bootable usb and paste it in the root of sms folder. Please follow steps below

Created a sccm bootable media usb from which task sequence can be run and image the machine successfully.

Explore the USB and copy date folder (in my case data folder wasn't available in mounted directory) and paste it to the root of the sms folder in mounted boot.wim

unmount the boot.wim using command below

dism /unmount-wim /mountdir:c:\WinpeMount\X64 /commit

copy the c:\mount\boot.wim and paste it on the location where you copied the original boot.wim from (you need to rename existing boot.wim to boot_old.wim befor pasting the new boot image)

Update the boot image to the distribution point and thats it.

PXE boot shouldn't fail on 'preparing network connection' stage now.

Happy imaging!!!!!

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...