Jump to content


standalone wds works but pxe not on windows server 2016

Recommended Posts

Hello All,

I am following the SCCM CB guide by Niall Brady.

AD01 - DC+DHCP+DNS -running WS 2016

CM01 - SCCM +PXE -running WS 2016, SCCM CB 1702, ADK 1702, SQL 2016

I am facing weird issue while setting up OS deployment.. The PXE server is not responding to unknown computers. I have done below to rectify the issue:

  • Manually imported MAC and GUID into SCCM
  • Removed WDS server manually, deleted RemoteInstall folder,Restarted SCCM server. Re-enabled WDS then PXE role re-added.
  • Ensured Boot WIM is deployed to DP from DataSource Tab making it availbale for PXE booting

Still when I boot Gen1 or Gen2 Hyper-V machine, no PXE booting happens. I am seeing DHCP Failed message on screen while DHCP is functional.

I even tried same setup using Virtualbox thinking issue with Hyper-v but issue persists on VirtualBox as well.

What I observed that if I setup below, standalone WDS works flawlessly, machines are getting IP address, boot images are downloading.

AD01 - DC+DHCP+DNS (running WS 2016)

WDS01 - WDS (running WS 2016)

Not sure, what happens when PXE is enabled. This was always worked earlier but recently facing issue when tried on SCCM CB 1702/1706/1710.

Any help is highly appreciated as I am wasting countless hours troubleshooting this since last week.



Share this post

Link to post
Share on other sites

Hi Niall,

Thanks but fortunately issue got resolved now. I confirmed on Hyper-v and Virtual box as well.

Apparently issue was with wds installation done by pxe. When I installed wds manually, it worked. But I have tried this earlier also bu not worked but this time I tried step by step and it worked.

Thanks again.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.