Jump to content


Recommended Posts

I am running into issues with enabling HTTPS for my site.

All my clients are utilizing a PKI certificate, my DP is using a certificate that meets the requirements.

I first switch my MP to HTTPS, and no errors in logs on the server, however, communication between server-client doesn't work.
I checked CCMmessaging.log and these are the errors.
 

Raising event:
instance of CCM_CcmHttp_Status
{
	ClientID = "GUID:39c25844-fdcd-4128-ad02-afbbbb7da681";
	DateTime = "20180306185215.125000+000";
	HostName = "Servername-hidden";
	HRESULT = "0x87d0027e";
	ProcessID = 724;
	StatusCode = 403;
	ThreadID = 300;
};
	CcmMessaging	3/6/2018 12:52:15 PM	300 (0x012C)
Successfully queued RefreshSecuritySettingsEvent event.	CcmMessaging	3/6/2018 12:52:15 PM	300 (0x012C)
Successfully queued event on HTTP/HTTPS failure for server 'Servername-hidden'.	CcmMessaging	3/6/2018 12:52:15 PM	300 (0x012C)
Post to http://Servername-hidden/ccm_system_windowsauth/request failed with 0x87d00231.	CcmMessaging	3/6/2018 12:52:15 PM	300 (0x012C)
[CCMHTTP] ERROR: URL=http://Servername-hidden/ccm_system/request, Port=80, Options=480, Code=0, Text=CCM_E_BAD_HTTP_STATUS_CODE	CcmMessaging	3/6/2018 1:14:47 PM	4980 (0x1374)
Raising event:
instance of CCM_CcmHttp_Status
{
	ClientID = "GUID:39c25844-fdcd-4128-ad02-afbbbb7da681";
	DateTime = "20180306191447.628000+000";
	HostName = "Servername-hidden";
	HRESULT = "0x87d0027e";
	ProcessID = 724;
	StatusCode = 503;
	ThreadID = 4980;
};
	CcmMessaging	3/6/2018 1:14:47 PM	4980 (0x1374)
Successfully queued event on HTTP/HTTPS failure for server 'Servername-hidden'.	CcmMessaging	3/6/2018 1:14:47 PM	4980 (0x1374)
Post to http://Servername-hidden/ccm_system/request failed with 0x87d00231.	CcmMessaging	3/6/2018 1:14:47 PM	4980 (0x1374)
[CCMHTTP] ERROR: URL=http://Servername-hidden/ccm_system/request, Port=80, Options=480, Code=0, Text=CCM_E_BAD_HTTP_STATUS_CODE	CcmMessaging	3/6/2018 1:16:47 PM	11316 (0x2C34)
Raising event:
instance of CCM_CcmHttp_Status
{
	ClientID = "GUID:39c25844-fdcd-4128-ad02-afbbbb7da681";
	DateTime = "20180306191647.300000+000";
	HostName = "Servername-hidden";
	HRESULT = "0x87d0027e";
	ProcessID = 724;
	StatusCode = 503;
	ThreadID = 11316;
};
	CcmMessaging	3/6/2018 1:16:47 PM	11316 (0x2C34)
Successfully queued event on HTTP/HTTPS failure for server 'Servername-hidden'.	CcmMessaging	3/6/2018 1:16:47 PM	11316 (0x2C34)
Post to http://Servername-hidden/ccm_system/request failed with 0x87d00231.	CcmMessaging	3/6/2018 1:16:47 PM	11316 (0x2C34)

 

So, I went ahead and switched the MP back to HTTP, and the clients still cannot communicate with the server. 

Help please.

 

excerpt_ccmmessaging_log.log

Share this post


Link to post
Share on other sites
>>> Selected Certificate [Thumbprint 9d93c668ac7b318448c5e7e97fe6dca10984b6e7] issued to 'server-name-hidden' for HTTPS Client Authentication	SMS_MP_CONTROL_MANAGER	3/6/2018 1:00:38 PM	13240 (0x33B8)
Failed to send http request /SMS_MP/.sms_aut?MPLIST. Error 12030	SMS_MP_CONTROL_MANAGER	3/6/2018 1:00:38 PM	13240 (0x33B8)
Call to HttpSendRequestSync failed for port 443 with 12030 error code.	SMS_MP_CONTROL_MANAGER	3/6/2018 1:00:38 PM	13240 (0x33B8)

Mpcontrol.log error message when switched to HTTPS

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...