Jump to content


Push HP BIOS Settings via OSD (Windows 10)

Recommended Posts

Hi guys,

Hoping to find people that have managed to push HP BIOS settings via OSD (Windows 10), I've pretty much followed this guide (only the folder structures are slightly different) but I'm having issues actually deploying the settings, setting the BIOS password seems to work okay and I've read that for certain TPM settings to be pushed then a BIOS password must be set prior.

My folder setup:




BIOS Config settings to push:

BIOSConfig 1.0
;     Originally created by BIOS Configuration Utility
;     Version:
;     Date="2018/03/20" Time="14:53:23" UTC="0"
;     Found 215 settings
Virtualization Technology (VTx)
    Reset to default
TPM Reset to Factory Defaults
Reset of TPM from OS
OS Management of TPM
Activate TPM On Next Boot
TPM Device
TPM Activation Policy
    F1 to Boot
    Allow user to reject
    *No prompts
TPM Device Security Level
OS Management of TPM Security Level
Reset of TPM from OS Security Level

Task sequence setup:



The bios password sets just fine, but in the SMSTS log I see the following for BIOS settings - HP EliteBook 840 G2 itself:


Have attached the SMSTS.log.

Any help would greatly be appreciated, I've been working on this for the last couple of days without success, I've tried:

  • Adding CMD.exe /C prefix (same error)
  • Changing the format of the file to repset (same error)
  • Ran the command manually on the device and works just fine with the same configuration files (as .txt and .repset)
  • Tried running the steps in WinPE rather than in the operating system (same error)

Thanks in advance.


Share this post

Link to post
Share on other sites

48 minutes ago, Ath3na said:

should the command be something like ?

biosconfigutility.exe /CurSetupPasswordFile:"passwordfile.bin" /setconfig:Elitebook820.REPSET

Ours are like this.

The password is set at an earlier stage, both occur during winpe

Exactly as this post says. The manual refers to the proper config file that is .REPSET


Additionally, I believe I ran into this issue with my Elitebook 8560P. What I did was use the bios tool to extract the current REPSET, and then ensure that the commands I am using match what my existing configuration file says. I found that some of the setting names didn't match what the instructions said.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.