Jump to content


CaptHelpful

Updating Boot Images - how far do I take it?

Recommended Posts

I'm using SCCM 1710 and have been having the following error happen part way through the TS.  This is from the SMSTS.log

Quote

Argument 3 is invalid.    OSDDriverClient    4/18/2018 8:36:40 AM    1908 (0x0774)
ParseArguments( argc, argv, eDriverOperation, sPackageId, pBootCriticalInfo, bAllowUnsigned, bBestMatch ), HRESULT=80070057 (e:\nts_sccm_release\sms\client\osdeployment\osddriverclient\osddriverclient.cpp,341)    OSDDriverClient    4/18/2018 8:36:40 AM    1908 (0x0774)
Failed to pass arguments. Code 0x80070057    OSDDriverClient    4/18/2018 8:36:40 AM    1908 (0x0774)
Exiting with return code 0x80070057    OSDDriverClient    4/18/2018 8:36:40 AM    1908 (0x0774)
Process completed with exit code 2147942487    TSManager    4/18/2018 8:36:40 AM    1464 (0x05B8)
!--------------------------------------------------------------------------------------------!    TSManager    4/18/2018 8:36:40 AM    1464 (0x05B8)
Failed to run the action: Apply Yoga 2 Drivers. This is usually caused by a problem with the program. Please check the Microsoft Knowledge Base to determine if this is a known issue or contact Microsoft Support Services for further assistance.
The parameter is incorrect. (Error: 80070057; Source: Windows)    TSManager    4/18/2018 8:36:40 AM    1464 (0x05B8)

This link, https://support.microsoft.com/en-us/help/4096313/the-apply-driver-package-task-fails-with-error-80070057 says to update my Boot Images to my DP's and I've done that with my main PXE boot image, however I was a bit scared to go all the way.  

1254684

 

With such a large difference between the current ADK - 10.0.16299.0 - and the current production client ver. - 5.00.8577.1115 - I'm wanting some reassurance and guidance.  

I have several different Boot images, some of which are stored in the default directory ( \\servername>\SMS_<sitecode>\osd\boot\<x64>, which should mean they are being updated when I update SCCM) and others which are custom boot images.  However, when I go to update the DP, an option for both types shows up that's not covered anywhere and I'm a bit nervous to go forward with.
1st, why is there such a large range on the default boot images?  

2nd, I've done the update on my default boot image (without reloading to the current WinPE ver of the ADK) and still had the same error.  Does that point to needing to reloading, or do I need to update all the boot images as well (I came into this environment after it had been set up already and are still using the previous TS.)

3rd, do I need to update any of the TS themselves after doing this update?  I know some are using old MDK packages...

Thanks for the help in advance.

Share this post


Link to post
Share on other sites


Update - I tried just updating the DP's on all the boot images I had, without doing the client update.  Still got errors.  I tried turning off the 2 images that were broadcasting PXE and still got the error.

The fix - I changed the boot image that my TS was using for PXE (under properties > advanced tab) to the default image that was updated already.  Fixed all my ills...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...