Jump to content


rmags

SOLVED Installing .NET 3.5 inside TS with DISM

Recommended Posts

I'm having issues installing this inside the TS for a windows 10 1709 WIM. I was trying to following these two posts to implement it with no luck. Here's a snipit of the smsts:

Cannot perform a cyclic copy

Failed to run the action: Copy Files. 
The system cannot open the file. (Error: 00000004; Source: Windows)    TSManager    5/16/2018 9:09:29 AM    1612 (0x064C)

 

RupI5vN.png?1

EDPdAaj.png

 

 

Any idea?

 

Thanks

smsts.txt

Edited by rmags

Share this post


Link to post
Share on other sites


I have this working in my TS OSD. I setup mine differently than what you noted above.  Here is what I have:

 

1) Create a TS for the powershell ps1 file call

2) Create the TS for the OSD

 

Pics: location of 2 files; data in my ps1; TS for the OSD

2018-05-17_13-05-50.jpg

2018-05-17_13-06-05.jpg

2018-05-17_13-04-37.jpg

  • Like 1

Share this post


Link to post
Share on other sites
  1. Create a Package with the cab file
  2. Create a run Command Line Step
    1. Select the created Package
    2. Set as Command line:
      DISM.EXE /online /add-package /packagepath:.\relative\Path\to\dotNetFile.cab

Example:
(In this case the cab file is at the root directory of the package)

image.png.5e132b6723c5edcf0fdd0bde8a43527c.png

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...