Jump to content


anyweb

sample XP to Windows 7 task sequences

Recommended Posts

Hi,

 

I have imported xml file (on SMP) on my SCCM 2007 R2 SP2 but i have this error below although the task marked successfull in RAP and nothing happen :

 

Capture User State State Capture 11135 The task sequence execution engine failed executing an action

 

 

Also you can find logs of my test workstation, a help will be appreciate because i will migrate 200-250 computers if it works fine, thanks for all

smsts.log

loadstate.log

scanstate.log

Share this post


Link to post
Share on other sites

Well... its a pretty straight forward proces... when the OSDStateStorePath is being used it wil be untouched during a disk wipe.

 

For another Hardlink only example take a look here: http://www.petervanderwoude.nl/post/ConfigMgr-2007-USMT-40-and-using-Hard-Links.aspx

For another Hardlink and Offline example take a look here: http://www.petervanderwoude.nl/post/Capture-User-Files-and-Settings-Offline-(WinPE)-or-Online-(FullOS)-with-ConfigMgr-2007.aspx

 

Peter,

 

Some great stuff published at those links...it is just what I am looking for! Do you have those associated task sequences published anywhere? I am especially interested to see how you are setting the architecture. Any help is greatly appreciated!

Share this post


Link to post
Share on other sites

I have been trying to get the hardlink version work after numerous tries, I cant get to get it work and hopefully someone here can help me figure out.

 

I created a new collection, manually added an existing WinXP SP3 machine to it and advertised the task sequence to the collection.

 

The task sequence stops working at the beginning of "Applying Image State" and smsts.log shows a 2 errors (1.Error# 80072ee7 which is not getting IP I guess & 2. cannot connect to install.wim file)

 


  • [1]
    8/1/2011 7:11:43 PM Error. Received 0x80072ee7 from WinHttpSendRequest.
    8/1/2011 7:11:43 PM unknown host (gethostbyname failed)
    8/1/2011 7:11:43 PM hr, HRESULT=80072ee7 (e:\nts_sms_fre\sms\framework\osdmessaging\libsmsmessaging.cpp,7714)
    8/1/2011 7:11:43 PM sending with winhttp failed; 80072ee7
    8/1/2011 7:11:43 PM Will retry in 5 second(s)
    8/1/2011 7:11:48 PM Retrying...
     
    ----After 5 tries-----
     
    8/1/2011 7:13:09 PM End of retries
    8/1/2011 7:13:09 PM Send (pReply, nReplySize), HRESULT=80072ee7 (e:\nts_sms_fre\sms\framework\osdmessaging\libsmsmessaging.cpp,2052)
    8/1/2011 7:13:09 PM failed to send the request
    8/1/2011 7:13:09 PM DoRequest (sReply, false), HRESULT=80072ee7 (e:\nts_sms_fre\sms\framework\osdmessaging\libsmsmessaging.cpp,3835)
    8/1/2011 7:13:09 PM Failed to send status message (80072ee7)
    8/1/2011 7:13:09 PM smStatusMessage.Send(), HRESULT=80072ee7 (e:\nts_sms_fre\sms\client\tasksequence\executionengine\utility.cxx,529)
    8/1/2011 7:13:09 PM Non fatal error 0x80072ee7 in sending task sequence execution status message to MP
     
     
    [2]
    8/1/2011 7:13:26 PM Connecting to "\\WIN2K8-B.MIAMIKK.COM\SMSPKGC$\KK10000E"
    8/1/2011 7:13:26 PM Failed to connect to "\\WIN2K8-B.MIAMIKK.COM\SMSPKGC$\KK10000E" (1231). Retry in 12 seconds.
     
    --After about 5-7 tries---
    8/1/2011 7:15:12 PM Failed to connect to "\\WIN2K8-B.MIAMIKK.COM\SMSPKGC$\KK10000E" (1231).
    8/1/2011 7:15:12 PM reconnect(), HRESULT=800704cf (e:\nts_sms_fre\sms\framework\tscore\tsconnection.cpp,129)
    8/1/2011 7:15:12 PM connect(pszPath, pszAccount, pszPassword, L"", uFlags), HRESULT=800704cf (e:\nts_sms_fre\sms\framework\tscore\tsconnection.cpp,148)
    8/1/2011 7:15:12 PM Failed to access the share \\WIN2K8-B.MIAMIKK.COM\SMSPKGC$\KK10000E\ with network access account
    8/1/2011 7:15:12 PM !sAccessibleSource.empty(), HRESULT=80070002 (e:\nts_sms_fre\sms\framework\tscore\resolvesource.cpp,2392)
    8/1/2011 7:15:12 PM Failed to find an available source location
     
     
    8/1/2011 7:15:12 PM Installation of image 1 in package KK10000E failed to complete..
    The system cannot find the file specified. (Error: 80070002; Source: Windows)
     

 

The whole setup is in a VMWare Workstation. I can't figure out the reasons for these 2 issues. DNS/DHCP seems to be working fine. I am using domain admin account for everything and I am install OS on a bare-metal machine with same login/install.wim file without access problem.

 

Any help is really appreciated.

Share this post


Link to post
Share on other sites

I have tried to import the SMP xml file with no success. It says it successfully imported it, but its not there. So I have created a USMT package and 2 task sequences: one for capture and the other for restore. We have another imaging tool that we use so I will not be using MDT, I just want to use SCCM to capture and restore user data. After advertising this to my collection, I try running from Run Advertised Programs but I get the following message:

The requested software cannot be located.

 

I've updated my DP. I have also attached screen shots of my setup and error message. Can someone provide me with some direction? Im sure I am doing something wrong. Thanks.

post-11343-0-07188000-1314626228_thumb.png

post-11343-0-48796300-1314626311_thumb.png

post-11343-0-65558000-1314626314_thumb.png

Share this post


Link to post
Share on other sites

check the root of task sequences, refresh, do you see the imported task sequence now ?

Share this post


Link to post
Share on other sites

Thanks for the example. I used the hardlinking example as some profiles have large PST files stored within them.

 

I ran in to 1 minor issue, if you don't reset the computer account on AD then of course the machine will not join again. Some of our deployment guys were deleteing machines (which was most helpful) and then of course losing the group memberships.

 

I added a TS step using Netdom, part of the remote tools set available here http://www.microsoft...lang=en&id=7887 as SCCM SP2 uses winpe3 (win 7). Just copy the exe to a package and then run the command netdom reset machinename /domain:domainname

 

Hope that helps anyone running into issues re-joining the machine back to domain.

 

Thanks again

Share this post


Link to post
Share on other sites

Hi guys,

 

I was able to import the hardlink TS provided by anyweb, and it ran through fine with no errors. However, nothing was restored. The computer name stayed the same, and the "StateStore" folder is still in C. Everything else look like a fresh install of Win 7.

 

Note - we do redirect the user profiles to D in our XP and Win 7 images. I'm not sure if that is causing the problem, or I'm missing something else.

 

Thanks.

Share this post


Link to post
Share on other sites

I was unable to download the sample of .xml file (hardlink & SMP)..

 

I was planning to migrate Windows XP to Windows 7, without formatting the drive D, but before that I want to copy some important file from c:\windows\system32\ccm\inventory\a.mif file to D:\backup\

 

How can I do this, can anyone tell me how I want to create the TS?

Can I use the USMT package?

 

Please guide me :(

Share this post


Link to post
Share on other sites

Ok not sure if someone will beat me to it, hardlink is always a good option as its quick as no data is copied however if you have full device encryption like us you will have to first remove the encryption. And in our case then chain it to a desk in a locked room...

 

You need setup 3 TS variables with the following values, as follows:

OSDStateStorePath - %_SMSTSUserStatePath%

OSDMigrateAdditionalCaptureOptions - /hardlink /nocompress

OSDMigrateAdditionalRestoreOptions - /Hardlink /nocompress

 

After those 3 variables place a Capture User State step and select your USMT package (if you don't have use MDT to create one) and then select the 'radio button customize how user profiles are captured' and add the following files:

migapp.xml

migdocs.xml

miguser.xml

 

Now for capturing your MIF file, I have not tested this but it should work in theory as always test before going live. Add additional step of run command line and enter copy "c:\windows\system32\ccm\inventory\a.mif" "%OSDStateStorePath%\a.mif" /v /y this should then copy the file to the same as the hardlinked files.

 

Now restart in PE, do the normal for applying the windows 7 image but don't use the format and partition disk as the disk has a partition everything will be wiped apart from the hardlinked folder.

 

At the end a step Restore User State again add the USMT package, restore all captured user profiles with standard options. And of course copy back your a.mif file to the directory of choice.

 

That is how to do it with hardlinking.

 

This information has been taken from the example file attached at the beginning of the post. We have 1 additional step, I have created a VB script that resets the machine account on AD before restarting in PE so that the same machine account can be used to save having to re-add the machine to all the groups it once belonged to again.

 

I hope that helps you.

Share this post


Link to post
Share on other sites

I used the sample of hardlink TS but it seems like the profiles and files (excel, word, powerpoint, pst) is failed to restore. I don't know what is wrong :(

 

For Capture User State and Restore User State when I add the USMT package (x86 and x64), I choose to restore all captured user profiles with standard options only. But, I had change the miguser.xml file under USMT4.01 folder. Is this step ok?

 

Really appreciate any advice from expert!!

Share this post


Link to post
Share on other sites

Hi Peter,

My .wim file is installed on another partition instead of C: (Where XP installed), means after Win 7 installed i have found installation dir d: instead of C: drive i am not using any sysprep or unattend.xml file as mentioned at top portion anyweb comments " you don't need it, it's nothing more than a customised unattend.xml file which you can Deploy 7 without "

Share this post


Link to post
Share on other sites

Thanks for great samples - my hardlinking works great, but I Cannot make it work with SMP.

 

Is there a minimalist TS ? I have my Win 7 deployment TS working. All I need is to Migrate the data.

 

I thought I can

- capture existing machine with USMT4 to SMP

- Deploy 7

- restore settings /files from SMP

 

Could you tell me where I am wrong?

 

Thanks!

Share this post


Link to post
Share on other sites

Thanks for quick reply! I am using the built in steps, but the shared directory on SMP is empty. Thanks for the note, but I am not using the combination of the methods.

 

I must do something wrong.

My steps are these:

 

Request state store

Capture User Files And Settings (with USMT4)

Release state store

 

Install OS System (restart in win pe, partition disk, apply os, apply windows settings, apply network settings)

setup Config manager

 

Restore User Files and Settings

 

Thanks again for the help.

Share this post


Link to post
Share on other sites

Using this method, how do I specify the name I want the new machine to have?

 

In Create New Computer Association, it doesn't seem like I can just type the desired name of the machine (assuming an in-place upgrade from XP to 7)

 

Edit: I figured it out, turns out you create your new computer record first, then create the New Computer Association afterwards.

 

In SCCM, Click: Computer Management -> Operating System Deployment -> Computer Association, and Right-Click, then Import Computer Information.

 

In the next window, choose Import Single Computer, and specify the Name and MAC or SMBIOS GUID of your desired new PC. You can also choose your Source Computer in the same window.

 

This will create a Computer Association between the old and new PC, which allows USMT to know which PC's to allow Backup and Restore on.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...