Jump to content


LemonEistee

Admin Console not loading and WMI Errors

Recommended Posts

Hello,

 

I have the problem with my SCCM that I cannot open the Administration Console anymore.

The last think I have do bevor it don't works anymore was to fix my 0% downloading from Software Center Problem.

I have tried these steps from Arthur_Li (because the fix with the .mof files don't work for me)https://social.technet.microsoft.com/Forums/windows/en-US/df00b2e4-3bab-4b46-ad5a-95e82617a039/wmi-errors?forum=winserverNIS

Here are the SMSAdmin Logs:

[19, PID:1928][10/11/2018 08:50:07] :Transport error; failed to connect, message: 'The SMS Provider reported an error.'\r\nMicrosoft.ConfigurationManagement.ManagementProvider.WqlQueryEngine.WqlQueryException\r\nThe SMS Provider reported an error.\r\n   at Microsoft.ConfigurationManagement.ManagementProvider.WqlQueryEngine.WqlQueryResultsObject.<GetEnumerator>d__74.MoveNext()

[19, PID:1928][10/11/2018 08:50:07] :Transport error; failed to connect, message: 'The SMS Provider reported an error.'\r\nMicrosoft.ConfigurationManagement.ManagementProvider.WqlQueryEngine.WqlQueryException\r\nThe SMS Provider reported an error.\r\n   at Microsoft.ConfigurationManagement.ManagementProvider.WqlQueryEngine.WqlQueryResultsObject.<GetEnumerator>d__74.MoveNext()

   at Microsoft.ConfigurationManagement.AdminConsole.SmsSiteConnectionNode.GetConnectionManagerInstance(String connectionManagerInstance)\r\nConfigMgr Error Object:

instance of __ExtendedStatus
{
Operation = "ExecQuery";
ParameterInfo = "SELECT * FROM SMS_Site WHERE SiteCode = 'PS0'";
ProviderName = "WinMgmt";

}

Error Code:

ProviderLoadFailure

[19, PID:1928][10/11/2018 08:50:07] :Transport error; failed to connect, message: 'The SMS Provider reported an error.'\r\nMicrosoft.ConfigurationManagement.ManagementProvider.WqlQueryEngine.WqlQueryException\r\nThe SMS Provider reported an error.\r\n   at Microsoft.ConfigurationManagement.ManagementProvider.WqlQueryEngine.WqlQueryResultsObject.<GetEnumerator>d__74.MoveNext()

 

I have tried to reinstall the console with the AdminConsole.msi but this don't work.

Also I have tried to connect with my IP, but also no success.

The complete D drive where SCCM is installed, the SMSAdmins Group has "Full control" permissions. At this group are all user where can connected to the server and the server itself.
All sms services are running.

 

One think I found out is that my wmi maybe don't work right.

At another Topic (https://www.windows-noob.com/forums/topic/10298-applications-suddenly-wont-deploy-hung-stuck-at-0-downloading/) they tried "Run the query select * from sms_sci_component where componentname=SMS_DISTRIBUTION_MANAGER" to fix the wmi problem, but if I try this query I get the following error:

Number: 0x80041017
Facility: WMI
Description: Invalid query

 

Could it be that this query is only for 2012?

At the wmiprov.log I get this error by trying to open the Console from SCCM:

(Wed Oct 10 10:16:42 2018.780762406) : WDM call returned error: 5

 

The WMIDIAG Log is attach below :)

 

 

WMIDIAG-V2.2_2K12R2.SRV.RTM.64_SRV-SCCM_2018.10.12_09.52.41-REPORT.TXT

Edited by LemonEistee

Share this post


Link to post
Share on other sites


The Problem is, if I go to wmimgmt.msc -> right click "Properties" -> "Backup/Restore" and restore the old WMI data, the console opens up normal but I get the 0% downloading failure at the Software Center. If I recreate the WMI, I can't open the console anymore...

The SMSProv Logs are interesting... The last entry is from 10.10.2018 even though I have opened the console since this a lot (for trying). The last error entry was this:

(Bevor the error):

CSspQueryForObject :: Execute...

Execute WQL  =select * from SMS_ObjectContentExtraInfo WHERE ObjectID = "ScopeId_9D851C9F-A2EB-4606-BC35-9A166A60EA59/Application_4a496941-ed50-437e-9f9f-4d8e210e0ed5"

Error (was red):

Execute SQL =select  all

SMS_ObjectContentExtraInfo.DateCreated,SMS_ObjectContentExtraInfo.Description,
SMS_ObjectContentExtraInfo.FeatureType,SMS_ObjectContentExtraInfo.LastUpdateDate,
SMS_ObjectContentExtraInfo.NumberErrors,SMS_ObjectContentExtraInfo.NumberInProgress,
SMS_ObjectContentExtraInfo.NumberInstalled,SMS_ObjectContentExtraInfo.NumberUnknown,
SMS_ObjectContentExtraInfo.ObjectID,SMS_ObjectContentExtraInfo.ObjectType,SMS_ObjectContentExtraInfo.
ObjectTypeID,SMS_ObjectContentExtraInfo.PackageID,SMS_ObjectContentExtraInfo.SoftwareName,
SMS_ObjectContentExtraInfo.SourceSite,SMS_ObjectContentExtraInfo.SourceSize,
SMS_ObjectContentExtraInfo.SourceVersion,SMS_ObjectContentExtraInfo.
Targeted from fn_ListObjectContentExtraInfo(1033) AS SMS_ObjectContentExtraInfo  
where SMS_ObjectContentExtraInfo.ObjectID = N'ScopeId_9D851C9F-A2EB-4606-BC35-9A166A60EA59/Application_4a496941-ed50-437e-9f9f-4d8e210e0ed5'
Edited by LemonEistee

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...