Jump to content


"Invalid" content on a Distribution Point. Force a re-distribution?!

Recommended Posts

Hi all,

A problem that seems to be occurring more and more frequently in the environment I'm currently working in is content not successfully distributing to Distribution Points.  We have over 130 secondary site servers in the environment and it's common to find "Invalid" content when using the Content Library Explorer tool.

If a piece of content is "Invalid" I normally can't successfully remove it via the SCCM console as it then goes into a orphaned state in the content library.  If left for any period of time and then re-distributed to the problem DP, the files never go through the despool.box yet the distribution status pie chart will show green and the content library explorer changes back to "Invalid".  If I try to "re-distribute" the content from the SCCM console it just evaluates to already be there and stays in an "Invalid" state.  Sometimes updating the content version number and redistributing can fix the issue but 9 times out of 10 it just changes the version number in the content library but the content remains "Invalid"

I've been scouring the net trying to find a WMI/Powershell cmd to trigger a full resync of content for a specific package but I can't find anything.  Is there a way to do this either via WMI, Powershell, or directly in the SQL DB?  Even if the best solution is to delete the files directly from the content library I just need to find a reliable way to fully re-sync "Invalid" content.

We're using SCCM 1802 but this isn't a new problem, it's been knocking around for a long time. I hope someone has a script or a trick that can help me sort this issue.

Thanks in advance,


Share this post

Link to post
Share on other sites

Typically, I go to monitoring and content status.  I look for targeted and compliance.  For example...I have 9 targets.  If I have a package that says (9), but does not have 100% compliance, then I push it again.  As for an automated script...I'm not aware of that, but it could be handy.

Share this post

Link to post
Share on other sites

Thanks for you reply.  I think we're going to be logging a ticket to Microsoft for this problem now.  I've tried manually deleting things from the content library to try and trick a full redistribution but I think the record may need deleting from the database which I don't really want to do without knowing exactly what I need to delete.  I found the following query that can be run on the DB to detect the status of a package:

Select * FROM PkgServers WHERE PkgID = 'ABC00123' AND NALPath Like '%MYSERVERNAME01%'

You can set the "RefreshTrigger", "UpdateMask", and "Action" tables to trigger a redistribution using this command:

UPDATE PkgServers SET RefreshTrigger  = 1, UpdateMask = 4, Action = 1



But this is the same as doing a redistribution from the SCCM console or the content library.

I found that when a brand new package is first sent to a DP is uses "RefreshTrigger = 0", "UpdateMask = 0", and "Action = 2".  so I tried setting this on my faulty package but it just will not re-send the files. You can see the package being referenced in the distmgr.log but it doesn't push any files as the DB shows that they already exist on that site.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...