Jump to content

Sign in to follow this  

WDS Error 644 - Failed TFTP Download

Recommended Posts

Hello All,

Been struggling to PXE boot x64 UEFI clients lately. I'm able to pxe boot a Dell Latitude 3380 with integrated ethernet port. I've been unable to pxe boot a Dell XPS 13 (L322X) using a Startech USB 2.0 to Ethernet Adapter. I have about a dozen adapters, about 200 XPS 13's.

I'm aware that sometimes I may need to get the GUID of the XPS laptop and create a machine with that ID in SCCM first. However, I haven't had to do this before. 

Here's the weird part. I can see two different size wdsmgrfw.efi files being delivered to these machines. When I open event viewer and view the Admin log of the Deployment-Services-Diagnostics, I can see this file being delivered via WDS, but as I said, two different file sizes and paths can be observed.

Latitude 3380 grabs \smsboot\x64\wdsmgfw.efi - 1469752 bytes

XPS 13 grabs smsboot\x64\wdsmgfw.efi - 1272328 bytes

Any idea why WDS is grabbing a different sized file from a different path?




-- Background Notes

We have one flat network, one vlan. SCCM/WDS is on one box, DHCP services are running on another, separate box acting as domain controller with FSMO role.

I'm using DHCP policies and vendor classes on the DHCP server with the understanding it will tell PXE clients which image to use when booting, depending on their architecture. Having done so, in each policy, options 66 and 67 are defined to state IP address and name of file that should be requested from the SCCM box running WDS. I just want to add that using, and not using vendor classes and dhcp options makes no difference at all. I just wanted you to know I tried that.

When I check the Admin log of the Deployment-Services-Diagnostics folder within Event Viewer, I see the same message repeated over and over. 

The following Client failed TFTP Download:

Client IP:

Filename: smsboot\x64\wdsmgfw.efi


Variable Window: false


I've tried mirroring the network traffic to another switchport where I'm running Wireshark. I can observe a DHCP Discover, Offer, Request, Ack take place. I then watch 800 or so ACK's sent from the client as it downloads smsboot\x64\wdsmgfw.efi block by block. Then, the ACK's stop going out to SCCM. On the client I see printed to the screen PXE-E23, Client Received TFTP Error.

I'm really at a loss folks, but would really, really like to understand the issue and avoid rebuilding SCCM. I'm happy to provide any required information you need to help.


Share this post

Link to post
Share on other sites

When I view this exchange with Wireshark running on SCCM box, I can see SCCM/WDS box send 748 blocks of smsboot\x64\wdsmgr.efi to the PXE client. It then sends an TFTP Error to client!

When viewing same capture in opposite direction, I can see the client send ACK's for every block up to 748, then nothing. 

Why would the SCCM/WDS box be sending an error to the client when I can't see any reason for the client triggering such behavior?


Share this post

Link to post
Share on other sites

Is PXE broken for everything or just this model? Can you isolate it to a legacy / UEFI boot problem.

I don't use the DHCP scope options at all - just let SCCM respond on any subnet it manages.

So in the properties of the DP Role, PXE tab i have the first three options enabled. 

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...