Jump to content


xerxes2985

console can't connect to site database unless run as admin.

Recommended Posts

Hi all. I've been connecting just fine using an account that is a full administrator on the site server. Now, unless I run the program as an administrator, and use a different "full administrator" account, I get the following error. Please guide me in resolve (what logs etc)

The Configuration Manager console cannot connect to the Configuration Manager site database. Verify the following:

      •    This computer has network connectivity to the SMS Provider computer.
      •    Your user account has Remote Activation permission on the Configuration Manager site server and the SMS Provider computer.
      •    The Configuration Manager console version is supported by the site server.
      •    You are assigned to at least one role-based administration security role.
      •    You have the following WMI permissions to the Root\SMS and Root\SMS\site_<site code> namespaces: Execute Methods, Provider Write, Enable Account, and Remote Enable.
     

Share this post


Link to post
Share on other sites

check your RBAC settings, i.e. are you in a group that is a member of some group that has access to run the console

Share this post


Link to post
Share on other sites
17 hours ago, anyweb said:

check your RBAC settings, i.e. are you in a group that is a member of some group that has access to run the console

Checked, the account is a member of the group called SMS Admins that has access to run the console. Should I remove / re-add the account from there, as well as in the SCCM console?

Share this post


Link to post
Share on other sites

So far, everything I've checked on this list is valid. All permissions are in place, wmi permissions correct. 

This computer has network connectivity to the SMS Provider computer.
      •    Your user account has Remote Activation permission on the Configuration Manager site server and the SMS Provider computer.
      •    The Configuration Manager console version is supported by the site server.
      •    You are assigned to at least one role-based administration security role.
      •    You have the following WMI permissions to the Root\SMS and Root\SMS\site_<site code> namespaces: Execute Methods, Provider Write, Enable Account, and Remote Enable.
     

 

Yet, SMSAdminUI.log shows the following:

 

   at System.Management.ManagementScope.InitializeGuts(Object o)
   at System.Management.ManagementScope.Initialize()
   at System.Management.ManagementObjectSearcher.Initialize()
   at System.Management.ManagementObjectSearcher.Get()
   at Microsoft.ConfigurationManagement.ManagementProvider.WqlQueryEngine.WqlConnectionManager.Connect(String configMgrServerPath)
   at Microsoft.ConfigurationManagement.AdminConsole.SmsSiteConnectionNode.GetConnectionManagerInstance(String connectionManagerInstance)\r\n
[5, PID:1184][09/27/2019 11:25:06] :Insufficient privilege to connect, error: 'Access is denied.
'\r\nSystem.UnauthorizedAccessException\r\nAccess is denied.
\r\n   at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
   at System.Management.ManagementScope.InitializeGuts(Object o)
   at System.Management.ManagementScope.Initialize()
   at System.Management.ManagementObjectSearcher.Initialize()
   at System.Management.ManagementObjectSearcher.Get()
   at Microsoft.ConfigurationManagement.ManagementProvider.WqlQueryEngine.WqlConnectionManager.Connect(String configMgrServerPath)
   at Microsoft.ConfigurationManagement.AdminConsole.SmsSiteConnectionNode.GetConnectionManagerInstance(String connectionManagerInstance)\r\n

 

Thanks for any help you can provide,

Share this post


Link to post
Share on other sites

I also have a login problem with the console, however it works on my desktop in the office, but doesn't work on my laptop from home. Both connected to the company network, both using the same login credentials granted access to the sccm server. Strange

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...