Jump to content


How to update Lenovo BIOS during OSD SCCM

Recommended Posts

I'm having problems updating the BIOS for any ThinkCentre tiny desktops. M700, M710q, M720q. 

I've tried in WinPE via  x64 boot image. I saw on the ThinkDeploy Web site that x86 was only supported. Not sure if this is true or not.

I've also tried placing the command in various places within the TS. It doesn't matter where I place the command it never works and breaks the TS.. ERROR ERROR 

I've tried several variations of the BIOS update command. No luck. flash.cmd /sccm /quiet     flash64.cmd /sccm /quiet    flash.cmd /ign /sccm /quiet    wflash2.exe /quiet   and the list goes on and on.

I have a package that's been distributed. I reference the package with the command. I've even tried downloading the package first in the TS then running the command

When I've tried placing the command in after the OS install section the BIOS doesn't update but I don't have an error. 


I'm looking for the correct area in the Task Sequence where I should be trying to run the BIOS update. Someone that has had success before.  


I do know this statement :


                              #This needs to be a shutdown command, as the ThinkCentre BIOS documentation states 
                              # that the computer needs to reach an S5 power state to complete the update of the 
                              # BIOS.  Computer will actually reboot

From the Readme file inside of the BIOS files:

oautomate the ThinkCentre BIOS update, the FLASH.CMD file can be executed with the /quiet command line parameter. FLASH.CMD executes WFlash2.exe with predetermined command line parameters attached. FLASH.CMD is designed to pass any command line parameters to the WFlash2.exe in the command file.

To update the BIOS in an automated solution use the command line parameter /quiet. The /quiet command line parameter will allow the update of the BIOS through WFlash2.exe without physical presence or other interaction.

Some versions of WFlash2.exe support the /sccm parameter. The /sccm parameter is intended for use in a task sequence and will suppress the reboot until the administrator chooses to do so. Check the readme.txt in the extracted BIOS folder or run WFlash2.exe /? to verify that the version of WFlash2.exe you are using supports this option.

I can grab a few of the failed smsts.logs if that helps? 


I also have the same files being used an a Application Deployment to update the BIOS. From within Windows using the Software Catalog I can update any BIOS. I cannot use the same application during a TS. It won't update the BIOS. 

Share this post

Link to post
Share on other sites

This command should work ..


WFLASH2x64.exe xxxxxxx.ROM /bb /rsmb /ign /quiet /sccm

The Problem is that you actually need a shutdown and not a resboot, which is not supported in SCCM. There is a workaround with a delayed restart command but its not very pretty or reliable.

Also the kernel mode driver is using outdated and supported SHA1 signatures.

The whole ThinkCentre BIOS update routine is pretty much crap 😀

There is also a problem with HVCI and those outdated signatures, which might cause blue screens under Windows 10 wen you have HVCI avtivated.

After all i switched to the UEFI driver updates from https://www.catalog.update.microsoft.com/Search.aspx?q=thinkcentre%20firmware .

Problem there is, they are not updated as often as they would be needed to. But they are easy to install and just require a plain old restart.




Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...