Jump to content

Lewis Baskerville

Surface Pro imaging success? SCCM OSD hangs stalls at client install - Surface Pro 7 - waiting for ccmexec service.

Recommended Posts

Hi all,

Has anyone had any success imaging Surface Pro 7 devices with SCCM? I've imaged Surface Pro 3 & 4 in the past but I'm having a strange issue with the Pro 7's ☹️ As I understand it, Surface Pro X's can't be imaged using SCCM, I'm beginning to wonder if this Surface Pro 7's are the same....

We're running Config Manager 2006 (Hotfix Rollup KB4578605) and trying to image with Windows 10 1909. I've extracted the Surface Pro 7 drivers MSI and created a standard driver package. It's PXE boots just fine using the Microsoft Surface Pro Ethernet Adapter and the TS progresses and just hangs right at the end of the client install. The client.msi.log shows the client installed successfully. The smsts.log shows that it seems to have issues starting the ccmexec service.

I've been looking into this and seen people have had issues before or after this step with Surface Pro and suggest adding a wait or a reboot before or after the step. I've tried doing this before the Setup Windows and Config Manager step but can't do it after because it always hangs before then.

At the point where it hangs, I've pressed F8 to launch a command prompt and tried stopping the print spooler service (taskkill /IM spoolsv.exe /f) as others have suggested but still no dice.

I've googled the error - Failed to create instance for IMTCTokenHandler interface, hr=0x80080005 but this doesn't seem like a common error and hasn't offered any leads.

Snippet from smsts.log

==========[ TsProgressUI started in process 4308 ]==========    TsProgressUI    17/03/2021 23:37:39    4312 (0x10D8)
Registering COM classes    TsProgressUI    17/03/2021 23:37:39    4312 (0x10D8)
sbModulePath = C:\WINDOWS\system32\_SMSOSDSetup\TsProgressUI.exe    TsProgressUI    17/03/2021 23:37:39    4312 (0x10D8)
Shutdown complete.    TsProgressUI    17/03/2021 23:37:39    4312 (0x10D8)
Process completed with exit code 0    OSDSetupHook    17/03/2021 23:37:39    3516 (0x0DBC)
Successfully registered Task Sequence Progress UI.    OSDSetupHook    17/03/2021 23:37:39    3516 (0x0DBC)
Executing C:\_SMSTaskSequence\OSD\IMI00002\ccmsetup.exe /useronly /source:C:\_SMSTaskSequence\OSD\IMI00002 /config:MobileClient.TCF /status:956    OSDSetupHook    17/03/2021 23:37:39    3516 (0x0DBC)
Command line for extension .exe is "%1" %*    OSDSetupHook    17/03/2021 23:37:39    3516 (0x0DBC)
Set command line: "C:\_SMSTaskSequence\OSD\IMI00002\ccmsetup.exe" /useronly /source:C:\_SMSTaskSequence\OSD\IMI00002 /config:MobileClient.TCF /status:956    OSDSetupHook    17/03/2021 23:37:39    3516 (0x0DBC)
Executing command line: "C:\_SMSTaskSequence\OSD\IMI00002\ccmsetup.exe" /useronly /source:C:\_SMSTaskSequence\OSD\IMI00002 /config:MobileClient.TCF /status:956 with options (0, 0)    OSDSetupHook    17/03/2021 23:37:39    3516 (0x0DBC)
Process completed with exit code 0    OSDSetupHook    17/03/2021 15:43:12    3516 (0x0DBC)
Install succeeded. Blocking other instances of ccmsetup.    OSDSetupHook    17/03/2021 15:43:12    3516 (0x0DBC)
Creating ccmsetup mutex.    OSDSetupHook    17/03/2021 15:43:12    3516 (0x0DBC)
Installed Client    OSDSetupHook    17/03/2021 15:43:12    3516 (0x0DBC)
Backing up current global client logging settings that are read from registry    OSDSetupHook    17/03/2021 15:43:12    3516 (0x0DBC)
Overwrote client global logging setting in registry with OSD logging settings.    OSDSetupHook    17/03/2021 15:43:12    3516 (0x0DBC)
Start to cleanup Task Sequence policy    OSDSetupHook    17/03/2021 15:43:12    3516 (0x0DBC)
Task Sequence Manager deleted 0 instances    OSDSetupHook    17/03/2021 15:43:12    3516 (0x0DBC)
Task Sequence Policy cleanup done    OSDSetupHook    17/03/2021 15:43:12    3516 (0x0DBC)
End Task Sequence policy cleanup    OSDSetupHook    17/03/2021 15:43:12    3516 (0x0DBC)
Setting variable to indicate a client installation was done    OSDSetupHook    17/03/2021 15:43:12    3516 (0x0DBC)
Registering the task sequence with the execution manager in the newly installed operating system.    OSDSetupHook    17/03/2021 15:43:12    3516 (0x0DBC)
Active request handle is empty, registering with new active request handle. This is expected if the Task Sequence was started from a media/PXE.    OSDSetupHook    17/03/2021 15:43:12    3516 (0x0DBC)
Saving the new active request handle for the task sequence: {2A3DB9C0-4955-450D-B6F9-899601D88A48}    OSDSetupHook    17/03/2021 15:43:12    3516 (0x0DBC)
Failed to create instance for IMTCTokenHandler interface, hr=0x80080005    OSDSetupHook    17/03/2021 15:45:12    3516 (0x0DBC)
Waiting for CcmExec process to start    OSDSetupHook    17/03/2021 15:45:12    3516 (0x0DBC)
Failed to create instance for IMTCTokenHandler interface, hr=0x80080005    OSDSetupHook    17/03/2021 15:47:17    3516 (0x0DBC)
Waiting for CcmExec process to start    OSDSetupHook    17/03/2021 15:47:17    3516 (0x0DBC)


Share this post

Link to post
Share on other sites

have you tried with a newer release of Windows 10, for example v2004 or 20h2 ? do they also produce the same result ?

Share this post

Link to post
Share on other sites

Thanks for your reply. I've not created an image for the newer Windows 10 releases yet to test. Is this just to rule it out or have you seen issues with older versions of Windows and Surface Pro 7?

Edited by Lewis Baskerville
Added something additional

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...