Jump to content


problem to run PS script as application

Recommended Posts


I have a problem running PS scripts packaged as applications. If I run the script once, then everything is OK and the script will run. If I run the same script as an application, I see an error in Deployment Monitoring:
Google Chrome Uninstallation test, PS100014, Test collection, Required, Chrome Uninstallation, Failed to locate content, No additional information, 0x87D0032A (-2016410838), The uninstall command line is invalid, WIN10TEST, 14,18.06.2021 12: 19, Error, MSI, No, (SYSTEM), Yes, No, Yes,
. There is no information in the script.log on the clients computers about running the script.

if($AppInfo = Get-WmiObject Win32_Product -Filter "Name Like 'Google Chrome'"){
    # this is used when teh enterprise version is installed and works for both 32 and 64 bit hrome

I have set the PowerShell execution policy: Bypass in the client settings.
In the application I have set in the Installation program: powershell.exe -executionpolicy bypass -nologo -file Google_Chrome_v6.ps1.


I can see this in AppDiscovery.log  on clients:

AppProvider::GetHandlerInfo the action "UninstallAction" object couldn't be found

AppProvider::GetHandlerInfo failed.  Error 0x87d0032a

GetContentInfo failed with error 0x87d0032a

Method GetContentInfo failed with error 87D0032A

CAppProvider::ExecMethodAsync failed. Error 87d0032a











Edited by sajeret

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...