Jump to content


Sanchez

Executables Being Closed When They Shouldn't

Recommended Posts

Hi.

It seems that Install Behavior isn't working properly in the latest versions of Configuration Manager, as it is automatically closing applications, when it's not supposed to.

I'm deploying an application, and have specified an executable that must be closed for the application installation to succeed, in the "Install Behavior" tab of the deployment type.

I've created a required deployment for the application, but the "Automatically close any running executables..." option is un-checked. Despite that, when the deployment deadline is reached, the executable gets terminated. I would expect the installation to fail, without terminating the executable, which is what I want (and what it always used to do).

I've tried this with a couple of different application deployments, and they both do the same thing.

I had employed that method successfully a number of times in the past, to depoy applications as required, without having to worry about interrupting peoples' work. I first noticed the problem a couple of weeks ago, with Configuration Manager version 2103. I upgraded to version 2107, hoping that would resolve the issue, but it hasn't.

The "Show notifications for new deployments" option in client settings is set to "No", as I don't want users being nagged when I deploy new applications, but that's never been a problem before.

Is anyone else seeing this behaviour?


Thanks.

Share this post


Link to post
Share on other sites

Thanks. I thought it might be a bug, but Googled it and wondered why nobody else seemed to have mentioned it.

So far, I've just sent feedback, but yeah, I should probably raise a case. I wonder if anyone else is able to verify this behaviour in their environment, to make sure it's not just mine.

 

Thanks.

Share this post


Link to post
Share on other sites

Perfect; thanks!

  1. Install an old version of 7-Zip (as an example), on a test workstation.
  2. Launch 7-Zip File Manager
  3. Create an application in SCCM, with the newest MSI version of 7-Zip (standard MSIExec switches).
  4. In the Install Behavior tab of the deployment type, add 7zFM.exe as an executable that must be closed.
  5. Deploy the application as required, to the test workstation, and make sure to leave "Automatically close any running executables you specified..." un-checked.
  6. Run the machine policy and application deployment evaluation cycles, to hurry things along.
  7. The first time you do this, the content will be downloaded, and the installation will fail (as it should).
  8. Do the same again, and this time, the installation will proceed, and 7-Zip File Manager will be terminated.

At least that's what's happening here (just tried all of that myself).

If you trigger it manually, by clicking "Install" in Software Center, it behaves as it should - the installation fails, and the application stays open.

Is that enough detail, or do you need a step by step?

 

Thanks.

 

Share this post


Link to post
Share on other sites

Weirdly, I've just found that it doesn't happen on one of my test VMs - one which has no other software installed. On the other two (which have plenty of programs installed), and on user workstations, it happens. 🤷‍♀️

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...