Jump to content


GarW

ASD, WDS and PXE boot clients

Recommended Posts

Hi all,

 

Have the common PXE-E53 "No boot filename received" issue, but can't get to the bottom of it this time.

 

DHCP Server and PXE Service Point on different servers, in same subnet. Client in different subnet, IP Helper configured forwarding to both. (Have tried using DHCP Options 60,66,67 with no difference).

 

On SCCM PXE Service Point, WDS running without error. PXE Service Point running, but the following error "PXE Control Manager detected PXE service point is not responding to PXE requests. The error is 10048." PXEControl.log has the following which seems to indicate a bind issue?

 

)

SMS_PXE_SERVICE_POINT successfully STARTED.

********************************************************************************

Configuration and Availability Monitor thread started.

Initialized 'SMS Server Availability' performance instance => SMS PXE Service Point.

adding address to server list 10.01.101.146

adding address to server list 127.00.00.01

Bind Socket Failed

Error initializing PXE client

Bind Socket Failed

Error initializing PXE client

Pxe test request failed, error code is 10048.

STATMSG: ID=6319 SEV=E LEV=M SOURCE="SMS Server" COMP="SMS_PXE_SERVICE_POINT" SYS=xxx36 SITE=SV0 PID=4600 TID=1676 GMTDATE=Fri Nov 12 16:26:29.760 2010 ISTR0="10048" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0 SMS_PXE_SERVICE_POINT

PXE test request failed, status code is -2147014848, 'Error initializing PXE client'.

Successfully performed availability check against local computer.

Initialization still in progress.

 

Thanks in advance for any ideas of what to check next.

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for the response. Yes it has - I'm trying to get it to boot to a bare metal build. Advertisment seem OK, MAC address entered properly. Have checked for any old records with that MAC address but none there.

 

Just to satisy my curiosity, would you have any guidance on whether the error event on the PXE_SERVICE_POINT is normal - "PXE Control Manager detected PXE service point is not responding to PXE requests. The error is 10048.".

 

Your interest is really appreciated.

Share this post


Link to post
Share on other sites

Ive played around with a lot of this ..

 

My experience is

 

Helper addresses, helpder addresses, helpder addrressesssssss, put them everywhere for both the sccm and dhcp. Over and Over again I get this due to the comms guys saying "its been done" .. but when i hassel them, its been done kinda except the sccm.

 

Dont muck with WDS at all, remove pxe, remove wds, restart, configure wds without transport (dont touch it after config) and install PXE again. There is a specific article on this somewhere.

 

A small suggestion which everyone will shoot me over (but i love it), advertise it to all unknown computers and delete your imported record completely from all systems collection, restart the WDS service to clear the cache.

 

Make sure you dont have the advertisement as mandatory, check this over and over, because .. you screw that up and BLIP all your machines will enforce your TS.

 

This process basically resets everything back to being 'just installed' .. advertising to everything sccm doesnt know about to eliminate any hickups on the sccm side of things...

 

This is how I test both sccm and network PXE issues, then go back and lock down the advertisements....BE CAREFUL

  • Like 1

Share this post


Link to post
Share on other sites

had the same issue in my environment, my solution was the following: first make sure you have added both x86 and x64 boot images to your DP's. verify your smsboot\x86 and x64 folders have been populated with files should have pxeboot.com, Wdsnbp.com and etc. next have the IP helpers on your switches point to your DHCP server. On your DHCP server add options 66 and 67, for option 66 point to the IP of your SCCM server and for option 67 have that configured to the SMSBoot\x86\wdsnbp.com. that should do the trick.

Share this post


Link to post
Share on other sites

Thanks to all who posted. Got the following from a guy at MS which pointed me to the probem. I had run out of TCP ports and PXE couldn't bind to port 4011. I moved the WDS/PXE Service Point to a new dedicated machine and sorted the problem (Naturally I also had to change the IP Helper address on the router to point to the new IP address of the PXE Service Point - left the helper address to the DHCP server as is).

 

Error 10048 signifies "Only one usage of each socket address (protocol/network address/port) is normally permitted."

 

It indicates that the PXE Service Point is unable to bind itself on port 4011, which is used by PXE Service Point.

 

Do one of the following:

 

Enter the following command in the command prompt on a Windows XP or Windows Server 2003 computer to display the active connections being used by the TCP/IP protocol on this computer:

 

netstat -n

This will list the TCP/IP addresses bound to the client computer and the ports on which the TCP/IP addresses are communicating with a remote server. If the listed ports consume all of the available ports then TCP/IP port exhaustion occurs.

 

Enter the following command in the command prompt on a Windows Server 2003-based client computer to display the active connections being used by the TCP/IP protocol:

 

netstat -b

This will list the TCP/IP address bound to the client computer, the port on which the TCP/IP address are communicating with a remote server, and the application that is using the ports. This information can help determine which client applications are consuming excessive TCP/IP ports.

 

Disable all 3rd party applications running on the WDS/PXE Service Point Server and try again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...