Jump to content


Jazzyn

SCCM PXE Certificate expired

Recommended Posts

Hi

Could somebody shed some light on how you go about renewing the PXE certificate. We recived a message stating that it will expire in 3 hours. My colleague who setup the Site cannot recall creating it in the first instance so I assume it is created by default??I dunno!

Any help would be great, thanks.

 

P.s It has not actually expired yet, so not sure if it auto-renews just trying to be pro-active - if it does auto-renew then apologies.

Share this post


Link to post
Share on other sites

To resolve the issue for missing or expired certificates on Boot Media, a new certificate needs to be created:

 

1. Recreate the Boot Media by going in the Configuration Manager Admin Console to Site Database --> Computer Management --> Operating System Deployment.

2. Right clicking on Task Sequences and choosing Create Task Sequence Media.

3. Step through the Task Sequence Media Wizard to create the appropriate media.

4. In the Security screen, locate the Create self-signed media certificate option.

5. Make sure that the Set start date is set to either today or some date in the past.

6. Make sure that the Set expiration date is set to some date in the future.

7. Finish stepping through the Task Sequence Media Wizard to finish creating the ISO or USB Flash Drive.

8. Go to Site Database --> Site Management --> <Site_Code> --> Site Settings --> Certificates --> Boot Media and verify that there is now a valid non-expired non-blocked Certificate.

9. If using CDs/DVDs, once the ISO is created, create a CD/DVD from the ISO and dispose any previous OSD CDs or DVDs.

10. If using a USB Flash Drive, make sure to recreate all USB Flash Drives be redoing steps 1-8 above.

 

To resolve the issue for missing or expired certificates on a PXE Service Point, a new Certificate needs to be created:

 

1. Go to Site Database --> Site Management --> <Site_Code> --> Site Settings --> Site Systems and choose the server where the PXE Service Point is located.

2. In the right pane, right click on the ConfigMgr PXE service point and choose Properties.

3. Click on the Database tab and locate the Create self-signed PXE certificate option.

4. Under Create self-signed PXE certificate, set the Set expiration date option to some time in the future.

5. Click OK.

6. Go to Site Database --> Site Management --> <Site_Code> --> Site Settings --> Certificates --> PXE and verify that there is now a valid non-expired non-blocked Certificate.

7. Update the Boot Images by going to Site Database --> Computer Management --> Operating System Deployment --> Boot Images.

8. Expand both the Boot image (x64) and Boot image (x86) nodes (and any custom Boot Images if present).

9. For each Boot Image, right click on Distribution Points and choose Update Distribution Points.

10. Step through the Manage Distribution Points wizard until it has completed rebuilding the Boot Images.

11. Restart the Windows Deployment Services (WDS) Server service.

 

To resolve the issue if the certificate is blocked, follow these steps:

 

1. Go to Site Database --> Site Management --> <Site_Code> --> Site Settings --> Certificates.

2. Choose either Boot Media (if the deployment is being done via a boot media) or PXE (if the deployment is being done via PXE). You will be able to see all of the certificates associated with either the Boot Media or the PXE point.

3. Check to see if the applicable certificate is set to "Blocked" under the Status column. If the certificate is blocked, unblock it. To unblock a certificate, right click on it and choose "Unblock".

 

If you are not certain which certificate is the applicable one, you may have to unblock the certificates one at a time, retry the deployment again, and then see if the error goes away. Once you have determined the applicable certificate, you may want to go back and re-block the certificates that were not applicable and were unblocked during the testing.

 

 

credit: http://blogs.technet.com/b/configurationmgr/archive/2008/10/23/configmgr-2007-osd-task-sequence-fails-with-the-error-an-error-occurred-while-retrieving-policy-for-this-computer-0x80004005.aspx

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...