Jump to content


Ackros

Software Updates - Catalog not 100%

Recommended Posts

Hi,

 

I have noticed since I started trying to use the SUP for microsoft patch deployment that while i do get the console view to populate Search folders etc...

 

e.g. criteria set to Show Bulletin = "MS11"

 

There are some MS11 bulletins I know exist that never appear on this list even after a few days having forced a REPO sync.

 

THen I realised today that IE 8 nor 9 appear in the Product listings... any ideas on how to force that to sync correctly?

 

now the for the worst one .... according to both collections views for All Users and All Systems , THe Client Column Status is No.

 

With only one exception the SCCM (all in one) server itself.

 

 

 

I find this highly strange as i followed the excellent guides here and all seemed fine at the beginning.

 

This in stall has been up for weeks now so it has no excuses for not working right at this point....

 

grrr i hate microsoft for not making a single procduct installation..

 

a unified installer to get it to SCCM 2007 SP2 with R3,,, is it really too much to ask... lol ok thats my rant for today over.

 

 

 

 

having gotten the tools and used the trace log tool on my local laptop which has the client installed 4.00.6487.2000.

 

Mixed mode. etc..

 

Note my SCCM install is colocated with SCOM and VMware VCS so there is a custom IIS SMSWEB on ports 51808 /51809 (http/https)

 

the default iis is on 5080

 

 

 

If i run the Windows update from the control panel on the SCCM server i can find the available patches required for itself..

 

e.g. ms11-050 kb2530548 IE 9 critical

 

any and all ideas, suggestions welcome.

 

oh one thing i noticed yesterday in one of the local client logs on my laptop was a failure to locate SUP and it seemed to be trying to use port 80, and not port 51808.

 

 

 

 

form the client logs:

 

policyagnet.log - i see alot of reoccuring every 15 minutes

 

Requesting policy from authority: SMS:RVI, Ggroup membership changed, Raising event instance of CCM_XXXXXXXXXXXXXX etc..

 

 

!!in RED and YELLOW - lcoationservices.log - full log attached , sample from it below. i suspect this is the main cause ,

NOTE: we only have DNS servers on our 2008R2 domain no WINS servers. i could add some wins but if its not really needed.

 

Failed to retrieve Default Management Point from SLP  LocationServices              22/06/2011 09:46:47        5640 (0x1608)
Attempting to retrieve default management point from WINS   LocationServices              22/06/2011 09:46:47        5640 (0x1608)
Attempting to retrieve NLB default management point from WINS          LocationServices              22/06/2011 09:46:47        5640 (0x1608)
Failed to resolve 'NLB_RVI' to IP address from WINS       LocationServices              22/06/2011 09:46:51        5640 (0x1608)
No NLB default management point is present, attempting to resolve default management point from WINS                LocationServices              22/06/2011 09:46:51        5640 (0x1608)
Failed to resolve 'MP_RVI' to IP address from WINS        LocationServices              22/06/2011 09:46:56        5640 (0x1608)
Failed to retrieve default MP through WINS.       LocationServices              22/06/2011 09:46:56        5640 (0x1608)
Failed to retrieve AMP for site code 'RVI' with error (0x80004005). Nulling existing entry in WMI                LocationServices                22/06/2011 09:46:56        5640 (0x1608)
Persisted Default Management Point Location locally     LocationServices              22/06/2011 09:46:56        5640 (0x1608)
Unknown task LSProxyMPModificationTask in non-quarantine - ignoring.             LocationServices              22/06/2011 09:46:56                2108 (0x083C)
Attempting to retrieve proxy MP from AD           LocationServices              22/06/2011 09:46:56        5640 (0x1608)
Current AD site of machine is RuV-IE-Dublin        LocationServices              22/06/2011 09:46:56        5640 (0x1608)
Current AD site of machine is RuV-IE-Dublin        LocationServices              22/06/2011 09:46:56        5640 (0x1608)
Attempting to retrieve local MP from AD              LocationServices              22/06/2011 09:46:56        5640 (0x1608)
Current AD site of machine is RuV-IE-Dublin        LocationServices              22/06/2011 09:46:56        5640 (0x1608)
Retrieved local Management Point from AD: IEDUBAPP001.RUV.IE          LocationServices              22/06/2011 09:46:56        5640 (0x1608)
Attempting to retrieve default management point from AD        LocationServices              22/06/2011 09:46:56        5640 (0x1608)
Attempting to retrieve SLPs from AD      LocationServices              22/06/2011 09:46:56        5640 (0x1608)
Retrieved SLPs from AD                LocationServices              22/06/2011 09:46:56        5640 (0x1608)
[CCMHTTP] HTTP ERROR: URL=http://IEDUBAPP001/sms_slp/slp.dll?site&sc=RVI, Port=80, Protocol=http, SSLOptions=0, Code=0, Text=CCM_E_BAD_HTTP_STATUS_CODE           LocationServices              22/06/2011 09:46:57        5640 (0x1608)
Raising event:

instance of CCM_CcmHttp_Status
{
               ClientID = "GUID:927E3590-6502-4858-AA44-81207572ABEF";
               DateTime = "20110622084657.003000+000";
               HostName = "IEDUBAPP001";
               HRESULT = "0x8004027e";
               ProcessID = 2064;
               StatusCode = 404;
               ThreadID = 5640;
};
               LocationServices              22/06/2011 09:46:57        5640 (0x1608)
LSGetManagementPointForSiteFromSLP : No Default MP returned from SLP for site <RVI>         LocationServices                22/06/2011 09:46:57        5640 (0x1608)
Failed to retrieve Default Management Point from SLP  LocationServices              22/06/2011 09:46:57        5640 (0x1608)
Attempting to retrieve default management point from WINS   LocationServices              22/06/2011 09:46:57        5640 (0x1608)
Attempting to retrieve NLB default management point from WINS          LocationServices              22/06/2011 09:46:57        5640 (0x1608)
Failed to resolve 'NLB_RVI' to IP address from WINS       LocationServices              22/06/2011 09:47:01        5640 (0x1608)
No NLB default management point is present, attempting to resolve default management point from WINS                LocationServices              22/06/2011 09:47:01        5640 (0x1608)
Failed to resolve 'MP_RVI' to IP address from WINS        LocationServices              22/06/2011 09:47:06        5640 (0x1608)
Failed to retrieve default MP through WINS.       LocationServices              22/06/2011 09:47:06        5640 (0x1608)
Failed to retrieve AMP for site code 'RVI' with error (0x80004005). Nulling existing entry in WMI                LocationServices                22/06/2011 09:47:06        5640 (0x1608)
Persisted Default Management Point Location locally     LocationServices              22/06/2011 09:47:06        5640 (0x1608)
Attempting to retrieve proxy MP from AD           LocationServices              22/06/2011 09:47:06        5640 (0x1608)
Unknown task LSProxyMPModificationTask in non-quarantine - ignoring.             LocationServices              22/06/2011 09:47:06                2108 (0x083C)
Current AD site of machine is RuV-IE-Dublin        LocationServices              22/06/2011 09:47:06        5640 (0x1608)
Current AD site of machine is RuV-IE-Dublin        LocationServices              22/06/2011 09:47:06        5640 (0x1608)
Attempting to retrieve local MP from AD              LocationServices              22/06/2011 09:47:06        5640 (0x1608)
Current AD site of machine is RuV-IE-Dublin        LocationServices              22/06/2011 09:47:06        5640 (0x1608)
Retrieved local Management Point from AD: IEDUBAPP001.RUV.IE          LocationServices              22/06/2011 09:47:06        5640 (0x1608)
Attempting to retrieve default management point from AD        LocationServices              22/06/2011 09:47:06        4900 (0x1324)
Attempting to retrieve SLPs from AD      LocationServices              22/06/2011 09:47:06        4900 (0x1324)
Retrieved SLPs from AD                LocationServices              22/06/2011 09:47:06        4900 (0x1324)
[CCMHTTP] HTTP ERROR: URL=http://IEDUBAPP001/sms_slp/slp.dll?site&sc=RVI, Port=80, Protocol=http, SSLOptions=0, Code=0, Text=CCM_E_BAD_HTTP_STATUS_CODE           LocationServices              22/06/2011 09:47:06        4900 (0x1324)
Raising event:

instance of CCM_CcmHttp_Status
{
               ClientID = "GUID:927E3590-6502-4858-AA44-81207572ABEF";
               DateTime = "20110622084706.352000+000";
               HostName = "IEDUBAPP001";
               HRESULT = "0x8004027e";
               ProcessID = 2064;
               StatusCode = 404;
               ThreadID = 4900;
};
               LocationServices              22/06/2011 09:47:06        4900 (0x1324)
LSGetManagementPointForSiteFromSLP : No Default MP returned from SLP for site <RVI>         LocationServices                22/06/2011 09:47:06        4900 (0x1324)
Failed to retrieve Default Management Point from SLP  LocationServices              22/06/2011 09:47:06        4900 (0x1324)
Attempting to retrieve default management point from WINS   LocationServices              22/06/2011 09:47:06        4900 (0x1324)
Attempting to retrieve NLB default management point from WINS          LocationServices              22/06/2011 09:47:06        4900 (0x1324)
Failed to resolve 'NLB_RVI' to IP address from WINS       LocationServices              22/06/2011 09:47:11        4900 (0x1324)
No NLB default management point is present, attempting to resolve default management point from WINS                LocationServices              22/06/2011 09:47:11        4900 (0x1324)
Failed to resolve 'MP_RVI' to IP address from WINS        LocationServices              22/06/2011 09:47:15        4900 (0x1324)
Failed to retrieve default MP through WINS.       LocationServices              22/06/2011 09:47:15        4900 (0x1324)
Failed to retrieve AMP for site code 'RVI' with error (0x80004005). Nulling existing entry in WMI                LocationServices                22/06/2011 09:47:15        4900 (0x1324)
Persisted Default Management Point Location locally     LocationServices              22/06/2011 09:47:15        4900 (0x1324)
Attempting to retrieve proxy MP from AD           LocationServices              22/06/2011 09:47:15        4900 (0x1324)
Unknown task LSProxyMPModificationTask in non-quarantine - ignoring.             LocationServices              22/06/2011 09:47:15                912 (0x0390)
Current AD site of machine is RuV-IE-Dublin        LocationServices              22/06/2011 09:47:15        4900 (0x1324)
Current AD site of machine is RuV-IE-Dublin        LocationServices              22/06/2011 09:47:15        4900 (0x1324)
Attempting to retrieve local MP from AD              LocationServices              22/06/2011 09:47:15        4900 (0x1324)
Current AD site of machine is RuV-IE-Dublin        LocationServices              22/06/2011 09:47:15        4900 (0x1324)
Retrieved local Management Point from AD: IEDUBAPP001.RUV.IE          LocationServices              22/06/2011 09:47:15        4900 (0x1324)
Unknown task LSProxyMPModificationTask in non-quarantine - ignoring.             LocationServices              22/06/2011 09:48:15                2108 (0x083C)
Current AD site of machine is RuV-IE-Dublin        LocationServices              22/06/2011 10:09:35        5752 (0x1678)
Failed to send Location Request Message            LocationServices              22/06/2011 10:09:35        5752 (0x1678)
Failed to create Location Request Message body              LocationServices              22/06/2011 10:09:35        5752 (0x1678)
Executing Task LSRefreshLocationsTask LocationServices              22/06/2011 10:27:28        4900 (0x1324)
Current AD site of machine is RuV-IE-Dublin        LocationServices              22/06/2011 11:09:35        4900 (0x1324)
Failed to send Location Request Message            LocationServices              22/06/2011 11:09:57        4900 (0x1324)
Failed to create Location Request Message body              LocationServices              22/06/2011 11:09:57        4900 (0x1324)

Share this post


Link to post
Share on other sites

this line from the sample log shown, got my attention , as i was of the impression it uses the custom port i already set during install and setup of 51808 not 80

[CCMHTTP] HTTP ERROR: URL=http://IEDUBAPP001/sms_slp/slp.dll?site&sc=RVI, Port=80, Protocol=http, SSLOptions=0, Code=0, Text=CCM_E_BAD_HTTP_STATUS_CODE

 

i checked iis for that /SMS_slp/ virtual dir and it only exists on the SMSWEB site

 

I also noticed a eecondary issue - reporting the /SMSReporting_RVL is under the default site and not the SMSWEB. but we'll leave that one for another post once we get this issue resolved.

 

IIS 7 Sites :

 

Default : 5080

Operations Manager: 51908

SMSWEB : 51808 /51809 (http/https)

WSUS Admin : 8530 /8531

Share this post


Link to post
Share on other sites

Update : I have added the s-sscm-admin service account already to my A_workstationAdmins and A_ServerAdmins which are memeber of the Local Administrators Group in each server /workstation.

 

so as this was not working and i saw reference in ccm.log on sscm server to attempting use Machine Account and on another article someone sugggested trying adding the \\SSCMSERVER as Computer object into the relevant Group, I added mine in to the A_xxxAdmins group in Active Directory and now the ccm.log is hsowing successful connections.

 

going forward this is probably not wise to leave a machine account in their as if ever some thing bad got on to my Maanagement Server (SCCM, SCOM, Vmware VCS) it could potentiall have system wide access to the entire server and workstation environment.

 

any ideas on why the explicitily set domain account didnt work ?

Share this post


Link to post
Share on other sites

Since making the Machine Account for my SCCMServer a member of the relvant Domain Groups that control Local Admin access i can see the previous Admin$ authentication issue is now gone.

 

but still dont see the Collection list showning Client = Yes

 

 

======>Begin Processing request: "EQKRTRRZ", machine name: "IEDUBPC010"	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:00	9920 (0x26C0)
---> Trying the 'best-shot' account which worked for previous CCRs (index = 0x0)	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:00	9920 (0x26C0)
---> Attempting to connect to administrative share '\\IEDUBPC010.ruv.ie\admin$' using account 'ruv\s-sccm-admin'	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:00	9920 (0x26C0)
---> The 'best-shot' account has now succeeded 78 times and failed 39 times.	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:00	9920 (0x26C0)
---> Connected to administrative share on machine IEDUBPC010.ruv.ie using account 'ruv\s-sccm-admin'	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:00	9920 (0x26C0)
---> Attempting to make IPC connection to share <\\IEDUBPC010.ruv.ie\IPC$>	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:00	9920 (0x26C0)
---> Searching for SMSClientInstall.* under '\\IEDUBPC010.ruv.ie\admin$\'	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:00	9920 (0x26C0)
Received request: "EVSRNSKM" for machine name: "IEDUBPC011" on queue: "Incoming".	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:00	8896 (0x22C0)
Stored request "EVSRNSKM", machine name "IEDUBPC011", in queue "Processing".	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:00	8896 (0x22C0)
---> System OS version string "6.1.7601" converted to 6.10	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:01	9920 (0x26C0)
---> Mobile client on the target machine has the same version, and 'forced' flag is turned on.	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:01	9920 (0x26C0)
---> Creating \ VerifyingCopying exsistance of destination directory \\IEDUBPC010\admin$\ccmsetup.	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:01	9920 (0x26C0)
---> Copying client files to \\IEDUBPC010\admin$\ccmsetup.	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:01	9920 (0x26C0)
---> Copying file "d:\Program Files (x86)\Microsoft Configuration Manager\bin\I386\MobileClient.tcf" to "\\IEDUBPC010\admin$\ccmsetup\MobileClient.tcf"	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:01	9920 (0x26C0)
---> Created service "ccmsetup" on machine "IEDUBPC010".	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:02	9920 (0x26C0)
---> Started service "ccmsetup" on machine "IEDUBPC010".	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:02	9920 (0x26C0)
---> Deleting SMS Client Install Lock File '\\IEDUBPC010.ruv.ie\admin$\SMSClientInstall.RVL'	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:02	9920 (0x26C0)
---> Completed request "EQKRTRRZ", machine name "IEDUBPC010".	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:02	9920 (0x26C0)
Deleted request "EQKRTRRZ", machine name "IEDUBPC010"	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:02	9920 (0x26C0)
<======End request: "EQKRTRRZ", machine name: "IEDUBPC010".	SMS_CLIENT_CONFIG_MANAGER	22/06/2011 15:18:02	9920 (0x26C0)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...