Jump to content

  • 0
James Troy

OSD task cannot write to RunOnceEx registry if run from USB




I need to run a setup program at the end of OSD cycle (when administrator logs in the next time). I've setup a vbs to create the necessary entries in HKLM\Software\Microsoft\Windows\CurrentVersion\RunOnceEx.


If I run the OSD task via network deployment, it all works fine. Registry was created and the setup was executed during next sign in.


The same task sequence is then exported to USB media.


However, the OSD task failed to write to the registry if I perform deployment via USB media. I've re-confirmed by adding a simple "reg export" to the end of the batch script.


In network deployment, I can see the registries created properly, but in USB deployment the system only created the key but no value.


This is the same whether if I run the task using "Install Software" method or Run Command line method.


Any help will be greatly appreciated as this has been holding me back from deploying machines for the past 2 weeks and I've googled all that I could google.


Thanks and Regards


Share this post

Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.