Jump to content


using SCCM 2012 RC in a LAB - Part 11. Adding the Reporting Services Point role

Recommended Posts



Had the same problem with the error that the reporting services are not available. On the SQL Reporting manager, I Changed the Management and Reporting URLs to Host header and added the FQDN of the server. Then removed and re-added the Reporting Role.



Share this post

Link to post
Share on other sites

I too had the issue where the reports worked directly on my SCCM server but not from a remote console. I was able to correct this issue by examining the SmsAdminUI.log. I noticed that every time i tried to open the Reports tool it logged:



[6, PID:4576][08/02/2013 17:05:14] :[ORLSCCM01.zerochaos.local] : The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.

So what I did was open the SSRS Report Server page from my SQL 2012 Server and export the self-signed certificate it used to secure the Reporting Server page. I then imported it into my PC's Trusted Root Certification Authorities and it worked correctly after that. To correct the issue I would recommend that you install a certificate in the SSRS Config Console that your workstations already trust, like from an internal CA.

Share this post

Link to post
Share on other sites

I am trying to create reports. I got as far as "click on the Properties Tab followed by New Role Assignment" in IE.


However i do not see "Properties Tab". I am on SCCM2012 R2. Did the view changed? If so, then where are the Properties Tab? Or i am missing something?


Thank you,

Share this post

Link to post
Share on other sites

• Reporting Services Point role installs correctly and you are able to access the Web Service URL, but not the Report Manager URL
• When accessing the Report Manager URL, you receive an Internal Server Error (HTTP 500)
• No reports show up in the Configuration Manager Console
• The ssrp.log shows the following every minute after deployment:
Set configuration
Check state
Check server health
Successfully created srsserver
Reporting Services URL from Registry
Reporting Services is running
Retrieved datasource definition from the server
Confirmed version [11.0.3128.0] for the Sql Srs Instance
Retrieved datasource definition from the server
Updating data source
(!) SRS root folder was reported missing
Failures reported during periodic health check by the SRS Server
:blink: I banged my head on this for a while, but finally resolved it. :D
Check the ReportServerService logs in your SQL folder (Microsoft SQL Server\MSRS11.MSSQLSERVER\Reporting Services\LogFiles). I saw the following:

System.InvalidOperationException: This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.
We run a secure environment with the following GPO setting enabled:
Policy Setting System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing Enabled
This policy effectively breaks SSRS.
Here is the fix:
• Run notepad with administrative credentials
• Open the Reporting Services Web.config file (Microsoft SQL Server\MSRS11.MSSQLSERVER\Reporting Services\ReportManager)
• Scroll through the file to find the <system.web> section
• Add the following line within this section:
<machineKey validationKey="AutoGenerate,IsolateApps" decryptionKey="AutoGenerate,IsolateApps" validation="3DES" decryption="3DES"/>
• Save the Web.config file and close notepad
• Open the Reporting Services Configuration Manager and connect to the Report Server Instance
• Stop and Start the Report Service

Sure enough, no more HTTP 500 error! :D


Hope this helps anyone else who is having this issue.

  • Like 1

Share this post

Link to post
Share on other sites



I having problem to configure the reporting service in SCCM 2012. After setup reporting service point in SCCM 2012, my report list still show empty and the configuration folder below does not create at my SQL report manager URL






I tried re-do this few step many times but none of it works. Hope that you can give me some idea why this happen, thanks.



Share this post

Link to post
Share on other sites

I am having an issue with Reporting. When I go to Monitoring and then reports on my console, located on my SCCM server, all the reports show up. When I go to look at the reports on a remote console (with the same user) I do not have any reports showing. So I tried to go into the Report Options and select a default report server I get the following error message:


"There is a problem connecting to the specified reporting server. Please check the connection and make sure SQL reporting service is running on the specified server."



I am not sure what might be causing this problem. Also, in our environment we I have the SQL on it's own machine, I can get to the Reporting by going through IE, and we have Windows Firewall turned off. Any ideas as to what may be the cause?

Hi there, I have the exact same issue, and I cannot figure it out.. :( have you sorted out something yet?

Thank you

Share this post

Link to post
Share on other sites

I've got the Reporting working well thanks to you. Do you know of a good site to teach us how to create reports? I'd also like to be able to filter the results of one of the canned reports. When I run the 'Compliance history of a configuration baseline', I get multiple computers showing up. I'd like to filter out the older entries and keep only the most recent status.


Thanks again for the great series.

I'm off to view your Compliance instructions.


Share this post

Link to post
Share on other sites



I'm Trying to install reporting services point SCCM 2012, I configured the site system role without problems, but when I tried to configure the report options I get this error:


"There is a problem connectiong to the specified reporting, please check the conection and make sure SQL Reporting Service is running on the especified server. "


The reporting service is running on remote server, I'm using SQL SERVER 2008 r2 Sp2.


When users are added or user rights are modified on the report folder by using Reporting Services Report Manager, Configuration Manager doesn't do nothing, if I use a new reporting instance with no user added, everything works OK, create security roles and add user to report folders.


firewall is turn off in both servers, the SSRS version is 10.50.4000.0


Any Idea?

Share this post

Link to post
Share on other sites

I had to create a Report DB in SQL as it didnt seems to create it i then linked that in report services, problems i have is i open IE as admin then http://FQDN/reportsand get a 404 error, if i open FQDN/ReportServer it works and i can access it. Not sure if something in IIS is missing maybe?






Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...