Jump to content

Sign in to follow this  

Cant deploy image to Dell Optiplex 745 - mass storage

Recommended Posts



as the subject suggests im struggling to deploy XP sp3 x86 to an Optiplex 745 because of mass storage drivers.


I can happily deploy the same XP image to other Optiplex such as the 755 or 760 and inject their mass storage drivers because their drivers are available as a download from Dells website. The 745 drivers are built in Windows. When I put an image on a 745 SCCM is obviously making XP look in a different folder for drivers then the central windows drivers and doesnt find anything and I get the BSOD.



The above URL shows a list of mass storage drivers for Optiplex but if you see the text the 745 isnt listed as the drivers are on the xp cd.



I have also tried the XP Desktop combo drivers in the URL above. I've been through every driver in the list and nothing works.


I have even tried creating a sysprep.inf file containing only the below text and adding it into the "Apply Operating System" section of the task sequence.





I have also tried a program such as "Driver Magician Lite" to backup the mass storage drivers from a functioning 745. I can import the backed up drivers into SCCM but when I try to add them to the task sequence the drop down menus are empty unlike other mass storage drivers I've done in the past.


If I put an XP sp3 cd in the drive and manually install it will work fine.


This has been slowly driving me crazy the last few months. Optiplex 755 and upwards = fine. I imagine I'd also have trouble with an Optiplex GX620 which would also be included in Windows but I havent tried yet.


Somebody please save me from this madness.

Share this post

Link to post
Share on other sites

It's been awhile, but I thought there was some sort of BIOS adjustment for the hard drive that needed to be made on some of the Dell models. Like I said, it's been awhile since I've done XP, but poke around in the BIOS settings and see if that helps (make a note to write down the current settings so you can reset things when you're done)...

Share this post

Link to post
Share on other sites

You might boot up with your WinPE SCCM boot disc and (if you have command support enabled) press F8 and use the DISKPART command to wipe out the existing partitions. I've seen some oddities where the drive needed to be repartitioned and formatted. Also, make sure you're running the latest BIOS from Dell...

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...