Jump to content


Sign in to follow this  
itdept@sparta.org

Deploying Office 2010 as part of OSD Task Sequence

Recommended Posts

I have created an application for office 2010 using the OCT tool and I am able to install this application from the command line as well as from software center. When I try and deploy it as part of a task sequence it copies the files to the ccmcache folder in windows and even starts setup.exe. I have verified that setup.exe is running in task manager. The problem I run into is that it never installs anything using this method. No file structure in program files (x86) and it just sits there installing 1 of 1 programs. It times out after the 120 minute period that I have setup for the install per a few forums I have read. Below is the setup log for the application from c:\windows\temp

 

 

PERF: TickCount=361360 Name=OBootStrapper::Run Description=Begin function

Operating System version: 6.1.7601 Service Pack 1. Platform ID: 2

Running 32-bit setup on a 64-bit operating system.

Command line: "C:\Windows\ccmcache\1\setup.exe"

No command line arguments given

Parsing config.xml at: config.xml

Preferred product specified in config.xml to be: PROPLUS

Verify file signature in "C:\Windows\ccmcache\1\setup.exe"

C:\Windows\ccmcache\1\setup.exe is trusted.

Verify file signature in "C:\Windows\ccmcache\1\ProPlus.WW\OSETUP.DLL"

C:\Windows\ccmcache\1\ProPlus.WW\OSETUP.DLL is trusted.

Using setup controller dll at [C:\Windows\ccmcache\1\ProPlus.WW\OSETUP.DLL].

PERF: TickCount=361766 Name=OBootStrapper::Run Description=Calling RunSetup

 

PERF: TickCount=361766 Name=RunSetup Description=Begin function

Catalyst execution began: 04/27/2012 13:56:47.

Parsing config.xml at: config.xml

Preferred product specified in config.xml to be: PROPLUS

Setupexe Resiliency Mode is set to [PerformIfApplicable]; thus Resiliency is [disabled] for the [installExecutionMode]

Searching for updated versions of resource files under the 'updates' folder [C:\Windows\ccmcache\1\updates].

Found [0] resource files under the update folder.

Searching for default versions of resource files under the folder [C:\Windows\ccmcache\1].

Found [1] resource files under the default folder.

Running in [installExecutionMode]. Run from TEMP folder at [C:\Windows\TEMP\Setup000004f0].

Loaded resource file [C:\Windows\TEMP\Setup000004f0\OSETUPUI.DLL] (CultureTag=en-US).

Loaded Dll : C:\Windows\ccmcache\1\ProPlus.WW\OSETUP.DLL.

Catalyst version is : 14.0.4755.1000

JobExecutionMode is InstallExecutionMode.

Check if Office is supported on Windows 6.1.7601

Checking if CLSID_DOMDocument60 can be created.

Checking the version of MSXML6.

MSXML version check passed. Minimum required version is [6.10.1129], installed Version is [6.30.7601.17514].

LIS: start parsing setup xml

LIS: finished parsing LIS package "{90140000-0117-0409-0000-0000000FF1CE}"

LIS: start parsing setup xml

LIS: finished parsing LIS package "{90140000-0016-0409-0000-0000000FF1CE}"

LIS: start parsing setup xml

LIS: finished parsing LIS package "{90140000-00BA-0409-0000-0000000FF1CE}"

LIS: start parsing setup xml

LIS: finished parsing LIS package "{90140000-0044-0409-0000-0000000FF1CE}"

LIS: start parsing setup xml

LIS: finished parsing LIS package "{90140000-0115-0409-0000-0000000FF1CE}"

LIS: start parsing setup xml

LIS: finished parsing LIS package "{90140000-0116-0409-1000-0000000FF1CE}"

LIS: start parsing setup xml

LIS: finished parsing LIS package "{90140000-00A1-0409-0000-0000000FF1CE}"

LIS: start parsing setup xml

LIS: finished parsing LIS package "{90140000-001A-0409-0000-0000000FF1CE}"

LIS: start parsing setup xml

LIS: finished parsing LIS package "{90140000-0018-0409-0000-0000000FF1CE}"

LIS: start parsing setup xml

LIS: finished parsing LIS package "{90140000-002C-0409-0000-0000000FF1CE}"

LIS: start parsing setup xml

LIS: finished parsing LIS package "{90140000-0011-0000-0000-0000000FF1CE}"

LIS: start parsing setup xml

LIS: finished parsing LIS package "{90140000-0019-0409-0000-0000000FF1CE}"

LIS: start parsing setup xml

LIS: finished parsing LIS package "{90140000-0010-0409-0000-0000000FF1CE}"

LIS: start parsing setup xml

LIS: finished parsing LIS package "{90140000-001B-0409-0000-0000000FF1CE}"

Product: PROPLUS

AddOnGroup Culture: en-us

AddOnId: WORD.EN-US

AddOnId: OFFICE.EN-US

AddOnId: PUBLISHER.EN-US

AddOnId: ACCESS.EN-US

AddOnId: INFOPATH.EN-US

AddOnId: ONENOTE.EN-US

AddOnId: PROOFING.EN-US

AddOnId: OFFICE64.EN-US

AddOnId: OUTLOOK.EN-US

AddOnId: GROOVE.EN-US

AddOnId: EXCEL.EN-US

AddOnId: POWERPOINT.EN-US

 

 

It never gets past this point. I am at a total loss.

Share this post


Link to post
Share on other sites

Running just setup.exe shuold be fine ive done it before. Make sure you set the right "experience" or whatever its called on the page where you set product key. Select the one with absolutely no interaction. And also make sure you check the "install from task sequence without being advertised"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...