Jump to content

  • 0

SCCM/MDT - PXE Boot not working


Hi there.

Looking for some advise regarding Windows 7 deployment & PXE Booting.

Background - we are using sccm 2007 & mdt 2010, and are currently in the middle of a project to migrate our OS to Windows 7.

We have a server (sccmbr01) which has been added as an sccm site-system, which contains the OS images & runs the WDS role; within sccm this is configured as a PXE Service Point.

The server had been happily sitting on its own subnet, happily deploying OS images, and providing both DHCP & PXE services.

However, Management have now, in their wisdom, decided to move this server onto the main ip subnet where our general server population are located.

This still worked ok, as long as sccmbr01 was providing dhcp service, with the scope set to a single subnet unused by any other devices.

Our problem at the moment is that we are looking to extend the OSD service - including PXE boot - throughout the organisation, so that we can perform "in situ" rebuilds & refreshes, etc. (estate - approx 5000 pcs, approx 200 subnets, many geographic locations etc).

The Comms team want to configure this so that DHCP for PXE boot/OSD is provided by our regular domain DHCP servers - their argument is that if we extend the DHCP scopes provided by sccmbr01, the addresses will be used up by the general PC population, i.e., this will become just another regular DHCP server on the WAN.

Comms have configured "ip helper" on the routers, etc; however, after several attempts, using different permutations, we have not been able to successfulyl PXE boot client.

When sccmbr01 had dhcp active, the files/paths displayed after F12 network boot were as follows, in order of appearance




We have tried to configure the DHCP servers to point to the above files, without success.

\smsboot\x64\pxeboot.com - launches "Windows Boot Manager" console, with the following error -

"file - \bbot\bcd

status - 0xc000000f

info - an error occurred while attempting to read the boot configuration data"

\smsboot\boot.sdi - displays error "too big to fit in memory"

\smsimages\smspkg\pr10022b\winpe.pr10022b.wim - displays TFTP error

When we leave DHCP unconfigured, using only IP Helper (this seems to be the recommended method), an error 53 (boot file not found) is displayed.

Do you have any suggestions what we could try next, or something we may be missing?

I found this thread which seems to be quite similar:


Any suggestions would be gratefully sppreciated.



Share this post

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0


I now have this working.

The DHCP servers are configured to point to \smsboot\x64\wdsnbp.com


However, this kept displaying an error:

TFTP download \smsboot\x64\abortpxe.com

PXEBoot aborted


I found this link on another forum which seemed to do the trick:



the "clear last PXE advertisement" option seems to be a bit flaky. I deleted the TS advert, reset the "clear last PXE..." flag, then re-advertised the TS.


The PC is now booting from PXE and successfully having Windows 7 deployed.





  • Like 1

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.